×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Sep 2007
    Posts
    4

    [new thread] Installing S60 3rd Edition FP2 v1.1 on Vista

    Quote Originally Posted by wizard_hu_ View Post
    If you search for vista in the Wiki and the Blogs, you will find some ideas and a "success story" about using Vista for S60 development.
    When I am trying to install Series 60 SDK - 3rd Edition in my Vista homebasic then I found that -
    "WINDOWS VISTA USERS::Please find the GCCE patch for MSVISTA
    in\C:\S60\devices\S60_3rd_FP2_SDK_v1.1\plugins\vistapatch".Being a new person I could not found how I can make the GCCE patch for MSVISTA in\C:\S60\devices\S60_3rd_FP2_SDK_v1.1\plugins\vistapatch and again when I am trying to install PythonForS60 1.4.4 SDK 3rdEd. zip then I found that the application has failed to start because CHARCONV.dll for python_launcher.exe and APPARC.dll for python.exe was not found.Re-installing the application may fix the problem.Any one can help me please?

    Thanks in advance

    ALTAF

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Series 60 SDK - 3rd Edition

    Let's take this one problem at the time.

    You have been instructed by the installer to install a GCCE compiler patch from a specified location? Have you found the patch files? If so, what have you done with them?

    I'm going to move this to a new thread, the title/subject of the original thread is confusing.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  3. #3
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: [new thread] Installing S60 3rd Edition FP2 v1.1 on Vista

    Here's what the SDK release notes have to say about the issue:

    ...
    Microsoft Windows Vista operating-system-specific known issues
    --------------------------------------------------------------
    The S60 3rd Edition SDK for Symbian OS, Feature Pack 2 v1.1 works on Microsoft Windows Vista Business, with the following known limitations:

    - ARMV5 support is not available for Vista.
    - Build for GCCE target fails on Vista. Compilation for GCCE from command line and Carbide.C++ needs the following modifications:

    There is a patch available to enable compilation for GCCE target over command line at C:\<SDK_Installation_directory>\Plugins\vistapatch.
    Please refer to the help.txt file available with the package for instructions.

    However, to build via Carbide.c++, an extra step is needed in addition to replacing the cl_bpabi.pm file provided in the package.

    Add the following to the system PATH variable (through Control Panel->System->Advanced system settings) in the following order:
    C:\Program Files\CSL Arm Toolchain\bin;C:\Program Files\CSL Arm Toolchain\arm-none-symbianelf\bin;C:\Program Files\CSL Arm Toolchain\libexec\gcc\arm-none-symbianelf\3.4.3;C:\Program Files\Common Files\Symbian\tools.

    Restart the system for changes to take effect. Note that CSL Arm Toolchain needs to be installed to C:\Program Files\CSL Arm Toolchain for the patch to work.

    - Audio might cause panics at the end of play. This has no functional impact.
    ...
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  4. #4
    Registered User
    Join Date
    May 2010
    Posts
    15

    Re: [new thread] Installing S60 3rd Edition FP2 v1.1 on Vista



    why ?
    Last edited by 5800XM_VN; 2010-05-21 at 17:56.

  5. #5
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: [new thread] Installing S60 3rd Edition FP2 v1.1 on Vista

    Why what? ;)
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

Similar Threads

  1. Configuring S60 3rd Edition FP2 SDK for MIDP for NetBeans
    By CodeRed in forum Mobile Java General
    Replies: 4
    Last Post: 2008-04-24, 14:21
  2. S60 3rd Edition SDK FP2 Installation
    By AbrahamDavid in forum Symbian Tools & SDKs
    Replies: 4
    Last Post: 2008-04-03, 10:55
  3. Is S60 3rd Edition FP2 Available?
    By premsharma in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2007-07-17, 09:43
  4. What is going on with Vibration on S60?
    By amd_rikus in forum Mobile Java General
    Replies: 3
    Last Post: 2006-06-16, 00:29
  5. Installing S60 2nd edition FP2 for Visual Studio 2003
    By doctordwarf in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2005-04-29, 16:26

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×