×

Discussion Board

Results 1 to 9 of 9
  1. #1
    Registered User
    Join Date
    Aug 2008
    Location
    Gurgaon, India
    Posts
    155

    Unhappy Emulator Terminates....

    Hi All,

    I have made an application, which builds fine and emulator starts up. But at the time of finally launching the application, emulator terminates without any message.

    Can anyone solve this problem?

    Thanks in advance.
    Vineet Billorey "The Great"

  2. #2
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Emulator Terminates....

    check your %temp%\epocwind.out for error messages.

  3. #3
    Registered User
    Join Date
    Aug 2008
    Location
    Gurgaon, India
    Posts
    155

    Unhappy Re: Emulator Terminates....

    Sorry SKumar,

    I could not search the file epocwind.out in my S60 installation folder.
    Vineet Billorey "The Great"

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,697

    Re: Emulator Terminates....

    Because it is not there, it is in your Temp folder, %temp% abbreviates that
    Try: Windows+R, notepad %temp%\epocwind.out, Enter

  5. #5
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Emulator Terminates....


  6. #6
    Registered User
    Join Date
    Aug 2008
    Location
    Gurgaon, India
    Posts
    155

    Unhappy Re: Emulator Terminates....

    Sorry,
    It is a very long file, but I m pesting last few lines of the error message:
    Code:
        76.605	Thread vcommandmanager::MMFControllerProxyServer- created @ 0x261cf7c - Win32 Thread ID 0x120
        76.635	TeUtl: ECN.HandleCallBack.<
        76.635	TeUtl: ECN.DoHandleCallBack.<
        76.635	TeUtl: ECN.DoHandleCallBack.>
        76.635	TeUtl: ECN.HandleCallBack.>
        76.635	CDRMClock::TimeChanged
        76.635	CDRMClock::TimeChanged ok
        76.815	[<SRSF>] [Error!] CVCommandManager::ParseAllFilesFromDirectoryL(const TDesC16 &) CVCommandManager::ParseAllFilesFromDirectoryL - GetDir returns [-12] [F:Vcommandmanager.cpp][L:175][TId:207]
        76.820	Thread vcommandmanager::MMFControllerProxyServer- created @ 0x261a158 - Win32 Thread ID 0xd50
        76.845	TeUtl: ECN.HandleCallBack.<
        76.845	TeUtl: ECN.DoHandleCallBack.<
        76.845	TeUtl: ECN.DoHandleCallBack.>
        76.845	TeUtl: ECN.HandleCallBack.>
        76.850	CDRMClock::TimeChanged
        76.850	CDRMClock::TimeChanged ok
        76.850	[<SRSF>] [Error!] CContextProvider::CreateVCommandContextLC() CContextProvider::CreateVCommandContextLC SaveContext call failed [F:Contextprovider.cpp][L:99][TId:207]
        76.850	Thread vcommandmanager::VCManagerThread Killed -39
        76.855	TeUtl: ECN.HandleCallBack.<
        76.855	TeUtl: ECN.DoHandleCallBack.<
        76.855	TeUtl: ECN.DoHandleCallBack.>
        76.855	TeUtl: ECN.HandleCallBack.>
        76.855	CDRMClock::TimeChanged
        76.855	CDRMClock::TimeChanged ok
        76.890	Thread ChatBox_0xEAB59D3E.exe::Main created @ 0x2645334 - Win32 Thread ID 0x8f0
        76.905	Thread ChatBox_0xEAB59D3E.exe::ChatBox_0xEAB59D3E Killed -1
    Vineet Billorey "The Great"

  7. #7
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,697

    Re: Emulator Terminates....

    I would guess that you directly execute ChatBox_0xEAB59D3E.exe (so you do not click in the emulator to Installations, then your icon), that is why it shuts down the emulator on exiting.
    That -1 at the end is probably about that something is missing somewhere: http://wiki.forum.nokia.com/index.php/Error_codes
    You may try enabling Just In Time debugging in the emulator preferences, then start your code with the debugger and it will probably show where the problem occurs.

  8. #8
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,345

    Re: Emulator Terminates....

    Quote Originally Posted by vineetbillorey View Post
    Hi All,

    I have made an application, which builds fine and emulator starts up. But at the time of finally launching the application, emulator terminates without any message.

    Can anyone solve this problem?

    Thanks in advance.
    Check this article and read it thoroughly: Running the emulator from Carbide.c++
    Nokia Developer Wiki Moderation team

  9. #9
    Registered User
    Join Date
    Aug 2008
    Location
    Gurgaon, India
    Posts
    155

    Thumbs down Re: Emulator Terminates....

    Thanks All,

    I deleted the old project, created again and copied the previous code to it. Now it is running fine.
    Vineet Billorey "The Great"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×