×

Discussion Board

Results 1 to 9 of 9
  1. #1
    Registered User
    Join Date
    Sep 2008
    Posts
    12

    Question "Unable to install" on some s60 handsets

    Hello there,
    I've done a J2ME MIDlet and it works fine on my E65. But I tried sending it to a friend to try it on her N81 8Gb and she says she gets "Unable to install" after Preparing to install step.
    I've hacked my E65 long ago so it can install unsigned MIDlets.

    E65 is: v9.1 , S60v3 (initial release), MIDP 2.0, CLDC 1.1
    N81 8Gb is: v9.2, S60v3 FP1, MIDP 2.0, CLD 1.1

    and the rest specs are the same.

    I wonder what causes this ? is it the signing or the OS version ?
    Thanks for your time.

  2. #2
    Super Contributor
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,191

    Re: "Unable to install" on some s60 handsets

    If the MIDlet is signed MIDlet, what certificate are you using for signing?
    (remove the signing information and try to install... does it work?)

    Hartti

  3. #3
    Registered User
    Join Date
    Sep 2008
    Posts
    12

    Re: "Unable to install" on some s60 handsets

    Hi Hartti,
    No i haven't done anything about signing this application.
    Btw, by googling I found some similar cases about themes, midlets and other stuff and there were some odd solutions like removing memory card while installing or using data transfer mode instead of Nokia PC Suite installer and all.
    p.s.: and her App. Manager settings are as mine: Software installation => All, Online certif. check => Off
    Last edited by parsa28; 2008-10-03 at 20:33.

  4. #4
    Registered User
    Join Date
    Sep 2008
    Posts
    12

    Re: "Unable to install" on some s60 handsets

    I'm so worried about this cuz she's able to install my other MIDlets.
    Any ideas ?

  5. #5
    Super Contributor
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,191

    Re: "Unable to install" on some s60 handsets

    What are the contents of the JAD file and what APIs are you using the in MIDlet?

    Hartti

  6. #6
    Registered User
    Join Date
    Sep 2008
    Posts
    12

    Re: "Unable to install" on some s60 handsets

    Hi Hartti,
    The jad file is:
    Code:
    MIDlet-Name: MyApp
    MIDlet-Version: 1.0.1
    MIDlet-Vendor: MyName
    MIDlet-Jar-URL: MyApp.jar
    MIDlet-Jar-Size: 171885
    MIDlet-Description: MyApp
    MIDlet-Icon: /myapp.png
    MIDlet-Info-URL: http://www.mydomain.com
    MIDlet-1: MyApp,/myapp.png,myclass
    All the info matches the manifest file.
    But I found that when I bluetooth the file everything's fine ...I had sent the file over Yahoo messenger when the error occured.
    I'm actually going to put it on my own website for public download so what might be causing the problem ?

  7. #7
    Registered User
    Join Date
    Sep 2008
    Posts
    12

    Re: "Unable to install" on some s60 handsets

    Hey there,
    Unfortunately the problem still exists. i'm going crazy!
    When sending the MIDlet via bluetooth everything's fine.
    But when downloading it from the web, it says "Unable to install"(On N81 8GB) or "Invalid jar file"(On E65) or "Invalid application" (On 6300)
    Please, someone , any clue ?

  8. #8
    Regular Contributor
    Join Date
    Mar 2008
    Posts
    51

    Re: "Unable to install" on some s60 handsets

    can u deploy ur midlet with specific SDK ? i think E65 and N81 is defferent edition, but u can check it in this site,,

    may it help

    -regards-
    adek aidi

  9. #9
    Super Contributor
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,191

    Re: "Unable to install" on some s60 handsets

    Do you have the right MIME-type definitions on your server for JAR and JAR files?
    Can you also check from the manifest file inside JAR file and find out the value of these attributes
    # MicroEdition-Profile
    # MicroEdition-Configuration

    Those should be 2.0 and 1.1 respectively

    Hartti

Similar Threads

  1. "Unable to install" error
    By vnleeds in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 7
    Last Post: 2008-11-14, 05:32
  2. InputStream.skip() problem on S60 handsets
    By psycohk in forum Mobile Java General
    Replies: 3
    Last Post: 2007-11-16, 08:41
  3. Mail Sync for S60 / S60 3rd Devices
    By bmenke in forum PC Suite API and PC Connectivity SDK
    Replies: 4
    Last Post: 2006-09-17, 06:24
  4. "Unable to install" after changing UID3
    By cwhite124 in forum Symbian
    Replies: 8
    Last Post: 2006-07-10, 15:04

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×