×

Discussion Board

Results 1 to 3 of 3

Thread: emulator error

  1. #1
    Registered User
    Join Date
    Feb 2005
    Posts
    3

    emulator error

    Hi,

    i'm using Netbeans 6.1 and when i try to run an mobile project, i got an exception like above and the emulator disappears:

    Exception in thread "EventQueueMonitor-ComponentEvtDispatch" java.lang.UnsatisfiedLinkError: no sljava in java.library.path
    at java.lang.ClassLoader.loadLibrary(Unknown Source)
    at java.lang.Runtime.loadLibrary0(Unknown Source)
    at java.lang.System.loadLibrary(Unknown Source)
    at com.protocom.sso.javasso.SSOLoginScriptRunner.<clinit>(SSOLoginScriptRunner.java:2067)
    at com.protocom.sso.javasso.JavaSSOJobMgr.<init>(JavaSSOHook.java:180)
    at com.protocom.sso.javasso.JavaSSOHook.guiInitialized(JavaSSOHook.java:270)
    at com.sun.java.accessibility.util.EventQueueMonitor.maybeNotifyAssistiveTechnologies(EventQueueMonitor.java:228)
    at com.sun.java.accessibility.util.ComponentEvtDispatchThread.run(EventQueueMonitor.java:631)


    anyone can help me

  2. #2
    Nokia Developer Expert
    Join Date
    Aug 2007
    Posts
    1,595

    Re: emulator error

    Hello calikus,

    i got an exception like above and the emulator disappears
    Which emulator are you referring to?

    Regards,
    r2j7
    [URL="http://library.forum.nokia.com/java"][B] >>> Java Developer's Library <<<[/B][/URL]
    [URL="https://www.developer.nokia.com/Resources/Support/Technical_support.xhtml"] [B]>>> Technical Support for Java ME development <<<[/B][/URL]
    [URL="https://publish.ovi.com/info/"][B]>>> Nokia Publish: reach millions of Nokia users worldwide through Nokia Store <<<[/B][/URL]

  3. #3
    Regular Contributor
    Join Date
    Mar 2008
    Posts
    51

    Re: emulator error

    Quote Originally Posted by calikus View Post
    Hi,

    i'm using Netbeans 6.1 and when i try to run an mobile project, i got an exception like above and the emulator disappears:

    Exception in thread "EventQueueMonitor-ComponentEvtDispatch" java.lang.UnsatisfiedLinkError: no sljava in java.library.path
    at java.lang.ClassLoader.loadLibrary(Unknown Source)
    at java.lang.Runtime.loadLibrary0(Unknown Source)
    at java.lang.System.loadLibrary(Unknown Source)
    at com.protocom.sso.javasso.SSOLoginScriptRunner.<clinit>(SSOLoginScriptRunner.java:2067)
    at com.protocom.sso.javasso.JavaSSOJobMgr.<init>(JavaSSOHook.java:180)
    at com.protocom.sso.javasso.JavaSSOHook.guiInitialized(JavaSSOHook.java:270)
    at com.sun.java.accessibility.util.EventQueueMonitor.maybeNotifyAssistiveTechnologies(EventQueueMonitor.java:228)
    at com.sun.java.accessibility.util.ComponentEvtDispatchThread.run(EventQueueMonitor.java:631)


    anyone can help me
    it seems ur path for JAVA is missing or u move that ?
    can u check ur java platform seeting at Tools > java platform setting. check if the java path and emulator is correct also.

    may it help

    -regards-
    Adek aidi

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×