×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Dec 2007
    Posts
    7

    A problem about Http POST

    There is a problem occurs when I testing my application which uses HTTP POST method to send the information to server on the mobilephone(n95),when this application was running on the emulator,it is right, the server can receive the HTTP package like this:

    POST / HTTP/1.1
    Host: localhost
    Accept: text/*
    User-Agent: MyBlog(1.0)
    Content-Length: 9
    Content-Type: text/plain

    Name=Wang

    this is what I expected, but when I test on the mobliephone(useing WLAN to connect with the server which is running on the notebook and is connecting with same AP),the server can't receive the right package like this:

    POST / HTTP/1.1
    Host: 192.168.0.110
    Accept: text/*
    User-Agent: WebClient 1.0
    Content-Length: 9
    Content-Type: text/plain
    X-Nokia-MusicShop-Version: 1.0.0
    X-Nokia-MusicShop-Bearer: WLAN

    that is the body part of HTTP package disappeared,but the I can still see Content-Length: 9,and the last two line is automactic appended, so my post method failed like this, please help me, thank a lot

  2. #2
    Super Contributor
    Join Date
    Jul 2006
    Location
    Oulu, Finland.
    Posts
    1,174

    Re: A problem about Http POST

    Does the same happens using GPRS connection?

  3. #3
    Registered User
    Join Date
    Dec 2007
    Posts
    7

    Re: A problem about Http POST

    Thank you for your reply,when I use GPRS,I just can't connect with the server, that means nothing can be received by server, even if the server has a public IP

  4. #4
    Super Contributor
    Join Date
    Jul 2006
    Location
    Oulu, Finland.
    Posts
    1,174

    Re: A problem about Http POST

    Do you have GPRS connection available on your phone, It would be interesting to see how it behaves when you use mobile phone directly, anyway coming back to your question, which package is the right one for you #1 or #2.

  5. #5
    Registered User
    Join Date
    Dec 2007
    Posts
    7

    Re: A problem about Http POST

    My mobliephone have accessed the WAP over GPRS, I can use it to other application like web browse,but for my own application,it can't access the server, I can use WLAN access the server,and the first packet is right for me, the 2nd packet just have no body,the data I want to transfer is in BODY

  6. #6
    Regular Contributor
    Join Date
    Feb 2009
    Posts
    188

    Re: A problem about Http POST

    Hi..

    I have developed a Symbian mobile application for both s60 2nd edition and 3rd edition.

    Final thing is, after installing it to phone, when i start first time, it will ask to enter registration key. then, it should communicate with a web mysql database to verify whether the registration key that is entered by user is correct or not.

    I am beginner in web development. so please help me what to do?


    thanks

  7. #7
    Registered User
    Join Date
    Jul 2009
    Posts
    2

    Exclamation Re: A problem about Http POST

    Hi just one quick question..I have a php page that is rewritable, how symbian C++ can connect and post a data to that page?

Similar Threads

  1. HTTP post file problem
    By lucca99 in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2007-08-28, 15:39
  2. Nokia N70 - HTTP POST problem
    By heuven in forum Symbian Networking & Messaging (Closed)
    Replies: 3
    Last Post: 2007-04-13, 15:48
  3. HTTP Post problem
    By MananW in forum Symbian
    Replies: 1
    Last Post: 2007-02-17, 07:29
  4. Http post problem on different phones
    By tertiusbouwer in forum Mobile Java Networking & Messaging & Security
    Replies: 2
    Last Post: 2006-05-19, 16:02
  5. Nokia 3230 HTTP Post Problem
    By alpyor in forum Symbian
    Replies: 1
    Last Post: 2005-05-13, 04:15

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×