×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Oct 2008
    Posts
    2

    Application terminates abruptly w/o error on every device of S60 3rd Edition FP-2

    This J2ME Application is a Instant-Messenger based on protocol OMA-IMPS having features of chat/picture messaging/sms/call etc. This application is ported to several devices.
    But i am facing critical issue of sudden termination of my application while running on every device belongs to S60 3rd edition FeaturePack-2,example N78, N96, 6210, 6220 etc.

    After launching the midlet, once we try to log-in, application suddenly gets END on any screen without any error/exception and user comes to main menu of the device.

    Stage of termination is not defined and not same, sometimes it terminates when sign-in process is going on, sometimes after fetching contact list, sometimes while doing conversation, or in sending picture...

    I have debugged the code, but no error/exception is caught.
    I have tried to run messging application based on symbian,its running fine.other j2me client-server application is also running fine based on http/socket connections.

    Can anybody help me and suggest what sought of problem are thr in S60 3rd Edi FP-2 Devices???

  2. #2
    Registered User
    Join Date
    Feb 2007
    Location
    India
    Posts
    1,128

    Re: Application terminates abruptly w/o error on every device of S60 3rd Edition FP-2

    Hi friends,

    I am facing same problem in last few days...Please have look below post and suggest me. How to resolve this problem....

  3. #3
    Registered User
    Join Date
    Oct 2008
    Posts
    2

    Smile Re: Application terminates abruptly w/o error on every device of S60 3rd Edition FP-2

    Hi All,

    My problem is solved finally!!
    The problem was with continuous calls to a "synchronized" method.

    Actually, method paint() which was getting executed every time was set as synchronized,
    Like this :
    public synchronized void paint(Graphics g)
    I removed the synchronized keyword and run the application, than no termination happened.

    May be this will help the readers if they stuck with same kind of problem.

    Thanks&Regards,
    Divs

Similar Threads

  1. SyncML API and S60 3rd edition?
    By harri_salminen in forum Symbian Tools & SDKs
    Replies: 4
    Last Post: 2008-03-20, 14:50
  2. RS232 communication with S60 3rd edition device
    By swetha_s in forum Symbian Tools & SDKs
    Replies: 4
    Last Post: 2008-02-23, 16:06
  3. Replies: 3
    Last Post: 2007-07-19, 09:25
  4. remote s60 3rd edition application
    By iulian_moldovan in forum Symbian
    Replies: 1
    Last Post: 2006-11-30, 08:27
  5. Replies: 5
    Last Post: 2006-03-10, 09:28

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×