×

Discussion Board

Results 1 to 10 of 10
  1. #1
    Registered User
    Join Date
    Oct 2008
    Posts
    1

    SDK 5 emulator problem

    I'm using SDK 5.0 to develop program, when I use the emulator, I lock the keypad by accident, then I found I can't unlock the keypad and there are some words on the screen:"Use keyguard switch to unlock screen and keys".

    So I don't know what is "keyguard"? I never install it on the emulator.

    Please help!!!

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Budapest, Hungary
    Posts
    28,569

    Re: SDK 5 emulator problem

    Quote Originally Posted by jerrysf View Post
    "Use keyguard switch to unlock screen and keys".

    So I don't know what is "keyguard"? I never install it on the emulator.
    You do not "install" keys to the emulator, neither on the device. I have not seen 5th edition devices, but many 3rd edition ones have a dedicated switch for locking the keypad. And apparently it is not emulated for now.

  3. #3
    Nokia Developer Expert
    Join Date
    Jun 2008
    Posts
    333

    Re: SDK 5 emulator problem

    s60 5th hardware has a lock key button which can lock or unlock the phone.if this key button can not be found on the emulator,rebooting emulator should resolve your problem.

  4. #4
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,355

    Re: SDK 5 emulator problem

    Go to the emulator window's Tools menu and select Options and then go to the Events tab.
    To unlock the emulator trigger the Grip Open event from the Basic Events group.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  5. #5
    Super Contributor
    Join Date
    Jan 2007
    Location
    Bhubaneswar, India
    Posts
    1,189

    Re: SDK 5 emulator problem

    -------------------------------------
    Thanks & Regards
    Ram
    Symbian OS 9.2/9.3,S60 3rd FP1/FP2,Carbide.c++v2.0

  6. #6
    Registered User
    Join Date
    Apr 2008
    Posts
    1

    Re: SDK 5 emulator problem

    Hi You can delete the following folder
    \epoc32\winscw\data\private\10202be9\persists
    and your keyguard will start working.

    Actually the Keyguard settings are stored in one of the cenreps but I am not sure which one is the actual one. Deleting this folder is actually a sort of factory reset of the phone settings.

  7. #7
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,355

    Re: SDK 5 emulator problem

    I think that my solution (if it really works) is much better. Then once the access restored to the emulator just make sure to disable the autolock from settings.

    There are many things in the central repository and you wouldn't want those deleted just to remove 4 bytes worth of information
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  8. #8
    Registered User
    Join Date
    Dec 2008
    Posts
    1

    Re: SDK 5 emulator problem

    I have same problem.
    Please HELP !

  9. #9
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Budapest, Hungary
    Posts
    28,569

    Re: SDK 5 emulator problem

    Quote Originally Posted by fantomaz View Post
    I have same problem.
    Please HELP !
    Same problem => same solution. Feel free to read the posts in this thread.

  10. #10
    Registered User
    Join Date
    Dec 2008
    Posts
    1

    Re: SDK 5 emulator problem

    Go to Tools->Utilities
    After that Events->Basic Events
    Grip Open -> Click on send button

Similar Threads

  1. Replies: 4
    Last Post: 2008-06-15, 16:02
  2. MIDP applicatyion accessing a servlet not working in series 60 emulator
    By ferozekadamapuzha in forum Mobile Java General
    Replies: 11
    Last Post: 2008-05-07, 18:04
  3. Installing the SDK with Borland C++Builder
    By hrajalin in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2003-10-31, 02:46
  4. Series 60 Concept Emulator (SDK Beta 0.2 Linux) not working
    By mattbee in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2003-06-10, 11:43

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •