×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 22
  1. #1
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    VS 2008 and Carbide.vs

    Hi,

    From the multiple posts we have on VS 2008 related issues, seems Carbide.vs 3.0 can be installed with it. While that this great, do note:

    Carbide.vs 3.0 does not support VS2008 and has not been tested with it. If you choose to use Carbide.vs 3.0 with VS2008, pls be aware of this.

    If you want to help our R&D to possibly at a later date produce a version of Carbide.vs that is 2008 compatible (note again: this is no promise that this will ever happen), you can post VS2008 related issues in this thread.

    Before VS2008 is supported, we will simply note the issues. Pls do not post VS2008 issues as separate threads.

  2. #2
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    VS2008 linker error LNK1318

    Symptom: Linking fails with error:
    Code:
    ... fatal error LNK1318: Unexpected PDB error; ..
    This is a known VS 2008 defect. There is no workaround. MS has reported that it will be fixed in the final product.

  3. #3
    Registered User
    Join Date
    Nov 2007
    Location
    Romania
    Posts
    9

    Re: VS 2008 and Carbide.vs

    OK, maybe my writing was a little confusing on the Carbide.vs 3.0 thread ( I'm not a every day english speaker ).
    So what I was trying to say there is that this linking error is happening on VS 2005 with service pack 1, and I google for the error code and the only entry found was on a bug report for the new VS 2008 Beta2, but nothing for VS 2005.
    So this is not a VS 2008 bug ( maybe the same thing happens on 2008, I don't know )!

    And this linker error occurs with the default setting set by symbian importer tool, an not on every project. On the examples from the SDK it works fine, but on my app which uses other five libs ( compiled also with Carbide.VS 3.0 ) the linker generates that error. If I put the option "Generate Debug Info" to No, then it works, but the emulator triggers every time a breakpoint even before entering in E32Main().

    And I'm not the only one, I see that rpunskyy have the same problem.

  4. #4
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: VS 2008 and Carbide.vs

    OK, sorry, I misunderstood you there. So could you pls post this as a new thread and add to that thread your .mmp file, the full build output and if possible, some stripped down version of the code in your library. Without those it is quite hard to proceed!

  5. #5
    Registered User
    Join Date
    Jan 2008
    Posts
    6

    Re: VS 2008 and Carbide.vs

    How can I install Carbide 3.0 on an VS2008 System?
    I get a message box saying "Visual Studio 2005 is mandatory requirement"

    I am willing to try Carbide with VS2008 but I have to install it first. Question is how?


    Quote Originally Posted by mitts View Post
    Hi,

    From the multiple posts we have on VS 2008 related issues, seems Carbide.vs 3.0 can be installed with it. While that this great, do note:

    Carbide.vs 3.0 does not support VS2008 and has not been tested with it. If you choose to use Carbide.vs 3.0 with VS2008, pls be aware of this.

    If you want to help our R&D to possibly at a later date produce a version of Carbide.vs that is 2008 compatible (note again: this is no promise that this will ever happen), you can post VS2008 related issues in this thread.

    Before VS2008 is supported, we will simply note the issues. Pls do not post VS2008 issues as separate threads.

  6. #6
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: VS 2008 and Carbide.vs

    Thanks for the heads up on this. Just to make sure, you do have the C++ extension installed with VS2008 and it is not the Express version?

  7. #7
    Registered User
    Join Date
    Jan 2008
    Posts
    6

    Re: VS 2008 and Carbide.vs

    Thanks for the swift reply. I assume you men that it is not Carbide Express I am suppose to install or did you mean VS2008 Express, if such a thing exists?

    Quote Originally Posted by mitts View Post
    Thanks for the heads up on this. Just to make sure, you do have the C++ extension installed with VS2008 and it is not the Express version?

  8. #8
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: VS 2008 and Carbide.vs

    Just thinking that for VS 2005, the Express version is not extendable, so if 2008 had come with something like that, I guess that too would not be extended but haven't seen any Express for 2008... And just to make sure I am clear, there is no need to install Carbide C++ Express.

    So final check then: you do have the VS 2008 C++ package installed?

  9. #9
    Registered User
    Join Date
    Jan 2008
    Posts
    6

    Re: VS 2008 and Carbide.vs

    Please have patients with me this is all new to me.

    Yes, I have VS2008 Pro installed with every option. If that is what you men with "C++ Package".

    Once again: When trying to Install Carbide v3.0 on my Vista system with VS2008 (including C++ package) I get a message box which I have mentioned in my previous post.

    Quote Originally Posted by mitts View Post
    Just thinking that for VS 2005, the Express version is not extendable, so if 2008 had come with something like that, I guess that too would not be extended but haven't seen any Express for 2008... And just to make sure I am clear, there is no need to install Carbide C++ Express.

    So final check then: you do have the VS 2008 C++ package installed?

  10. #10
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: VS 2008 and Carbide.vs

    OK, so it seems that the final product installer is more strict with 2008 than was the beta installer. Thanks for reporting this, we'll check it out!

  11. #11
    Registered User
    Join Date
    Jan 2008
    Posts
    6

    Re: VS 2008 and Carbide.vs

    Well I messed around a little, modified the .msi installer and then my windows registry, and successfully installed Carbibe.vs 3.0 on my Vista x64 VS2008Pro system.

    I will read up a little on the "Carbide_vs_Getting_Started_Guide_version_3_0.pdf"
    document. I mainly want to do UIQ3.0-3.1 development.

    What would be the easiest way for me to test that Carbibe works as it should, before I go on learning it by myself

    I am assuming that there are VS projects with "hello world" type of programs as samples somewhere on forum.nokia.com?
    Or maybe buried somewhere in the UIQ SDK?

    Thanks

    Quote Originally Posted by mitts View Post
    OK, so it seems that the final product installer is more strict with 2008 than was the beta installer. Thanks for reporting this, we'll check it out!

  12. #12
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,566

    Re: VS 2008 and Carbide.vs

    Unfortunately I do not have the UIQ SDK-s installed right now, but both 3.0 and 3.1 comes with an Examples folder, containing Symbian examples (they are divided to examples that exist and run on UIQ and the SDK, and examples that only exist and you can learn from them, but you should not expect them to run) and UIQ-specific examples (obviously running on UIQ and the SDK).

  13. #13
    Registered User
    Join Date
    Jan 2008
    Posts
    6

    Re: VS 2008 and Carbide.vs

    I still haven't looked into the examples but have looked around on the net. I seem also to need a "Carbide.vs UIQ Support package". The only package which I have found is on develpoer.uiq.com, but it is only for version 2.1 of Carbibe. Maybe I can mess around with it and get it installed somehow.

    Quote Originally Posted by wizard_hu_ View Post
    Unfortunately I do not have the UIQ SDK-s installed right now, but both 3.0 and 3.1 comes with an Examples folder, containing Symbian examples (they are divided to examples that exist and run on UIQ and the SDK, and examples that only exist and you can learn from them, but you should not expect them to run) and UIQ-specific examples (obviously running on UIQ and the SDK).
    Last edited by polski; 2008-01-17 at 01:53.

  14. #14
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: VS 2008 and Carbide.vs

    hi polski,

    Thanks a lot for your efforts. The UIQ support package for 2.0.1 would need tons of tweaking in area of the descriptors. If you just want to try out how to work with VS2008 and Carbide.vs, may I suggest that you:

    - download the S60 3.1 SDK (http://www.forum.nokia.com/info/sw.n...16-3.0-mr.html, look for 3rd edition FP 1)
    - check out the Nokia Wiki for tweaks you need to do to run the SDK on Vista (see http://wiki.forum.nokia.com/index.php/Windows_Vista)
    - check out the getting started doc, you can make your first app and run it on the emulator by just creating a new project using the Hello World template)

    Good luck, keep us posted!

  15. #15
    Registered User
    Join Date
    Jan 2008
    Posts
    6

    Re: VS 2008 and Carbide.vs

    Thanks I will look into it a little later today or this week.
    I was wondering who has made the Carbibe UIQ support package? Would like to get in touch with them so see if they can give any suggestions on VS2008.

    Thanks

    Quote Originally Posted by mitts View Post
    hi polski,

    Thanks a lot for your efforts. The UIQ support package for 2.0.1 would need tons of tweaking in area of the descriptors. If you just want to try out how to work with VS2008 and Carbide.vs, may I suggest that you:

    - download the S60 3.1 SDK (http://www.forum.nokia.com/info/sw.n...16-3.0-mr.html, look for 3rd edition FP 1)
    - check out the Nokia Wiki for tweaks you need to do to run the SDK on Vista (see http://wiki.forum.nokia.com/index.php/Windows_Vista)
    - check out the getting started doc, you can make your first app and run it on the emulator by just creating a new project using the Hello World template)

    Good luck, keep us posted!

Page 1 of 2 12 LastLast

Similar Threads

  1. Carbide.vs 3.0 (supporting VS 2005) released!
    By mitts in forum Symbian Tools & SDKs
    Replies: 44
    Last Post: 2010-07-18, 09:30
  2. Carbide.c++ express vs Carbide.vs
    By zdenko in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 3
    Last Post: 2006-10-13, 06:15
  3. Compile error when upgrading from NDS 1.1 to Carbide.vs 2.0.1
    By ericcwhung in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2006-04-24, 07:58
  4. Request for input on Carbide.vs 2.0 Help
    By mitts in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2006-01-10, 09:16
  5. carbide.vs lacks support for app registration files
    By d.roettsches in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2005-12-02, 10:12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •