×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Regular Contributor
    Join Date
    Sep 2008
    Location
    Philippines, Manila
    Posts
    320

    Error on Build S60 2nd Edition FP 3

    hi

    i installed carbide v1.3 and S60 2nd FP 3, S60 3rd FP 2 ans S60 5th. the 3rd and 5th ed builds with no problem. but the S60 2nd ed has a problem.

    \SYMBIAN\CARBIDE\WORKSPACE\SIMPLE\GROUP\BLD.INF FATAL ERROR(S):
    \SYMBIAN\CARBIDE\WORKSPACE\SIMPLE\GROUP\BLD.INF(13) : Unsupported platform ARMV5 specified
    \SYMBIAN\CARBIDE\WORKSPACE\SIMPLE\GROUP\BLD.INF(13) : Unsupported platform GCCE specified

    i don't know what this means..

  2. #2
    Registered User
    Join Date
    Dec 2005
    Posts
    1,236

    Re: Error on Build S60 2nd Edition FP 3

    Hi,

    I am not quite sure whether carbide supports Second edtion fp3.
    Regards,
    Sriky

  3. #3
    Registered User
    Join Date
    Jun 2006
    Location
    India
    Posts
    1,043

    Re: Error on Build S60 2nd Edition FP 3

    Hi,
    The earlier version of Carbide supports 2nd edition. Here follow this discussion thread to see how to use Caribide with 2nd edition
    http://discussion.forum.nokia.com/fo...d.php?t=146572
    Maximus
    S60 Developer
    Impossible is nothing

  4. #4
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Error on Build S60 2nd Edition FP 3

    Quote Originally Posted by coolblues5000 View Post
    hi

    i installed carbide v1.3 and S60 2nd FP 3, S60 3rd FP 2 ans S60 5th. the 3rd and 5th ed builds with no problem. but the S60 2nd ed has a problem.

    \SYMBIAN\CARBIDE\WORKSPACE\SIMPLE\GROUP\BLD.INF FATAL ERROR(S):
    \SYMBIAN\CARBIDE\WORKSPACE\SIMPLE\GROUP\BLD.INF(13) : Unsupported platform ARMV5 specified
    \SYMBIAN\CARBIDE\WORKSPACE\SIMPLE\GROUP\BLD.INF(13) : Unsupported platform GCCE specified

    i don't know what this means..
    carbide.c++ 1.3 does not support pre v3.x sdks. try installing older carbide.x++ 1.2 side by side

  5. #5
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,567

    Re: Error on Build S60 2nd Edition FP 3

    Though the partial information pieces are also true, the basic thing is that the SDK knows it right: there is no such thing as ARMV5 or GCCE target in S60 2nd edition.
    If you want support pre-Symbian 9 and Symbian 9 SDK-s with a single bld.inf, PRJ_PLATFORMS should not be specified, and the .mmp file will need some #ifdef-s (like in #3 of http://discussion.forum.nokia.com/fo...highlight=eka2)

Similar Threads

  1. S60 2nd Edition FP2: Looking for Active Perl 5.6.1 build 531
    By xjussix in forum Symbian Tools & SDKs
    Replies: 19
    Last Post: 2009-12-23, 03:55
  2. Replies: 35
    Last Post: 2009-04-11, 14:36
  3. S60 2nd Edition SDK emulator error: Invalid Java Vesion
    By vikas_khengare in forum Mobile Java General
    Replies: 2
    Last Post: 2007-11-28, 10:47
  4. why it's give me undefined reference to `TUriParser8' in S60 2nd Edition FP3???
    By Tanya in forum Symbian Networking & Messaging (Closed)
    Replies: 3
    Last Post: 2007-11-23, 08:27
  5. creating s60 2nd edition application launcher
    By puh_sk8@hotmail.com in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 2
    Last Post: 2007-01-09, 08:25

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •