×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    65

    POST protocol in Symbian?

    Hi, I would like to send a file via HTTP and I think good way to do it is by using the POST -method. The problem is that I can't get the posted data in server. What could have went wrong is that I am using the post method just like in the GET method. Here is a bit of my code? Could someone help me on this...

    iWriteBuffer.Copy(_L8("POST /posttest.asp &quot);
    iWriteBuffer.Append(iRequestParameter);
    iWriteBuffer.Append(_L8(" HTTP/1.0\r\nHost:&quot);
    iWriteBuffer.Append(KDefaultServerName);
    iWriteBuffer.Append(_L8("\r\n\r\n\r\n\r\n&quot);

    -Pete

  2. #2
    Registered User
    Join Date
    Mar 2003
    Posts
    3

    RE: POST protocol in Symbian?

    I did some stuff with this a while back (ER5)
    I take it you have checked that the formating of the post is correct (this was always the mistake I made)

    http://www.w3.org/Protocols/

    Guus Davidson

  3. #3
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    344

    RE: POST protocol in Symbian?

    Hi,

    I tried sending SIS files over HTTP and it works fine.

    Ravi

  4. #4
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    65

    RE: POST protocol in Symbian?

    Thanks, I have resolved the problem, it was the way I wrote the request.

    Thanks for any help.:-)

    -Pete

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •