×

Discussion Board

Results 1 to 3 of 3

Hybrid View

  1. #1
    Regular Contributor
    Join Date
    Jan 2004
    Posts
    128

    debugging and running a widget

    Hi,

    I have just opened this thread to get some feedback about the debugging environment you are using. From some of the WRT presentations, the following approaches are suggested:

    - Firefox
    Firebug
    Javascript debugger plug-in
    Implement S60 Web widget's specific object stubs
    - On s60 emulator
    use alert method
    send log data to server
    enable java/ecma script error from the browser settings

    I tried to use the first approach in my project. As I am using AJAX requests, the following entry explained how to set up the debug environment
    http://blogs.forum.nokia.com/blog/ja...illa.com-en-us
    However, I have not been successfully and every time I send request and 401 HTTP request is gotten. Any idea?

    You could also add any suggestions for debugging.

    Cheers

  2. #2
    Nokia Developer Expert
    Join Date
    Oct 2008
    Posts
    9

    Re: debugging and running a widget

    Hi,

    if you're facing issue with the AJAX requests handling in firefox.

    option-1:
    Get GreaseMonkey + XMLHttpRequest Bypass script hack

    If this doesn't works for try next option

    option-2:

    Setp-1:
    ---------------------------------------------+
    Add this line of Javascript code before calling each XMLHTTPREQUEST.open function
    netscape.security.PrivilegeManager.enablePrivilege(”UniversalBrowserRead”);

    Code:
    // create XmlHttpRequest Object
    var xmlhttp = new XMLHttpRequest();
    
    // Enable Universal Browser Read
    try{ netscape.security.PrivilegeManager.enablePrivilege("UniversalBrowserRead"); }
    catch(e){ alert(e); }
    
    // before each
    xmlhttp.open(METHOD, URL);
    Step-2 {Optional for FF2 / Mandatory for FF3}
    ---------------------------------------------+
    - Open Firefox browser and navigate url > "about:config"
    - Search this property by using the filter "signed.applets.codebase_principal_support"
    - and set the Boolean value to "true"

    Comment : A codebase principal is a principal derived from the origin of the script rather than
    from verifying a digital signature of a certificate. Since codebase principals offer weaker security,
    they are disabled by default in Mozilla. More info: http://www.mozilla.org/projects/secu...d-scripts.html

    Step-3 {Optional }
    ------------------+
    - Open Firefox browser and navigate url > "about:config"
    - Search this property by using the filet "security.fileuri.strict_origin_policy"
    - and set the Boolean value to "false"

    Comment : allowed XMLHttp to do it’s thing from a file:///

    -------
    Hope this helps you.
    Raghava Chinnappa
    Last edited by raghava.chinnappa; 2008-10-21 at 09:30.

  3. #3
    Regular Contributor
    Join Date
    Jan 2004
    Posts
    128

    Re: debugging and running a widget

    Thanks for your suggestion.

    I have setup the following environment:

    - firefox 2.0.0.17
    - firebug 1.0.5
    - greasemonkey 0.7.20070607.0
    - XMlhttprequest - bypass security script

    I have followed your steps until point 2-b, because I don't see the last property you mentioned "signed.applets.codebase_principal_support".

    I have not been successful. Any time I sent a request, I am getting an HTTP 401 as response. However, I can not see in the NET panel of firebug that those requests have been performed.

    Any idea?

Similar Threads

  1. breakpoints disabled when running debugger.
    By nawkboy in forum Symbian
    Replies: 4
    Last Post: 2012-05-31, 10:45
  2. Problems running and debugging with NDS and Eclipse
    By dthon1 in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2005-05-12, 21:44
  3. Remotely debugging App when it's running on the phone.
    By aspaans in forum Mobile Java General
    Replies: 2
    Last Post: 2003-05-28, 16:51
  4. Remotely debugging App when it's running on the phone.
    By aspaans in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2003-05-27, 21:06
  5. running and debugging with emulator and JBuilder
    By zivgr in forum Mobile Java Tools & SDKs
    Replies: 2
    Last Post: 2003-05-06, 09:30

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×