×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Mar 2006
    Posts
    33

    is separate signing required for 3rd Edition FP1 and FP2 devices

    Hi,

    I have developed an application and tested it on N95 8GB (3rd edition FP1) and 6220 classic (3rd edition FP2). While development I have provided 3rd edition platform UID [0x101F7961].

    Backup and restore will work on 3rd edition FP1 onwards based devices. My question is do I need to make two separate express signing requests to distribute my application to these feature pack devices?

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,748

    Re: is separate signing required for 3rd Edition FP1 and FP2 devices

    As I understand you have a single version of your software. What would be the difference between the two packages?

  3. #3
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,347

    Re: is separate signing required for 3rd Edition FP1 and FP2 devices

    You do not need to submit two separate applications unless you find some API deprecation in different OS versions.
    Nokia Developer Wiki Moderation team

  4. #4
    Registered User
    Join Date
    Mar 2006
    Posts
    33

    Re: is separate signing required for 3rd Edition FP1 and FP2 devices

    thank you.

    source code is exactly same for both version. I had doubt as I no where found info about signing on different platform feature pack

  5. #5
    Registered User
    Join Date
    Jun 2006
    Location
    India
    Posts
    1,043

    Re: is separate signing required for 3rd Edition FP1 and FP2 devices

    Hi,
    Kiran has rightly pointed out if there is no deprecated APIs in your code then you dont need to go for separate signing at all. Since you have a single base line code and you have ensured that your application works fine in both 3.1 as well as 3.2 platform you can go ahead with the single signing of your application.
    Maximus
    S60 Developer
    Impossible is nothing

Similar Threads

  1. APS not supporting FP1 devices
    By tote_b5 in forum Symbian Media (Closed)
    Replies: 12
    Last Post: 2009-02-04, 07:52
  2. Autofocus S60 3rd ed FP1 to FP2
    By Christophe.A in forum Symbian Media (Closed)
    Replies: 9
    Last Post: 2008-09-10, 13:30
  3. JSRs supported on FP1 vs FP2
    By roey in forum Mobile Java General
    Replies: 2
    Last Post: 2008-07-30, 16:39
  4. Replies: 1
    Last Post: 2008-05-01, 08:08
  5. is FP2 backwards compatible with FP1 phones?
    By jkarney in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2005-06-30, 19:26

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×