×

Discussion Board

Results 1 to 9 of 9
  1. #1
    Registered User
    Join Date
    Sep 2008
    Posts
    11

    The application does not start on the phone

    hi,
    I have created with carbide c++ the .sisx file for my application, then i have installed this file on the phone correctly, but when i try to start it, the application does not start and it is running on the phone in background.

    what can i do?

  2. #2
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: The application does not start on the phone

    Quote Originally Posted by massimo190286 View Post
    hi,
    I have created with carbide c++ the .sisx file for my application, then i have installed this file on the phone correctly, but when i try to start it, the application does not start and it is running on the phone in background.

    what can i do?
    what is the type of application you have created,

  3. #3
    Registered User
    Join Date
    Sep 2008
    Posts
    11

    Re: The application does not start on the phone

    i have created a GUI application with wizard executable for Nokia S60 3rd-Future Editions only.

  4. #4
    Registered User
    Join Date
    Dec 2005
    Posts
    1,236

    Re: The application does not start on the phone

    Did you add any new classes or code in the project. Could you tell us what do you mean by the application does not start and it is running on the phone in background
    Regards,
    Sriky

  5. #5
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,542

    Re: The application does not start on the phone

    Quote Originally Posted by massimo190286 View Post
    i have created a GUI application with wizard executable for Nokia S60 3rd-Future Editions only.
    What do mean by future editions only?

    How have you verified that its working in the background? Is it a simple helloworld created by wizard or you have your own codes added to it also?

  6. #6
    Registered User
    Join Date
    Sep 2008
    Posts
    11

    Re: The application does not start on the phone

    The simple hello world application start corretly, the application in question contains other .cpp file, i think that it running in background because i can't unistall it, until i not arrest the application manually going in the management of applications.

    When i try to start application in the installation folder, does not appear my first view with my menu, but remains displayed the list of the available application in the folder and
    over the icon of my application appears a turning circle as a symbol of loading or execution.

  7. #7
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: The application does not start on the phone

    Quote Originally Posted by massimo190286 View Post
    The simple hello world application start corretly, the application in question contains other .cpp file, i think that it running in background because i can't unistall it, until i not arrest the application manually going in the management of applications.

    When i try to start application in the installation folder, does not appear my first view with my menu, but remains displayed the list of the available application in the folder and
    over the icon of my application appears a turning circle as a symbol of loading or execution.
    the application will not go to back ground if you some thing wrong with your added code or you are forcing it to go to background in you code.

  8. #8
    Registered User
    Join Date
    Jun 2006
    Location
    India
    Posts
    1,043

    Re: The application does not start on the phone

    Hi,
    If its a simple helloworld application then can you close it when the application is in foreground? In case not there is something which you would have added which is not closing the application. Or are u really trying something like a background application?
    Maximus
    S60 Developer
    Impossible is nothing

  9. #9
    Registered User
    Join Date
    Dec 2005
    Posts
    1,236

    Re: The application does not start on the phone

    Quote Originally Posted by massimo190286 View Post
    The simple hello world application start corretly, the application in question contains other .cpp file, i think that it running in background because i can't unistall it, until i not arrest the application manually going in the management of applications.

    When i try to start application in the installation folder, does not appear my first view with my menu, but remains displayed the list of the available application in the folder and
    over the icon of my application appears a turning circle as a symbol of loading or execution.
    mm I think you should put logs in your application. It has hung somewhere may be. How to put logs is in thislogger example
    Regards,
    Sriky

Similar Threads

  1. Replies: 1
    Last Post: 2008-05-08, 12:32
  2. Run Console Application on Phone
    By sliver33 in forum Symbian
    Replies: 9
    Last Post: 2006-10-27, 21:55
  3. Application does not work in the phone
    By stefano.garusi in forum Symbian
    Replies: 2
    Last Post: 2006-10-04, 07:52
  4. Replies: 1
    Last Post: 2003-04-01, 11:37

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×