×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 17
  1. #1
    Registered User
    Join Date
    Apr 2007
    Posts
    3

    Pips not installing on N78

    Hi,
    I'm trying to install pips_nokia_1_3_SS.sis from Open C SDK to new N78 device. Installer starts to install embedded PIPS upgrade package but fails saying "Unable to install. Component is build in."

    Glib installs ok. The release notes claim that open c would support 3rd edition FP2. Open C had similar trouble in earlier releases with phones where some parts had been included to some newer phone firmwares. Is this the same trouble over again? Does it work for you?

    Firmware version (*#0000#) says:
    Software version: 12.046
    Software version date: 25-06-2008
    Custom version: 12.046.051.1
    Custom version date: 25-06-2008
    Language set: 003
    Model: N78
    Type: RM-235
    Latest update: Not updated

    Best regards,
    Jaakko Tuosa

  2. #2
    Super Contributor
    Join Date
    Oct 2007
    Location
    Deva, Romania
    Posts
    3,471

    Re: Pips not installing on N78

    Hi,

    According to this page:
    Devices based on S60 3rd Edition, Feature Pack 2 have the Open C APIs delivered in their firmware. For all other devices, the Open C/C++ Plug-ins for S60 3rd Edition delivers device plug-ins for Open C and Open C++.
    So I guess PIPS came with the device's firmware and is already installed.

  3. #3
    Registered User
    Join Date
    Dec 2006
    Posts
    2,280

    Re: Pips not installing on N78

    Bogdan is 100% correct, you don't need to install P.I.P.S. or Open C on 3rd FP2 phones, it's already in the firmware and this is exactly what the error from the installer tells you.

    Sorcery

  4. #4
    Registered User
    Join Date
    Jan 2010
    Posts
    15

    Re: Pips not installing on N78

    Greetengs.

    I have the same n78 and the same error.
    I've installed all Open C and Open C++ dependencies, but PIPS fails.
    And when I try to install Qt afterwards - it says that PIPS is not installed.
    If I continue anyway - Qt installs but no Qt app works.

    What is the solution for this model? And maybe it should be available somewhere on the wiki?

  5. #5
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Pips not installing on N78

    Unfortunately there seems to be an issue with a stub sis file on N78 so if you already have the latest version available to you the only way to address the problem is to format the device (*#7370#). Do note that is will cause all your data to be lost so a backup is highly recommended.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  6. #6
    Registered User
    Join Date
    Jan 2010
    Posts
    15

    Re: Pips not installing on N78

    Will it help? I do not want to loose all my contacts, messages etc.

    And does firmware update not format the phone system files?

  7. #7
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Pips not installing on N78

    As said, if you already have the latest firmware you cannot upgrade anymore so your only chance is to format the phone. If you can update the firmware, do it.

    You will lose the data unless you make a backup copy (using PC Suite) or you store it to a server using e.g. Ovi Contacts
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  8. #8
    Registered User
    Join Date
    Jan 2010
    Posts
    15

    Re: Pips not installing on N78

    I've updated firmware yesterday. And it has not helped.

  9. #9
    Regular Contributor
    Join Date
    Mar 2006
    Posts
    81

    Re: Pips not installing on N78

    I've now got myself an N78 with the latest firmware. Guess what? I've got exactly the same problem. This was reported over a year ago. Are Nokia ever going to fix it!?

    Is it just the N78 that has this issue? What about all of the other S60 3.2 phones?

  10. #10
    Regular Contributor
    Join Date
    Mar 2006
    Posts
    81

    Re: Pips not installing on N78

    iftifn, it seems that the firmware isn't the problem. It's whatever is on the C drive. I can now confirm that formatting the device as ltomuta suggested does work.

  11. #11
    Registered User
    Join Date
    Mar 2010
    Posts
    1

    Re: Pips not installing on N78

    I also got it working by restoring factory defaults.
    Thanks a million.

    UNT,
    Jag

  12. #12
    Registered User
    Join Date
    Nov 2010
    Posts
    38

    Re: Pips not installing on N78

    The Hard reset did not work for me.

    I did the following steps:

    I resetted my phone, using *#7370#

    I Try To install the qt_installer.sis From the Qt Nokia SDK
    Code:
    SWI error 0 c:\sys\bin\pipelib.ldd
    and then breaks the installer:
    Code:
    error-10257
    I unpacked the qt_installer.sis and extracted the files to the memory card. All of them Install correctly, except the qt.sis and the pips.sis.

    When I start the qt.sis i soon get to a point which tells me:
    Code:
    Component 'PIPS Installer' missing. Continue anyway?
    If i continue, my applications don't work on the phone.

    When I try to install the pips.sis it tells me:
    Code:
    Unable to install. Component is built-in.
    looks like a chicken is searching for his unlayed eggs here.

    Any more Advice?

  13. #13
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,752

    Re: Pips not installing on N78

    If you have reseted the phone already, trying a firmware update should not cause too much trouble. Copying the files to the memory card does not replace installation. The device stores a checksum of every binary executable you have installed to the memory card. Files you have copied there do not have such checksum, thus the kernel will not load them. However on the other hand they can cause problems with installation.

  14. #14
    Registered User
    Join Date
    Nov 2010
    Posts
    38

    Re: Pips not installing on N78

    Sorry, I forgot to mention, I DID do a firmware update. I actually did it twice to ensure it worked.

    I Try to install the software FROM the Memory Card TO the phone. Its just the .sis installer i put to the card for simplicity, no binaries. The errors also occur, when i try to install the sis files from Windows using the OVI suite.

    I am talking about the Qt Libraries, not my own Applications here. I deploy my applications using the apropriate toolchain. They don't work, because P.I.P.S is not properly installed, that is the issue i try to resolve here.

  15. #15
    Registered User
    Join Date
    Nov 2010
    Posts
    38

    Re: Pips not installing on N78

    Will there be any solution to this? At the current state it seems not to be possible to develop Qt apps for the N78 at all.

Similar Threads

  1. How to capture SIP log on N78?
    By ayog in forum VoIP
    Replies: 6
    Last Post: 2008-12-02, 09:56
  2. Installing carbide.c++ 1.3 for N73 application
    By amarzo in forum Symbian Tools & SDKs
    Replies: 8
    Last Post: 2008-09-02, 13:43
  3. How to Change N78 Contacts image?
    By ppiggy in forum Symbian
    Replies: 0
    Last Post: 2008-06-18, 07:11
  4. How retriving the installing sisx filename
    By echo3 in forum Symbian
    Replies: 12
    Last Post: 2007-10-23, 16:09
  5. OpenC and PIPS
    By Symbian_Neil in forum News and Announcements
    Replies: 2
    Last Post: 2007-02-27, 12:53

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×