×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Dec 2007
    Posts
    2

    http post in widget

    hi,all

    I use "http post" method to invoke webServive and I found a problem (in s60).
    the Content-type is"application/x-www-form-urlencoded"(have to be)

    I posted base64 about 17k length ,
    the params like "a=SJpEyRkrS2p7xeb+1i6Q9Nprfs0eT1Nfn3e52N8F/uRqyUoO959UTBQ9Krrs2xdpT4&b=jk",

    when param "a" is short, the post is ok, but when "a" is very long ,the server returns "http 400".
    But even the param "a" is long enough, it works fine in firefox ,so it should not be the problem of the server.

    I've searched all the resources i can find ,but offer me no help.

    Can anyone help me?

    Does s60 have some restricts about the post length?

  2. #2
    Registered User
    Join Date
    Aug 2008
    Posts
    1

    Re: http post in widget

    I think so, there is a limitation about the length of URL, normally 256 charachers.


    Quote Originally Posted by BillZS View Post
    hi,all

    I use "http post" method to invoke webServive and I found a problem (in s60).
    the Content-type is"application/x-www-form-urlencoded"(have to be)

    I posted base64 about 17k length ,
    the params like "a=SJpEyRkrS2p7xeb+1i6Q9Nprfs0eT1Nfn3e52N8F/uRqyUoO959UTBQ9Krrs2xdpT4&b=jk",

    when param "a" is short, the post is ok, but when "a" is very long ,the server returns "http 400".
    But even the param "a" is long enough, it works fine in firefox ,so it should not be the problem of the server.

    I've searched all the resources i can find ,but offer me no help.

    Can anyone help me?

    Does s60 have some restricts about the post length?

  3. #3
    Registered User
    Join Date
    Oct 2008
    Posts
    1

    Re: http post in widget

    I don't think so, i also have this problem.

    I post about 8,000 charaters(not get) ,it is still ok,but if i post more, the problem shows up.

Similar Threads

  1. waiting for HTTP POST response
    By gemilib in forum Symbian C++
    Replies: 3
    Last Post: 2007-11-19, 17:00
  2. Using HTTP POST & Nokia 6600 to upload octet stream to server
    By ssandor in forum Mobile Java Networking & Messaging & Security
    Replies: 1
    Last Post: 2005-09-19, 11:00
  3. Series 40 phones HTTP POST problem
    By jessicay in forum Mobile Java Networking & Messaging & Security
    Replies: 0
    Last Post: 2004-06-23, 01:01
  4. Replies: 0
    Last Post: 2002-05-09, 12:07
  5. HTTP POST?
    By dennisluemkemann in forum Mobile Java General
    Replies: 1
    Last Post: 1970-01-01, 02:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •