×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Oct 2008
    Posts
    2

    Cannot auto start multilingual app during install

    Hello,

    I have a multilingual GUI application that is supposed to be kicked off by the end of my install. I have the pkg file defined as specified by the SDK documentation and I'm using FILERUN, RI options to launch the GUI, after all my resource (rsc) files have been copied. For some reason, install will never launch the application. But, after installation is complete, if I try to start the app then it works.

    I have an english only version of the same pkg that works fine, so definetely seems to be a resource related problem. I noticed that if I install all .r* files (as opposed to .rsc only), the app will come up successfully. But in this case, it will always use english, as opposed to the language selected by the user.

    I've found some other posts in the forum that seem related to this, but nothing that will actually solve my problem. Has anyone seen anything similar?

    Thanks.

  2. #2
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,347

    Re: Cannot auto start multilingual app during install

    FILERUN option will not work with Self-signed applications. Is it the case with you?
    Nokia Developer Wiki Moderation team

  3. #3
    Registered User
    Join Date
    Oct 2008
    Posts
    2

    Re: Cannot auto start multilingual app during install

    Hi Kiran,

    no, that's no my case. FILERUN works fine for me if I build/install an english only version.

    Thanks.

  4. #4
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,165

    Re: Cannot auto start multilingual app during install

    it should not have any difference on how many languages you have, at least I have not seen anybody mentioning this problem previously, so maybe it is something else that goes wrong.

  5. #5
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Cannot auto start multilingual app during install

    yes that is true, i have a multi-language application that starts after installation as usual.

  6. #6
    Registered User
    Join Date
    Jun 2006
    Location
    India
    Posts
    1,043

    Re: Cannot auto start multilingual app during install

    Hi,
    I was able to start my multilanguage application after install using FI,RI but it was the non GUI application but what I was doing in that I had to load the appropriate resource myself since there was no GUI environment available by the framework.In your case however you are having the GUI environment so it should not be a problem, of course you have to use the .r* files if you have more than one language files.
    Maximus
    S60 Developer
    Impossible is nothing

Similar Threads

  1. Auto start and Auto installation
    By sunithadevim in forum Symbian
    Replies: 8
    Last Post: 2008-02-07, 04:58
  2. Replies: 6
    Last Post: 2007-04-02, 11:52
  3. exe app to auto start (2ed)
    By shadow-2005 in forum Symbian
    Replies: 4
    Last Post: 2007-03-27, 10:04
  4. How to start MIDLet app on mobile startup?
    By corej2me in forum Mobile Java General
    Replies: 1
    Last Post: 2006-12-18, 18:26
  5. Replies: 2
    Last Post: 2006-07-07, 06:02

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×