×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 18
  1. #1
    Regular Contributor
    Join Date
    Oct 2008
    Posts
    91

    sis file not getting installed need help

    Hello All,

    I have tried everything possible, but there is some problem with my sis file installation.
    I am consistently getting the error "Unable to install"
    I checked the UID's , got it developer signed, also checked enough space on the handset I am trying to install it on...

    what else can the problem be...

    please help me with this...

  2. #2
    Super Contributor
    Join Date
    Nov 2005
    Location
    London
    Posts
    584

    Re: sis file not getting installed need help

    Check out this post: http://blogs.forum.nokia.com/index.p...7&articleId=93

    Sounds like you're maybe installing to a data-caged location. Please post your .pkg file if you can't determine the issue from the link above...

  3. #3
    Regular Contributor
    Join Date
    Oct 2008
    Posts
    91

    Re: sis file not getting installed need help

    Hello stichbury,
    Thanks for your reply.
    I read the info at the link. but even if it is a matter of data caging...how do I resolve it?

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,737

    Re: sis file not getting installed need help

    Try re-reading Stichbury's comment, focus on the last sentence this time.

  5. #5
    Regular Contributor
    Join Date
    Oct 2008
    Posts
    91

    Re: sis file not getting installed need help

    Hi,
    here's the pkg file ...



    ; Installation file for MobileFinder application
    ;
    ; This is an auto-generated PKG file by Carbide.
    ; This file uses variables specific to Carbide builds that will not work
    ; on command-line builds. If you want to use this generated PKG file from the
    ; command-line tools you will need to modify the variables with the appropriate
    ; values: $(EPOCROOT), $(PLATFORM), $(TARGET)
    ;
    ;Language - standard language definitions
    &EN

    ; standard SIS file header
    #{"MobileFinder"},(0x2001ECE3),1,0,0

    ;Localised Vendor name
    %{"Vendor-EN"}

    ;Supports Series 60 v 3.0
    [0x101F7961], 0, 0, 0, {"Series60ProductID"}
    [0x102032BE], 0, 0, 0, {"Series60ProductID"}

    ;Files to install
    ;You should change the source paths to match that of your environment
    ;<source> <destination>
    "C:\Symbian\Carbide\workspace\MobileFinder\sis\Installation.txt" - "",FT,TE
    "$(EPOCROOT)Epoc32\release\$(PLATFORM)\$(TARGET)\MobileFinder.exe" -"!:\sys\bin\MobileFinder.exe"
    "$(EPOCROOT)Epoc32\data\z\resource\apps\MobileFinder.rsc" -"!:\resource\apps\MobileFinder.rsc"
    "$(EPOCROOT)Epoc32\data\z\private\10003a3f\apps\MobileFinder_reg.rsc" -"!:\private\10003a3f\import\apps\MobileFinder_reg.rsc"
    ;"$(EPOCROOT)Epoc32\data\z\resource\apps\mflogo.mbm" -"!:\resource\apps\mflogo.mbm"
    "$(EPOCROOT)Epoc32\data\z\MobileFinderSplash.mbm" -"!:\resource\apps\MobileFinderSplash.mbm"

    "$(EPOCROOT)Epoc32\Data\z\2001ece3.rsc"-"c:\private\101f875a\import\[2001ece3].rsc"
    "C:\Symbian\9.2\MobileFinder\help\MobileFinder.hlp" - "!:\resource\help\MobileFinder.hlp"

  6. #6
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,737

    Re: sis file not getting installed need help

    The .pkg seems to be fine (I have not checked what are those pre-requisites, but that would display the Series60ProductID text), so make sure that you are building the application for GCCE target when creating the installation file.

  7. #7
    Regular Contributor
    Join Date
    Oct 2008
    Posts
    91

    Unhappy Re: sis file not getting installed need help

    hi wizard_hu_,

    I have built it for GCCE target . can't figure out what is the problem...

  8. #8
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,737

    Re: sis file not getting installed need help

    You can also search for Unable to install in the Wiki, but those ideas apply to really rare cases.

  9. #9
    Regular Contributor
    Join Date
    Aug 2008
    Posts
    59

    Re: sis file not getting installed need help

    On which handset you are trying to install???

  10. #10
    Regular Contributor
    Join Date
    Aug 2008
    Posts
    59

    Re: sis file not getting installed need help

    Did you confirm weather any other sis files are able to install on that device????
    Please have a look at this
    Last edited by dudhani_ss; 2008-11-04 at 09:34.

  11. #11
    Regular Contributor
    Join Date
    Oct 2008
    Posts
    91

    Re: sis file not getting installed need help

    Hi,
    actually I am trying to do an application which uses Location Aquisition API's. I am trying to install it on Nokia E50.
    does it need to have an inbuilt GPS , I dont know if E50 has it

  12. #12
    Regular Contributor
    Join Date
    Oct 2008
    Posts
    91

    Re: sis file not getting installed need help

    Hi,
    E50 does not have GPS in built.
    is that the reason why I am not able to install the application using Location Aquisition API's?

  13. #13
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,737

    Re: sis file not getting installed need help

    No, that would be a runtime issue.

  14. #14
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,737

    Re: sis file not getting installed need help

    Finally I have checked 0x102032BE, it identifies S60 3rd Edition, FP1. Your device is a noFP one, try removing that pre-requisite.

  15. #15
    Regular Contributor
    Join Date
    Oct 2008
    Posts
    91

    Re: sis file not getting installed need help

    Thanks wizard_hu_ for your reply...
    I wanted to know that everytime I change anything in my application ( like now i will be changing the product UID as you have said ) do I need to get my application signed again?

    waiting for reply

    -ash_leo

Similar Threads

  1. [announce] PyUIQ. Python for UIQ 2.1 and 3.x
    By OscarBernabeu in forum Symbian
    Replies: 35
    Last Post: 2008-01-17, 09:12
  2. Mobile Virus Info and Solution
    By kunalshastry in forum General Development Questions
    Replies: 16
    Last Post: 2007-08-07, 11:12
  3. Creating and installing SIS file...
    By Himanshu_Joshi in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2007-04-12, 17:36
  4. Replies: 7
    Last Post: 2006-10-27, 10:49
  5. unable to merge two sis file on device .
    By amardeep in forum Symbian
    Replies: 0
    Last Post: 2003-04-25, 08:08

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×