×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    May 2008
    Posts
    3

    Question Not able to retreive cellid in 9.1 phones

    Hi All,

    I am developing an application which retrieves the cellid and location area code whenever there is a change in cellid. It is working fine in the 9.2 phones but, it is not working in 9.1 phones. I am using the API iTelephony::GetCurrentNetworkInfo() for retrieving the cellid and location area code and iTelephony::NotifyChange(); for notifying the change in phone network. Please let me know what could be the reason . Thanks in advance.

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Not able to retreive cellid in 9.1 phones

    If you let us know how exactly is not working (error, leave or panic code as appropriate) we might be able to help, otherwise ...

    Also, this question is less related to LBS (merely an enabler technology) and more to Symbian Networking, a domain which has its own dedicated forum on these boards.
    Last edited by ltomuta; 2008-11-04 at 18:24.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  3. #3
    Registered User
    Join Date
    May 2008
    Posts
    3

    Re: Not able to retreive cellid in 9.1 phones

    I was not getting any error/leave/panic. I was getting the value as o for both cellid and location area code. Then i found out that there is a known issue that the API receives both location area code and cell ID as 0 when the the application is running while a phone call or data transfer is initiated, in progress, or being terminated. Please check the link:

    http://wiki.forum.nokia.com/index.ph..._network_usage


    But, my requirement is to send cellid and location area code values to the server whenever there is a change in these values so that i get the location name from the server based on the values i had send to the server. So, what other options i have to make it work for 9.1. It is working perfectly in N95-8GB but not working in the mobiles E65/E61i/E50. Are there any other API's available to get the network info in 9.1??

Similar Threads

  1. Any vendor specific AT commands for Nokia phones
    By jasthy in forum PC Suite API and PC Connectivity SDK
    Replies: 1
    Last Post: 2006-12-07, 10:08
  2. vCard message through a SMS message to various Nokia phones
    By makippola in forum Smart Messaging
    Replies: 2
    Last Post: 2006-04-21, 09:32
  3. Connecting Multiple Phones to 1 PC
    By unwantedmails in forum General Development Questions
    Replies: 0
    Last Post: 2004-01-04, 12:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×