Discussion Board

Results 1 to 13 of 13
  1. #1
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    89

    Update error on install

    Hi group,
    I have a small Symbian application which i released a few month ago (v1.0), now i made a major update to the functionality and would like to release a new version v1.2. When i try to install v1.2 on top of v1.0 i always get "Update error" message! The PKG files looks identical, except for the fact that v1.2 has additional resources for 2 more languages. My device is Samsung i8510. Anybody knows what the problem is?

    thanks in advance!

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,793

    Re: Update error on install

    You can actually search for Update error in the Wiki.
    Update error is about an attempt to overwrite a file which has been installed by a .sis file with different PkgUID.

  3. #3
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    89

    Re: Update error on install

    thanks for the reply, but my PKG uids are the same!

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,793

    Re: Update error on install

    What happens if you comment out those additional resources from the "1.2" .pkg file?

  5. #5
    Regular Contributor
    Join Date
    Mar 2008
    Location
    Bangalore, India
    Posts
    204

    Re: Update error on install

    Hi,

    Uninstall the previous version first and then install the new one.

    Regards,
    Srivatsan

  6. #6
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Update error on install

    Quote Originally Posted by srivatsan.d View Post
    Hi,

    Uninstall the previous version first and then install the new one.

    Regards,
    Srivatsan
    When attempting to fix a re-install/update problem that's not really an option, is it?
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  7. #7
    Super Contributor
    Join Date
    Nov 2004
    Location
    Wiltshire, UK
    Posts
    3,644

    Re: Update error on install

    Remember that in addition to the uid being the same, the package name must also be the same as well as the unique vendor name.
    Download Symbian OS now! [url]http://developer.symbian.org[/url]

  8. #8
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    89

    Re: Update error on install

    hi, sorry for the late reply, i tried striping my PKG of additional languages and i can ALWAYS install if the number of languages is less then 4!! It doesn't matter which languages are included i tried all combinations, what matters is plain number!! less then or equal 4 all good, more then 4 - "Unable to install". By the way i tried that on all phones in new Samsung RDA aka Dev.lab. My App name, vendor name, UID doesn't matter, it's a FRESH install, and i know for fact Samsung doesn't have my app pre-installed
    thanks for your help!

    P.S. i already had a thread on Samsung Symbian forum

  9. #9
    Registered User
    Join Date
    Jul 2008
    Posts
    1,201

    Re: Update error on install

    Quote Originally Posted by minstn View Post
    Hi group,
    I have a small Symbian application which i released a few month ago (v1.0), now i made a major update to the functionality and would like to release a new version v1.2. When i try to install v1.2 on top of v1.0 i always get "Update error" message! The PKG files looks identical, except for the fact that v1.2 has additional resources for 2 more languages. My device is Samsung i8510. Anybody knows what the problem is?

    thanks in advance!
    UID whether or not to modify.
    TurboC
    珍惜每一次机会

  10. #10
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    89

    Re: Update error on install

    well i can, but i got it from Symbian Signed and i'm absolutely sure everything is OK with it, if i leave 4 languages only in my PKG all works fine!!

  11. #11
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Update error on install

    Is this problem reproducible on Samsung devices only or on Nokia as well? (I don't know what phones are available in Samsung's RDA)

    If Nokia phones are affected too, you can create a bug report and attach the SIS files to it.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  12. #12
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    89

    Re: Update error on install

    thanks for the reply! as i said Nokia works as charm! this is a problem with samsung device only (Samsung i8510 aka innov8). i know it sounds a bit strange to post a thread about Samsung on this forum but i'm simple disparate! and i know that Forum Nokia always helped in the past!

  13. #13
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Update error on install

    Quote Originally Posted by minstn View Post
    i know it sounds a bit strange to post a thread about Samsung on this forum but i'm simple disparate! and i know that Forum Nokia always helped in the past!
    No worries about that, we will, of course, try to help. Is just that if the problem would be reproducible on Nokia devices we would have better means of investigating the issue.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

Similar Threads

  1. About Nokia Software Update (i.e. Firmware Update)
    By talk2mishal in forum General Development Questions
    Replies: 5
    Last Post: 2008-06-20, 14:45
  2. [moved] " SOFTWARE UPDATE FAILED "
    By musum in forum General Development Questions
    Replies: 1
    Last Post: 2008-06-01, 08:04
  3. Replies: 1
    Last Post: 2008-02-07, 05:55
  4. unable to install jar
    By stevenpannell in forum Mobile Java General
    Replies: 5
    Last Post: 2006-11-10, 18:26
  5. SIS install fails in S60 V3
    By Holler in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 5
    Last Post: 2006-09-15, 03:03

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×