×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Aug 2008
    Posts
    11

    connection problem by hidden access point

    Hi, everyone
    i'm developing s60 Application

    my app connect by hidden access point
    but my app don't connect by hidden acces point, in N81 only
    other phone is no problem

    i did hide access point by PutRecordChanges(ETrue)

    connect is
    ///////////////////////////////////////
    TCommDbConnPref pref;
    ....
    iConnection.Start(pref);
    User::LeaveIfError( iSocket.Open(...))
    ///////////////////////////////////////

    but iSocke.open don't normally processed on N81

    what problem is it?
    How should i?

    Thank you.
    Have a nice day

  2. #2
    Nokia Developer Champion
    Join Date
    Jul 2007
    Location
    ShenZhen, China
    Posts
    4,346

    Re: connection problem by hidden access point

    can you show more code, I use N81, but not any problem.

    Code:
    iPref.SetIapId(aIap);
    iPref.SetDialogPreference(ECommDbDialogPrefDoNotPrompt);
    iPref.SetDirection( ECommDbConnectionDirectionOutgoing );
    iPref.SetBearerSet(ECommDbBearerUnknown);
    iConnection.Start(iPref, iStatus);
    
    ...
    
    
    User::LeaveIfError(iSocket.Open(*iSocketServ, KAfInet, KSockStream,
                KProtocolInetTcp, iConnection));
    ----------------------------
    坚持学习, 坚持编码
    http://www.devdiv.net/
    qxiaoyuan

Similar Threads

  1. Problem MMC+USB Connection
    By Fede81 in forum Symbian
    Replies: 1
    Last Post: 2007-06-14, 06:13
  2. Problem MMC+USB Connection
    By Fede81 in forum General Development Questions
    Replies: 3
    Last Post: 2006-07-19, 15:21
  3. Access point creation problem
    By stv2005 in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2005-05-11, 18:25
  4. Access Point Problem on Emulator
    By IlyaEck in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2004-09-06, 01:32
  5. Why is client code to CSocketEngine hanging at Access Point dialogue?
    By nawkboy in forum Symbian Networking & Messaging (Closed)
    Replies: 2
    Last Post: 2003-03-11, 11:16

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •