×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Super Contributor
    Join Date
    Mar 2003
    Posts
    1,733

    toolkit won't launch in JRE 1.2.2

    Posted by Jodi Schober, jodi.schober@qsent.com
    on January 18, 2001 at 19:23

    When I try to run the toolkit, a message saying I don't have JRE 1.2.2 installed error box pops up. It was working when I clicked OK, but now it just opens the .jar file in my zip app. Does the JRE have to be installed in a certain directory? I just put it in the default location.

  2. #2
    Super Contributor
    Join Date
    Mar 2003
    Posts
    1,733

    RE: toolkit won't launch in JRE 1.2.2

    Posted by WAP Toolkit Team, info.wapbrowser@nokia.com
    on January 20, 2001 at 01:26

    Toolkit launcher was pretty broken in version 2.0.
    One of the known problems is that it fails to
    detect JRE 1.2.2 if you are not an administrator.
    When it happens, it simply performs the default
    action (whatever happens when you double-click
    on a jar file in Explorer)

    Your options:

    1. wait for toolkit 2.1 (it's been officially released,
    but it may take a few more days to update
    the download page)
    2. Give yourself administrative privileges
    3. Give yourself full access to the key
    SOFTWARE\JavaSoft\Java Runtime Environment
    under HKEY_LOCAL_MACHINE and all its
    subkeys (you can use regedt32.exe to edit
    the permissions). This *may* fix the problem

    I would recommend solution no. 1

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •