×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Registered User
    Join Date
    Jul 2006
    Posts
    6

    PA package re-installation problem

    Hello,
    When creating a package as PA, the package will be automatically installed first time inserting the card. But if removing the package, next time inserting the card won't cause the auto-install.
    I believe there may be some mark or change in the SIS registry so that phone knows this PA is installed before.
    Is there any way to remove "that mark" to make the PA works again? (I know there are some APIs in DevKit that can at least get SIS registry information, is there any information related to this issue?)

    Regards,
    John~

  2. #2
    Registered User
    Join Date
    Jun 2007
    Location
    Mumbai, India
    Posts
    1,998

    Re: PA package re-installation problem

    Hi John,

    What do u mean by PA Package?

  3. #3
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,689

    Re: PA package re-installation problem

    Quote Originally Posted by kamalakshan View Post
    What do u mean by PA Package?
    Search for PA in the SDK Help.

  4. #4
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: PA package re-installation problem

    While developing and testing the PA, it appears not to like that the content changes on the packet, so most often it seems that you actually need to format the device in order to get it installing nicely. (did test this only with N73 quite a long time ago, so with new firmwares or new devices it could work differently of course)

  5. #5
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: PA package re-installation problem

    The idea of the PA is that the application is by default automatically installed on any phone on which the memory card is inserted. However, once the user has expressed explicit uninstall request the application will no longer be automaticaly installed but the user will have to perform express installation through the Application Manager.

    This makes sense of course, an uninstalled application should remain so until the user decides the oposite. Any automatic re-install would be intrusive.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  6. #6
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: PA package re-installation problem

    Quote Originally Posted by ltomuta View Post
    The idea of the PA is that the application is by default automatically installed on any phone on which the memory card is inserted. However, once the user has expressed explicit uninstall request the application will no longer be automaticaly installed but the user will have to perform express installation through the Application Manager.

    This makes sense of course, an uninstalled application should remain so until the user decides the oposite. Any automatic re-install would be intrusive.
    Thanks for clarification, Chief.

  7. #7
    Registered User
    Join Date
    Jul 2006
    Posts
    6

    Red face Re: PA package re-installation problem

    Thank you guys for helping me on this one.
    Yes, I totally agree that user has the control of the application. But I just wonder why system can understand this application is installed before.
    It seems that something remains in the system even when user uninstalls the application.
    I just wonder if there is a way to know this information.
    Thanks again guys~

    Regards,
    John~

  8. #8
    Super Contributor
    Join Date
    Jul 2007
    Location
    ShenZhen, China
    Posts
    4,346

    Re: PA package re-installation problem

    when you use nokia pc suite, and setting phone usb mode to "data transfer" mode, you can find \private\install and \private\uninstall dir, it contain installed and unistalled app's uid dir.

    but it seems no help to you
    ----------------------------
    坚持学习, 坚持编码
    http://www.devdiv.net/
    qxiaoyuan

Similar Threads

  1. ActivePerl installation problem
    By Dark London in forum Symbian Tools & SDKs
    Replies: 3
    Last Post: 2009-01-16, 05:21
  2. Problems about maemo 4.0.1 SDK installation.
    By fgg_maemo in forum General Development Questions
    Replies: 3
    Last Post: 2008-10-07, 14:26
  3. S60 3rd MR SDK known installation problem
    By Mr.Y in forum Tools and SDK Feedback (Closed)
    Replies: 5
    Last Post: 2008-09-09, 19:04
  4. silent installation package....
    By GeKI in forum Symbian
    Replies: 1
    Last Post: 2006-12-14, 10:37
  5. Installation problem with Nokia Dev Suite for J2ME
    By anirvan in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2004-04-24, 14:52

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×