×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    4

    Question How to get HTML body of the POP3 message (email)

    Currently I'm accessing an email body in the following way:

    Code:
    	CMsvEntry* MsvEntry = iModel->GetMsvEntryL(EmailIndex - 1);
    	CPop3ClientMtm* Pop3Mtm = static_cast<CPop3ClientMtm*>(iModel->iClientReg->NewMtmL(KUidMsgTypePOP3);
    	CleanupStack::PushL(Pop3Mtm);
    
    	Pop3Mtm->SwitchCurrentEntryL(MsvEntry->EntryId());
    
    	Pop3Mtm->LoadMessageL();
    
    	if (MsvEntry->HasStoreL()) {
    
    		if (Pop3Mtm->HasContext()) {
    			CRichText& RichText = Pop3Mtm->Body();
    			TInt Length = RichText.DocumentLength();
    			
    			// here I can get email body text via RichText object
    		}
    	}
    
    	CleanupStack::PopAndDestroy(Pop3Mtm);
    BUT....
    The problem appears when the email cantains the HTML part only (there is no alternative text) - the Pop3Mtm->Body() is empty then.
    The S60_Platform_POP_IMAP_Example_v1_1 is able to simply parse the HTML boty and show it, but I've got no idea how to do that by my self... (without CBaseMtmUi)
    If you have some tip fell free to post it here
    Regards,
    --
    Jakub Kopera

    P.S. Confused with email recipient list? here are some tips
    http://discussion.forum.nokia.com/fo...d.php?t=150168

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: How to get HTML body of the POP3 message (email)

    Have you checked if it is then delivered as an attachment ?

Similar Threads

  1. problem with 8310 to send a Service loading push message
    By Nokia_Archive in forum General Messaging
    Replies: 2
    Last Post: 2002-10-10, 08:38
  2. problem to send a service loading message push for 8310
    By alinesimon in forum General Messaging
    Replies: 1
    Last Post: 2002-05-06, 12:39
  3. Problem to send a service loading push message for 8310
    By alinesimon in forum General Messaging
    Replies: 1
    Last Post: 2002-05-06, 11:19
  4. Problem to send a service loadinfd push message for 8310
    By alinesimon in forum Smart Messaging
    Replies: 1
    Last Post: 2002-05-03, 10:49

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×