×

Discussion Board

Results 1 to 3 of 3

Thread: Compass on N95

  1. #1
    Regular Contributor
    Join Date
    Sep 2007
    Posts
    78

    Compass on N95

    Hei

    Trying to use compass. Everything works greatly on 6210 bbut when using with N95 TRK gives:

    Load failed
    TRKProtocolPlugin: Failed to load the application. (Either installing the application may have failed or dependent libraries may be missing)

    So there are some missing libraries.
    The question is how to start the application without missing library forcing to use different versions of software. It easyly causes error to generate different versions with conditional compiling.

    BR

    Hannu

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Compass on N95

    Nokia 6210 is a S60 3rd Edition FP2 device while N95 is a S60 3rd Edition FP1.

    As the platform does not provide forward compatibility you should not expect that an application built for S60 3rd Edition FP2 would work on a FP1 device, especially when you know that the feature you intend to use is not in fact available on the device.

    Build your application with the S60 3rd Edition FP1, remove the unsupported features, and you will see your application working on N95 too.

    Alternatively, move your platform specific code in a DLL and load it dynamically only on the platform that supports it.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  3. #3
    Regular Contributor
    Join Date
    Sep 2007
    Posts
    78

    Re: Compass on N95

    Quote Originally Posted by ltomuta View Post
    Nokia 6210 is a S60 3rd Edition FP2 device while N95 is a S60 3rd Edition FP1.

    As the platform does not provide forward compatibility you should not expect that an application built for S60 3rd Edition FP2 would work on a FP1 device, especially when you know that the feature you intend to use is not in fact available on the device.

    Build your application with the S60 3rd Edition FP1, remove the unsupported features, and you will see your application working on N95 too.

    Alternatively, move your platform specific code in a DLL and load it dynamically only on the platform that supports it.
    OK,

    It seems like two versions: One with compass and second without. Both compiled with 3.2 or 5.0 .

    Somehow the combination Carbide 1.3 and S60 3.2 seems to work best in N95 and 6210

    Hannu

Similar Threads

  1. N95 Accelerometer & JSR-256
    By AnthonyAndrews in forum Mobile Java General
    Replies: 9
    Last Post: 2009-04-21, 22:12
  2. Replies: 84
    Last Post: 2008-03-04, 23:25
  3. Classic N95 vs US ver. N95
    By qwerty0824 in forum General Development Questions
    Replies: 5
    Last Post: 2007-09-13, 18:09
  4. N95 Some Questions & Suggestions
    By subzero_brighton in forum General Development Questions
    Replies: 0
    Last Post: 2007-06-22, 15:37

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×