×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 27
  1. #1
    Registered User
    Join Date
    Jun 2008
    Posts
    283

    Exclamation Vs.net 2005 can not read this sdk s60_2nd_fp2_sdk_msb

    i install all prerequist:
    1-active perl
    2-jdk
    3-vs enu sp1
    4-sdk (s60_2nd_fp2_sdk_msb)

    and force prerequist for carbide.vs.3.0.1

    and open .net and make new project (symbian),but
    when i click ok .net show error message (no available sdk)
    while i install it (s60_2nd_fp2_sdk_msb)

    please, helpe me
    Ahmed Mahfouz
    Researcher
    Handset

  2. #2
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,336

    Re: Vs.net 2005 can not read this sdk s60_2nd_fp2_sdk_msb

    If I am not mistaken then you need to use SDKs based on Code Warrior compiler for Carbide.vs 3.0.1 plugin.

    In your case, install "2nd Edition, FP2, CW(150 MB)" SDK from the dropdown list here: S60 Platform SDKs for Symbian OS, for C++
    Nokia Developer Wiki Moderation team

  3. #3
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Vs.net 2005 can not read this sdk s60_2nd_fp2_sdk_msb

    it is always recommended that you read the readme.txt that comes with SDK or tool or even the download page.

    from download page

    Carbide.vs 3.0 adds support for the latest S60 SDKs in Visual Studio 2005
    .NET:
    Series 60 SDK 2.0 for Symbian OS (WINSCW)
    Series 60 SDK 2.1 for Symbian OS (WINSCW)
    Series 60 2nd Edition SDK for Symbian OS, Supporting Feature Pack 2, For C++, English version (WINSCW)
    Series 60 2nd Edition SDK for Symbian OS, Supporting Feature Pack 3, For C++ (WINSCW)
    S60 3rd Edition SDK for Symbian OS, for C++ (not recommended)
    API Plug-In for the S60 3rd Edition SDK for Symbian OS, for C++, MR
    S60 3rd Edition SDK for Symbian OS, for C++, Japanese version
    API Plug-In for the S60 3rd Edition SDK for Symbian OS, for C++, supporting Feature Pack 1
    S60 3rd Edition SDK for Symbian OS, Supporting Feature Pack 2 Beta, For C++, English version (WINSCW)
    Open C SDK Plug-In for S60 3rd Edition SDKs, for Symbian OS, for C++

  4. #4
    Registered User
    Join Date
    Jun 2008
    Posts
    283

    Question Re: Vs.net 2005 can not read this sdk s60_2nd_fp2_sdk_msb

    Quote Originally Posted by kiran10182 View Post
    If I am not mistaken then you need to use SDKs based on Code Warrior compiler for Carbide.vs 3.0.1 plugin.

    In your case, install "2nd Edition, FP2, CW(150 MB)" SDK from the dropdown list here: S60 Platform SDKs for Symbian OS, for C++
    when i remove (s60_2nd_fp2_sdk_msb(142mb)) an error message appears
    and i install (s60_2nd_fp2_sdk(150mb)) when reach for last of installation 2 check box appear :
    1- s60_2nd_fp2
    2- s60_2nd_fp2_cw

    what of them i can select?
    Ahmed Mahfouz
    Researcher
    Handset

  5. #5
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Vs.net 2005 can not read this sdk s60_2nd_fp2_sdk_msb

    you should select (2) that is non-msb(CW) vesion

  6. #6
    Registered User
    Join Date
    Jun 2008
    Posts
    283

    Question Re: Vs.net 2005 can not read this sdk s60_2nd_fp2_sdk_msb

    in the previous SDK(s60_2nd_fp2_msb) it's not recognizable by .net and show message there is no sdk available and i open file ..\devices.xml and change device id from"s60_2nd_fp2" to "s60_2nd_fp2_cw" .net recognize it

    this change effect for another SDK?
    Ahmed Mahfouz
    Researcher
    Handset

  7. #7
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Vs.net 2005 can not read this sdk s60_2nd_fp2_sdk_msb

    no it must not be done, AFAIK you have to use CW SDKs for Carbide.vs Plugin

  8. #8
    Registered User
    Join Date
    Jun 2008
    Posts
    283

    Question Re: Vs.net 2005 can not read this sdk s60_2nd_fp2_sdk_msb

    when create new symbian project and select installed sdk and build project error message appear:

    Error 1 error RES: cpp.exe failed with code -1. (Reason: Unknown error) CompileItem
    Ahmed Mahfouz
    Researcher
    Handset

  9. #9
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Vs.net 2005 can not read this sdk s60_2nd_fp2_sdk_msb

    looks like you have resolved the plugin installation problem. what i can guess this error is due to changes in your device files and sdk files.

  10. #10
    Registered User
    Join Date
    Jun 2008
    Posts
    283

    Re: Vs.net 2005 can not read this sdk s60_2nd_fp2_sdk_msb

    when i retrive device id an error cause in compilation process sdk not installed
    Ahmed Mahfouz
    Researcher
    Handset

  11. #11
    Registered User
    Join Date
    Jun 2008
    Posts
    283

    Re: Vs.net 2005 can not read this sdk s60_2nd_fp2_sdk_msb

    when change in xml file in C:\Program Files\Common Files\Symbian\SDK Descriptors\Nokia\S60_2nd_FP2_v3.xml

    in device id sdk appears in sdk configuration manager and not available
    Ahmed Mahfouz
    Researcher
    Handset

  12. #12
    Registered User
    Join Date
    Jun 2008
    Posts
    283

    Re: Vs.net 2005 can not read this sdk s60_2nd_fp2_sdk_msb

    pleassssssssssssssssss, i stray with all sdk's

    i dowenload many sdk and read releasenotes and i have 6600 target device
    and i have os xp sp2,
    vs.net 2005,install carbid.vs3.0.1
    and all prerequist install and forcepre requist

    i'm strayyyyyyyyyyyyyy
    Ahmed Mahfouz
    Researcher
    Handset

  13. #13
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,355

    Re: Vs.net 2005 can not read this sdk s60_2nd_fp2_sdk_msb

    OK, let's review. Your phone is something called 6600. Would that be the Nokia 6600, the Nokia 6600 slide or the Nokia 6600 fold?

    If you have the first one then you likely have the wrong SDK. If you have one of the other two then you are trying to work with the wrong technology.

    Let's clarify this first and then we move towards addressing the rest of the problems, whichever they might be.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  14. #14
    Registered User
    Join Date
    Jun 2008
    Posts
    283

    Question Re: Vs.net 2005 can not read this sdk s60_2nd_fp2_sdk_msb

    Quote Originally Posted by ltomuta View Post
    OK, let's review. Your phone is something called 6600. Would that be the Nokia 6600, the Nokia 6600 slide or the Nokia 6600 fold?

    If you have the first one then you likely have the wrong SDK. If you have one of the other two then you are trying to work with the wrong technology.

    Let's clarify this first and then we move towards addressing the rest of the problems, whichever they might be.
    OK, let's review and analys the problem:

    1.phone 6600 neither fold nor slide implies developer platfrom ->S60 2nd Edition (initial release).
    2.i'm c++ developer use vs.net 2005 implise i would like use vs.net to develope mobile application.

    from above clause:

    1. which sdk can i use that are compatible with vs.net 2005 and with my target device 6600 initial release?
    Ahmed Mahfouz
    Researcher
    Handset

  15. #15
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,355

    Re: Vs.net 2005 can not read this sdk s60_2nd_fp2_sdk_msb

    Quote Originally Posted by ahmed mohamed mahfouz View Post
    OK, let's review and analys the problem:

    1.phone 6600 neither fold nor slide implies developer platfrom ->S60 2nd Edition (initial release).
    2.i'm c++ developer use vs.net 2005 implise i would like use vs.net to develope mobile application.

    from above clause:

    1. which sdk can i use that are compatible with vs.net 2005 and with my target device 6600 initial release?
    The "S60 2nd Edition (initial release)" means basically the S60 2nd Edition SDK (no feature pack). Now, as this SDK is available in two versions, for Microsoft and Metrowerks compilers, you need to make sure you chose the right one.

    So, we're back at the tools. You have Visual Studio 2005 so we need to find the version of the Carbide.vs plug-in that works with it. There are two version of the plug-in currently available but only version 3.0.1 is compatible with Visual Studio 2005.

    Now we have to check if Carbide.vs 3.0.1 is compatible with the S60 2nd Edition SDK and if so, which version. From plug-in's data sheet we find that
    Supported Symbian OS SDKs

    Carbide.vs 3.0 provides support for the following Symbian OS SDKs:
    S60 2nd Edition SDK for Symbian OS, for C++, supporting
    CodeWarrior

    • S60 2nd Edition SDK for Symbian OS, for C++, supporting Feature
    Pack 1, supporting CodeWarrior
    ...
    We have a match and the SDK we need is available for download at S60 Platform SDKs for Symbian OS, for C++ under the name "2nd Edition, CW (107 MB)"

    While downloading this SDK make sure to read the corresponding release notes (from the same page) with special focus on the recommended version of Perl.
    Last edited by ltomuta; 2008-11-29 at 13:50.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

Similar Threads

  1. Symbian S80 SDK & VS 2005
    By VirGin in forum Symbian Tools & SDKs
    Replies: 23
    Last Post: 2007-10-04, 08:08
  2. can nokia sdk 2.1 read two attatched mobile phones in one pc?
    By sms_gateway_help in forum Tools and SDK Feedback (Closed)
    Replies: 1
    Last Post: 2007-08-19, 14:28
  3. How to know Socket has read the full message form a server in SDK socket example?
    By Mohan Kumar in forum Symbian Networking & Messaging (Closed)
    Replies: 2
    Last Post: 2007-06-22, 16:26
  4. Replies: 1
    Last Post: 2005-12-26, 14:04

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •