×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Dec 2008
    Posts
    4

    TRK 3.0.8 not working in Carbide 2.0

    I've downloaded and installed the latest Carbide 2.0 IDE but am having problems performing on device debugging. It looks like Carbide 2.0 doesn't support TRK 3 connections (which I require for my device - N85).

    Help > On-Device Connections...
    The only TRK connection listed is "TRK 2.x USB". If I select this, and go to "TRK 2.x USB Settings" only TRK 2.8.9 is listed in the "Install remote agent" tab. I attempted to run the install, and the install failed on about 50%. According to the following thread, I need TRK 3 for the N85:-
    http://discussion.forum.nokia.com/fo...d.php?t=146545

    Interestingly TRK 3.0.8 is available in the IDE program files folder:-
    C:\Program Files\Nokia\Carbide.c++ v2.0\plugins\com.nokia.carbide.trk.support_1.4.0.014\trk\s60

    I tried installing that manually, and the install succeeded. However I cannot use the "TRK 2.x USB" setting in Carbide - the "Initiate service testing" button, just produces:-
    Error: TRK did not respond

    Additional info:-
    Device: N85
    SDK: S60 3rd ed FP 2
    IDE: Carbide 2.0
    Connection: USB cable

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,674

    Re: TRK 3.0.8 not working in Carbide 2.0

    I think this may also apply to your case: http://discussion.forum.nokia.com/fo...d.php?t=150936

  3. #3
    Nokia Developer Expert
    Join Date
    Oct 2004
    Location
    Austin, TX USA
    Posts
    271

    Re: TRK 3.0.8 not working in Carbide 2.0

    "However I cannot use the "TRK 2.x USB" setting in Carbide"

    In addition to the information above about TRK 3.0.8 being blocked, this is the wrong connection type for TRK 3.x. Use the "USB" setting instead for TRK 3.x. The other one is for TRK 2.x only.

    Regards,

    Matt P.

  4. #4
    Registered User
    Join Date
    Dec 2008
    Posts
    4

    Post Re: TRK 3.0.8 not working in Carbide 2.0

    Thanks for the advice. I've successfully setup the connection using the "USB" option, and not only did the connection tests succeed, but I have also successfully run and debugged the app on the device.

Similar Threads

  1. Build is disabled in Carbide v1.3 !!!
    By mockba in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 5
    Last Post: 2008-07-29, 09:26
  2. Carbide versus Carbide Visual Studio
    By VirGin in forum Symbian Tools & SDKs
    Replies: 6
    Last Post: 2008-07-10, 02:56
  3. Carbide VS 2.0 fails to launch registration
    By kpoxa in forum Symbian Tools & SDKs
    Replies: 9
    Last Post: 2006-11-01, 01:32
  4. Replies: 0
    Last Post: 2005-11-02, 15:31
  5. I've got my CARDPHONE 2.0 working, here's how
    By Nokia_Archived in forum Multimodecards
    Replies: 0
    Last Post: 2002-05-21, 19:31

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×