×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Registered User
    Join Date
    Feb 2005
    Posts
    8

    Reinstall S60 SDK from a backup

    Hi,

    Do S60 SDKs (3rd edition, MR) allow restoring the SDK to original state by restoring from a backup?

    I tried the following
    - installed the SDK
    - took a backup of C:\Symbian\9.1\S60_3rd_MR to another directory (using a backup program)
    - used SDK for development (developed an app using networking, not bluetooth; see below)
    - restored the content of C:\Symbian\9.1\S60_3rd_MR from the backup

    After doing this a couple of times the emulator started to report a panic in one component (see the message below). Is it possible that SDKs do not allow this kind of backup-restore?

    App. closed:
    !BTManServer
    BT RegistryDB Pa 1

    Best, Mikko

  2. #2
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Reinstall S60 SDK from a backup

    if you delete the SDK before you restore it might work.

  3. #3
    Registered User
    Join Date
    Feb 2005
    Posts
    8

    Re: Reinstall S60 SDK from a backup

    Quote Originally Posted by skumar_rao View Post
    if you delete the SDK before you restore it might work.
    Are there some files which my backup program would not be able to restore?

    (I am assuming that the program overwrites all changed files found from backup and deletes others.)

    Best, Mikko

  4. #4
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Reinstall S60 SDK from a backup

    Quote Originally Posted by msuonio View Post
    Are there some files which my backup program would not be able to restore?

    (I am assuming that the program overwrites all changed files found from backup and deletes others.)

    Best, Mikko
    also emulator crates some times in windows Temp File.

  5. #5
    Registered User
    Join Date
    Feb 2005
    Posts
    8

    Re: Reinstall S60 SDK from a backup

    Quote Originally Posted by skumar_rao View Post
    also emulator crates some times in windows Temp File.
    I see. I found some files which seem to be related to symbian in temp directory (subdir epoc and epocwind.out). I deleted most of the files in the temp directory. However, bt still panics when I start the emulator.

    I also tried the repair option in SDK installer (without rebooting), but that did not help.

    (My goal is to find a way to quickly reinstall the SDK.)

    Best, Mikko

  6. #6
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Budapest, Hungary
    Posts
    28,570

    Re: Reinstall S60 SDK from a backup

    Temp is not really important. That is why it is 'temp'.
    The strange thing is that I am using a similar approach, from time to time I simply delete the complete epoc32 folder, and restore it from a backup. And it works actually (in case of S60 3rd MR, I have installed it on the day it was released, and restored it for at least ~50 times by now).
    However if you install various plugins, and do not refresh your backup, that may cause problems (because the registry might 'remember' that you have installed some extra parts). In your particular case of BT, have you experimented with the custom BT driver? Was it installed when you took the backup? Is it installed now?

  7. #7
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Reinstall S60 SDK from a backup

    me too delete the Symbian\<SDK> folder and copy fresh one from my backup. But now i realized i am stupid, i should have replacing Epoc only [thanks wizard]

  8. #8
    Registered User
    Join Date
    Feb 2005
    Posts
    8

    Re: Reinstall S60 SDK from a backup

    Quote Originally Posted by wizard_hu_ View Post
    Temp is not really important. That is why it is 'temp'.
    The strange thing is that I am using a similar approach, from time to time I simply delete the complete epoc32 folder, and restore it from a backup. And it works actually (in case of S60 3rd MR, I have installed it on the day it was released, and restored it for at least ~50 times by now).
    However if you install various plugins, and do not refresh your backup, that may cause problems (because the registry might 'remember' that you have installed some extra parts). In your particular case of BT, have you experimented with the custom BT driver? Was it installed when you took the backup? Is it installed now?
    I deleted the epoc32 folder and restored everything from backup. Now it seems to work and bt does not panic.

    A pity that restoring without deleting does not work. With bigger (nonpublic) SDKs it would faster to be able to just restore changed files, I think.

    Best, Mikko

Similar Threads

  1. How to integrate wtk 2.5.2 with Nokia S60 SDK?
    By hennry2000 in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2009-05-12, 17:21
  2. Replies: 5
    Last Post: 2007-05-22, 09:49
  3. Need S60 SDK 2.6 to install SIP plug-in4 ?
    By xjdong in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2006-02-07, 05:05
  4. Problem: S60 SDK for CW in PC with .NET
    By anttij in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2005-02-28, 11:36
  5. Almost all tools (S60 MIDP SDK B0.1, Nokia S60 SDK Symbian OS v0.3) Crashes
    By alexandershalamov in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2002-07-03, 13:44

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •