×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 18
  1. #1
    Regular Contributor
    Join Date
    Sep 2008
    Posts
    54

    Unhappy app not running on memory card

    hi,
    i made two application one is gui and other i m using it as an exe in the first one.when i am installing in phone memory every thing is perfectly fine and running but when i m installing it in memory card,exe is not running and gui is working fine.all the files of app(using as hidden so calling it exe) are copied into desired location i.e in e: drive.
    even the appui part of exe is not getting executed.On checking with task spy it is giving kern exec 0.
    please suggest something.


    thanks
    mayank
    Last edited by mayankkodesia; 2008-12-10 at 06:26.

  2. #2
    Super Contributor
    Join Date
    Jul 2007
    Posts
    596

    Re: app not running on memory card

    check your pkg file and also in aplication code wheather there is any hard-coded paths for c:\ drive.


    thanks

  3. #3
    Regular Contributor
    Join Date
    Sep 2008
    Posts
    54

    Unhappy Re: app not running on memory card

    hi,
    in application when i m installing the main app all the file are installed in the e: drive and if trying to launch from e:
    drive again it is showing kern exec 0 and not entering in the appui of app(exe).


    thanks
    mayank

  4. #4
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: app not running on memory card

    Quote Originally Posted by mayankkodesia View Post
    hi,
    in application when i m installing the main app all the file are installed in the e: drive and if trying to launch from e:
    drive again it is showing kern exec 0 and not entering in the appui of app(exe).


    thanks
    mayank
    what kishor is referring to is in you "application code" did you check if any where you have a hardcoded path,

  5. #5
    Regular Contributor
    Join Date
    Sep 2008
    Posts
    54

    Unhappy Re: app not running on memory card

    hi,
    yes i check for that and also code shud be crashed later on no?
    but its not getting in Appui.
    waiting for suggestions!!!!!!11

    thanks
    mayank

  6. #6
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,169

    Re: app not running on memory card

    Kern-Exec 0 would indicate that there is a R-Class object that is used without initializing it correctly. So check you code, and see which R-Classes you are using, and see if you handle the error codes etc. correctly.

  7. #7
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,751

    Re: app not running on memory card

    And you may still consider doing a search for "c: in your source code...

  8. #8
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: app not running on memory card

    You may also consider placing a breakpoint within the entry point and then execute the application step-by-step to see where it takes you.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  9. #9
    Nokia Developer Expert
    Join Date
    Jun 2008
    Posts
    333

    Re: app not running on memory card

    I agree with ltomuta.
    Try to use log file to locate the detail place where you get the error.

  10. #10
    Registered User
    Join Date
    Oct 2010
    Posts
    6

    Re: app not running on memory card

    Hi,

    I am also facing this problem. If I install my sis in phone memory, it is getting listed in the applications under menu. If I install it in external memory, it is not getting listed in the applications. But in settings if i go to installed applications it is showing that the app is installed in external memory card. My phone is Nokia 5800. Any help, thanks in advance.

    Regards,
    Saranya

  11. #11
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,751

    Re: app not running on memory card

    You probably have some hard-coded reference to c: as it has been discussed in this thread already, just in a different context.

  12. #12
    Registered User
    Join Date
    Oct 2010
    Posts
    6

    Re: app not running on memory card

    I have made a search in my carbide c++ project for C: No where in cpp or h files I could find the hard coding. In the project workspace I could see a .cproject file. In that I have some line like this.
    <ROM_BUILDER_DATA_ID ROMBUILDWORKINGDIRECTORYSTORAGE="C:\"/>

    Will this be the reason?

  13. #13
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,751

    Re: app not running on memory card

    I guess not, you are not building a ROM, at least as I understand.

  14. #14
    Registered User
    Join Date
    Oct 2010
    Posts
    6

    Re: app not running on memory card

    Fine... I am developing using carbide c++ as I told in my earlier post. Are there any settings to be done in carbide project before building, to solve this issue?

  15. #15
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,751

    Re: app not running on memory card

    Also check for file access attempts without drive letters (like "\\resource\\apps\\my.picture.mbm"), only in the C++ code (it is normal to have such file references in resource files). "Current" drive might be c: even for applications installed to other drives. CompleteWithAppPath or RProcess().FileName().Left(2) can deliver you the drive letter.

Similar Threads

  1. Automatic install from memory card fails
    By forester404 in forum Symbian
    Replies: 1
    Last Post: 2008-02-06, 08:15
  2. Problem reinstalling app in memory card
    By felixksp in forum Symbian
    Replies: 2
    Last Post: 2007-12-17, 16:24
  3. Memory Full Error on Nokia6600 running MIDlet Application
    By tbechnati in forum Mobile Java General
    Replies: 0
    Last Post: 2004-05-02, 14:19
  4. Replies: 0
    Last Post: 2003-03-06, 18:22

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×