×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Dec 2008
    Posts
    2

    rtsp video link not getting played in N96

    I have created a player code which plays a rtsp video in N95. If i test the same code in N96, it doesnt work fine and shows an error : Prefetch -34 . Can anyone clarify me how to play rtsp link in N96 ?

  2. #2
    Super Contributor
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,191

    Re: rtsp video link not getting played in N96

    You are talking about a MIDlet doing the streaming, right?
    Have you set the network preferences in the RealPlayer, as the Java implementation uses those for streaming

    Hartti

  3. #3
    Registered User
    Join Date
    Dec 2008
    Posts
    3

    Re: rtsp video link not getting played in N96

    Quote Originally Posted by hartti View Post
    You are talking about a MIDlet doing the streaming, right?
    Have you set the network preferences in the RealPlayer, as the Java implementation uses those for streaming

    Hartti
    Hi Hartti,
    I'm using N96 for streaming rtsp video. You mention about setting network preferences in the RealPlayer. What exactly do I need to setup? I set the default access point and the UDP port for streaming preferences. What else do I need to setup?

    Another question is that if I want to play a rtsp video do I just need to call the function below?

    Player player = Manager.createPlayer("rtsp://serverip:554/sample_100kbit.mp4");
    player.realize();
    player.start();

    How does the streaming data direct to realplayer?

    When I setup the player and run realize(). I got the error message of "Realize error: -7002"

    hope you can help me~~
    or give me some advice
    thanks

  4. #4
    Super Contributor
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,191

    Re: rtsp video link not getting played in N96

    The Java ME streaming inplementation on S60 devices uses RealPlayer in the background (still within the UI of teh MIDlet). The method call to create the player is like you pointed out.

    Also the default access point is the main one to set up in the realplayer network settings

    Can you play the stream you pointed out directly in the RealPlayer? If yes, could you try to use a narrower stream?

    Hartti

  5. #5
    Nokia Developer Expert
    Join Date
    Aug 2007
    Posts
    1,595

    Re: rtsp video link not getting played in N96

    Hello neelSaysHai and zepptime,

    I have created a player code which plays a rtsp video in N95. If i test the same code in N96, it doesnt work fine and shows an error : Prefetch -34 . Can anyone clarify me how to play rtsp link in N96 ?
    This is a known issue and our internal experts are investigating it. I'll document this to Forum Nokia Wiki.

    Solution: use the native S60 browser to establish network connection, put the browser on background and launch the RTSP Java app.

    Regards,
    r2j7
    [URL="http://library.forum.nokia.com/java"][B] >>> Java Developer's Library <<<[/B][/URL]
    [URL="https://www.developer.nokia.com/Resources/Support/Technical_support.xhtml"] [B]>>> Technical Support for Java ME development <<<[/B][/URL]
    [URL="https://publish.ovi.com/info/"][B]>>> Nokia Publish: reach millions of Nokia users worldwide through Nokia Store <<<[/B][/URL]

  6. #6
    Registered User
    Join Date
    Aug 2007
    Posts
    40

    Re: rtsp video link not getting played in N96

    Player in N95 and N96 are different

    N95 uses RealPlayer - Commercial version
    N96 uses RealPlayer - Open source Helix Player.

    In N96 I am not able set default access point in the helix player.
    Error code -34 is Network related Error.

    I had to set it in the my code it self, after that it worked properly on both devices.
    I hope this will solve your problem.


    Quote Originally Posted by r2j7 View Post
    Hello neelSaysHai and zepptime,



    This is a known issue and our internal experts are investigating it. I'll document this to Forum Nokia Wiki.

    Solution: use the native S60 browser to establish network connection, put the browser on background and launch the RTSP Java app.

    Regards,
    r2j7

  7. #7
    Registered User
    Join Date
    Dec 2008
    Posts
    3

    Re: rtsp video link not getting played in N96

    Dear paijwar and r2j7 and hartti,
    I can set the default access point now in the network settings section and it works perfect. I got the Error code -34 before and I solved it by setting up the default access point in the network settings and disabling the firewall on my computer.

    I noticed that paijwar mentioned about setting up the access about in your code. Can you give me an example of how to setup the default access point in code. I think it is very inconvenient to setup the default access point manually.

    It's very interesting that N96 doesn't support "streamable.contents" but it supports rtsp protocol. If it supports rtsp protocol why can't support streaming contents? I thought to use rtsp is to use streaming contents. I solved the interesting problem by trying the code from "Experiments in Streaming Content in JavaME" from http://blog.csdn.net/feidragon319/ar...3/1740539.aspx and it just needed some modifications. Just exclude the file of "RTSPProtocolHandler" from the code and includes the StreamingDataSource and RTPSourceStream and then it can start streaming on N96.

    However, what if I want to modify the RTSP protocol on N96?
    Does anyone have any idea?
    Quote Originally Posted by paijwar View Post
    Player in N95 and N96 are different

    N95 uses RealPlayer - Commercial version
    N96 uses RealPlayer - Open source Helix Player.

    In N96 I am not able set default access point in the helix player.
    Error code -34 is Network related Error.

    I had to set it in the my code it self, after that it worked properly on both devices.
    I hope this will solve your problem.

Similar Threads

  1. Only audio is being played but no video using CVideoPlayerUtility
    By Agent Ethan Hunt in forum Symbian Media (Closed)
    Replies: 6
    Last Post: 2007-08-24, 12:16
  2. RTSP video streaming on S60 SDKs?
    By robbin123 in forum Symbian
    Replies: 2
    Last Post: 2006-06-08, 19:02

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×