×

Discussion Board

Results 1 to 13 of 13
  1. #1
    Registered User
    Join Date
    Jun 2008
    Posts
    11

    Exclamation _reg.rsg file is empty

    My application is giving me an empty _reg.rsg file. Why is that? Please help..

    Thanks in advance!

    Sherif

  2. #2
    Nokia Developer Champion
    Join Date
    Jul 2007
    Location
    ShenZhen, China
    Posts
    4,346

    Re: _reg.rsg file is empty

    copy and edit C:\Symbian\9.2\S60_3rd_FP1\S60Ex\HelloWorldBasic\data\HelloWorldBasic_reg.rss for your project.
    ----------------------------
    坚持学习, 坚持编码
    http://www.devdiv.net/
    qxiaoyuan

  3. #3
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Budapest, Hungary
    Posts
    28,572

    Re: _reg.rsg file is empty

    The compiled version of the _reg.rss file is intended to be used by the Menu application, that is why you normally do not need a _reg.rsg file for it. Also note that .rsg files do not contain identifiers for unnamed resources, and that is the default case for _reg.rss files (you have a single unnamed APP_REGISTRATION_INFO in it).

  4. #4
    Registered User
    Join Date
    Jun 2008
    Posts
    11

    Re: _reg.rsg file is empty

    So, i am not supposed to get an empty _reg.rsg file? Would this happen if the application is having a problem in reading my resources?

  5. #5
    Registered User
    Join Date
    Jun 2008
    Posts
    11

    Re: _reg.rsg file is empty

    Quote Originally Posted by wizard_hu_ View Post
    The compiled version of the _reg.rss file is intended to be used by the Menu application, that is why you normally do not need a _reg.rsg file for it. Also note that .rsg files do not contain identifiers for unnamed resources, and that is the default case for _reg.rss files (you have a single unnamed APP_REGISTRATION_INFO in it).
    OK, i am observing something else in my build that i would like to mention here.. In one of the View.cpp files, i include <application.rsg> and use a view resource (APPLICATIONNAME_VIEW) that was defined in the rss file. However, upon building the application, i always get this error: undefined identifier APPLICATIONNAME_VIEW. Would this mean that the builder is failing to build my resources? given that it has successfully built the rest of the resources :S

    I am using Carbide.vs 3 over Visual Studio 2005.

    Thanks in advance.

  6. #6
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: _reg.rsg file is empty

    Quote Originally Posted by sheriftawfik View Post
    OK, i am observing something else in my build that i would like to mention here.. In one of the View.cpp files, i include <application.rsg> and use a view resource (APPLICATIONNAME_VIEW) that was defined in the rss file. However, upon building the application, i always get this error: undefined identifier APPLICATIONNAME_VIEW. Would this mean that the builder is failing to build my resources? given that it has successfully built the rest of the resources :S

    I am using Carbide.vs 3 over Visual Studio 2005.

    Thanks in advance.
    can you show us your _res.rss file.

  7. #7
    Registered User
    Join Date
    Jun 2008
    Posts
    11

    Re: _reg.rsg file is empty

    my _reg.rss file is as follows:

    #include <appinfo.rh>

    UID2 KUidAppRegistrationResourceFile
    UID3 0xXXXXX

    RESOURCE APP_REGISTRATION_INFO
    {
    app_file="MyApplication";
    }

  8. #8
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Budapest, Hungary
    Posts
    28,572

    Re: _reg.rsg file is empty

    I think you have accidentally overlooked the fact that in Symbian 9 (S60 3rd / 5th) a GUI application comes with two resource files:

    xy.rss, which is the application's own resource file:
    - it is compiled with the HEADER keyword, so there will be a xy.rsg amongst the includes
    - this is the file which may contain your view something, however we do not know unless you show
    - xy.rsc (the compiled resource) is going to be deployed to \resource\apps

    xy_reg.rss, which is the registration file meant to be used by the Menu application
    - normally it is compiled without the HEADER keyword, so xy_reg.rsg is not generated
    - it contains a single unnamed APP_REGISTRATION_INFO resource (as you can check in yours), so xy_reg.rsg would not be an exciting reading anyway
    - it is going to be deployed in \private\10003a3f\[import\]apps

    If you have problems with some view resource, show it.

  9. #9
    Registered User
    Join Date
    Jun 2008
    Posts
    11

    Unhappy Re: _reg.rsg file is empty

    Quote Originally Posted by wizard_hu_ View Post
    I think you have accidentally overlooked the fact that in Symbian 9 (S60 3rd / 5th) a GUI application comes with two resource files:

    xy.rss, which is the application's own resource file:
    - it is compiled with the HEADER keyword, so there will be a xy.rsg amongst the includes
    - this is the file which may contain your view something, however we do not know unless you show
    - xy.rsc (the compiled resource) is going to be deployed to \resource\apps

    xy_reg.rss, which is the registration file meant to be used by the Menu application
    - normally it is compiled without the HEADER keyword, so xy_reg.rsg is not generated
    - it contains a single unnamed APP_REGISTRATION_INFO resource (as you can check in yours), so xy_reg.rsg would not be an exciting reading anyway
    - it is going to be deployed in \private\10003a3f\[import\]apps

    If you have problems with some view resource, show it.
    Thanks for your explanation. It was useful to me.

    Please find below the part of the RSS file that is problematic:
    --------------------------------
    RESOURCE AVKON_VIEW r_primatranz_schedule_view
    {
    menubar = r_primatranz_schedule_menubar;
    cba = R_AVKON_SOFTKEYS_SELECTION_LIST;
    }

    RESOURCE MENU_BAR r_primatranz_schedule_menubar
    {
    titles =
    {
    MENU_TITLE { menu_pane = r_primatranz_app_menu; txt = "App"; },
    MENU_TITLE { menu_pane = r_primatranz_schedule_menu; txt = "View"; }
    };
    }

    RESOURCE MENU_PANE r_primatranz_schedule_menu
    {
    items =
    {
    MENU_ITEM
    {
    command = EHelp;
    txt = s_help;
    },
    MENU_ITEM
    {
    command = EAbout;
    txt = s_about;
    },
    MENU_ITEM
    {
    command = EAknSoftkeyExit;
    txt = s_exit;
    }
    };
    }
    ---------------------------------------------------
    In the *.rsg file, I find the above resources already assigned numbers (in the #define statements), but when I am trying to use any of these resources (i already have #include "XXX.rsg" in my code), i get the compile error: identifier not defined! But the rest of the identifiers (in *.rsg file) do not suffer from the same problem.. That's wierd!

    Please help..

    **By the way: I keep on searching for the *.rsc file, but i never find it. Does this mean there is something serious with my rss file?

    Regards,
    Sherif

  10. #10
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Budapest, Hungary
    Posts
    28,572

    Re: _reg.rsg file is empty

    Quote Originally Posted by sheriftawfik View Post
    RESOURCE AVKON_VIEW r_primatranz_schedule_view
    ---------------------------------------------------
    In the *.rsg file, I find the above resources already assigned numbers (in the #define statements), but when I am trying to use any of these resources (i already have #include "XXX.rsg" in my code), i get the compile error: identifier not defined! But the rest of the identifiers (in *.rsg file) do not suffer from the same problem..
    Make sure that you are #include-ing the same .rsg file what you see:
    - #include <xy.rsg> would be better syntax, since the file is generated in the middle of the SDK (epoc32\include), so it is a system include
    - make sure that you have no xy.rsg (probably an outdated one) copied directly to your project
    **By the way: I keep on searching for the *.rsc file, but i never find it. Does this mean there is something serious with my rss file?
    If you can not find xy.rsc in epoc32\data\z\resource\apps (after a target build) or epoc32\release\winscw\udeb\z\system\apps (after an emulator build), that is a problem. However this is unlikely, since in this case you would not get the #define-s for the new resources.

  11. #11
    Registered User
    Join Date
    Jun 2008
    Posts
    11

    Unhappy Re: _reg.rsg file is empty

    Quote Originally Posted by wizard_hu_ View Post
    Make sure that you are #include-ing the same .rsg file what you see:
    - #include <xy.rsg> would be better syntax, since the file is generated in the middle of the SDK (epoc32\include), so it is a system include
    - make sure that you have no xy.rsg (probably an outdated one) copied directly to your project
    I already did the above..
    Quote Originally Posted by wizard_hu_ View Post
    If you can not find xy.rsc in epoc32\data\z\resource\apps (after a target build) or epoc32\release\winscw\udeb\z\system\apps (after an emulator build), that is a problem. However this is unlikely, since in this case you would not get the #define-s for the new resources.
    But I really can't find .rsc anywhere! And the strange thing is that one application was successfully running without finding any rsc for it!

    I am copying my pkg file below:
    ; PrimaTranZ.pkg
    ;
    ;Language - standard language definitions
    &EN

    ;Standard SIS file header
    #{"PrimaTranZ"},(0xecb6ce86),1,0,0

    ;Localised Vendor name
    %{"PrimaTranZ-EN"}

    ;Unique Vendor name
    :"PrimaTranZ"

    ;Supports Series 60 v 3.0
    [0x101F7961], 0, 0, 0, {"Series60ProductID"}

    ;Files to install
    "..\..\..\epoc32\release\armv5\urel\PrimaTranZ.exe" -"!:\sys\bin\PrimaTranZ.exe"
    "..\..\..\epoc32\data\z\resource\apps\PrimaTranZ.rsc" -"!:\resource\apps\PrimaTranZ.rsc"
    "..\..\..\epoc32\data\z\resource\apps\PrimaTranZ_reg.mif" -"!:\resource\apps\PrimaTranZ_reg.mif"
    "..\..\..\epoc32\data\z\private\10003a3f\apps\PrimaTranZ_reg.rsc" -"!:\private\10003a3f\import\apps\PrimaTranZ_reg.rsc"
    "..\help\PrimaTranZ_0xecb6ce86.hlp" -"!:\resource\help\PrimaTranZ_0xecb6ce86.hlp"
    "..\group\PrivacyStatement.txt" -"!:\private\ecb6ce86\PrivacyStatement.txt"

    ;Required for application to be covered by backup/restore facility
    "backup_registration.xml" -"!:\private\ecb6ce86\backup_registration.xml"

    By the way, I removed the resources that were causing trouble, and now I am getting CONE 14 error! Please help..

  12. #12
    Registered User
    Join Date
    Jun 2008
    Posts
    11

    Re: _reg.rsg file is empty

    wizard_zu,

    I did some debugging of my code, and discovered that my view resources in my rss file are not accepted by the emulator. The emulator gives CONE 14 error when the code reaches "ConstructFromResource(XYZ_VIEW). The view resource that is causing the trouble is copied below:
    ---------------------------------------------------
    RESOURCE AVKON_VIEW r_primatranz_schedule_view
    {
    menubar = r_primatranz_schedule_menubar;
    cba = R_AVKON_SOFTKEYS_SELECTION_LIST;
    }

    RESOURCE MENU_BAR r_primatranz_schedule_menubar
    {
    titles =
    {
    MENU_TITLE { menu_pane = r_primatranz_app_menu; txt = "App"; },
    MENU_TITLE { menu_pane = r_primatranz_schedule_menu; txt = "View"; }
    };
    }

    RESOURCE MENU_PANE r_primatranz_schedule_menu
    {
    items =
    {
    MENU_ITEM
    {
    command = EHelp;
    txt = s_help;
    },
    MENU_ITEM
    {
    command = EAbout;
    txt = s_about;
    },
    MENU_ITEM
    {
    command = EAknSoftkeyExit;
    txt = s_exit;
    }
    };
    }
    ------------------------------------------------------
    is there anything wrong here?

  13. #13
    Registered User
    Join Date
    Jun 2008
    Posts
    11

    Re: _reg.rsg file is empty

    I am going to start a new thread for this special request. Hope to find you there!

Similar Threads

  1. Error : Cannot find file : for DUMMIES
    By PACALA_BA in forum Symbian
    Replies: 7
    Last Post: 2008-07-06, 13:18
  2. [announce] PyUIQ. Python for UIQ 2.1 and 3.x
    By OscarBernabeu in forum Symbian
    Replies: 35
    Last Post: 2008-01-17, 09:12
  3. Replies: 2
    Last Post: 2007-11-07, 07:55
  4. No library file found matching 'libedll.lib{.lib|.a}' or 'edll.lib'
    By manish_mishra2005 in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 5
    Last Post: 2007-08-28, 21:23
  5. Series 60 SDK Appwizard on windows xp
    By moonjoor in forum Symbian Tools & SDKs
    Replies: 15
    Last Post: 2003-12-24, 10:22

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •