×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Regular Contributor
    Join Date
    Nov 2006
    Posts
    51

    TAiwDialDataV1 and TAiwDialDataV1Pckg not working in 3rd edition FP2

    Hi,
    Does anyone encounter this problem? I have the following codes to do a voice call and it is working fine in 3rd edition FP1. However it does not work in 3rd edition FP2, when the codes are run, nothing happens.

    // Create AIW param package
    TAiwDialDataV1 data;
    TAiwDialDataV1Pckg dataPckg( data );
    data.SetTelephoneNumber( aData );
    data.SetCallType( EAiwVoice );

    data.SetWindowGroup(CCoeEnv::Static()->RootWin().Identifier());
    CAiwGenericParamList& paramList = serviceHandler->InParamListL();

    TPtrC8 ptr;
    ptr.Set( dataPckg );
    TAiwVariant variant( ptr );
    TAiwGenericParam param( EGenericParamCallDialDataV1, variant );
    paramList.AppendL( param );

    // Execute AIW command
    serviceHandler->ExecuteServiceCmdL( KAiwCmdCall,
    paramList,
    serviceHandler->OutParamListL() );

    // destroy criteria, interest, and serviceHandler
    CleanupStack::PopAndDestroy( 3 );

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,165

    Re: TAiwDialDataV1 and TAiwDialDataV1Pckg not working in 3rd edition FP2

    There seems to be something different between FP1 & FP2 then, anyway, for FP2 implementation, you could check Wiki: http://wiki.forum.nokia.com/index.ph...a_Consumer_API

  3. #3
    Regular Contributor
    Join Date
    Nov 2006
    Posts
    51

    Re: TAiwDialDataV1 and TAiwDialDataV1Pckg not working in 3rd edition FP2

    Hi,
    I saw the new implementation for aiw also, and it works fine on fp2 but not fp1. But now the problem is I have an application that is signed and working fine in fp1 and version before using the old AIW api. Now when run in fp2, it is not working properly. Shouldn't Symbian make it compatible so that the API should work on all 3rd edition platform. Now it means every application that uses it has to create a new version and sign it. Shouldn't this a bug in the platform?

  4. #4
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,165

    Re: TAiwDialDataV1 and TAiwDialDataV1Pckg not working in 3rd edition FP2

    Those APIs are from API plug-in, and they are there without any guarantee of compatibility, and that is expressed there very clarly.

    Thus you should use them only if you do not find any better API that you can do the same task.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×