×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 19
  1. #1
    Registered User
    Join Date
    Dec 2008
    Posts
    8

    unable to install an error occured on emulator

    Hi,
    i have created a simple widget with a js file,a html file, info.plist and an icon.png. i created a zip file for this folder and than renamed that file to wgz extension after doing all this i posted it to the other folder of the s60 directory, when i try to install the application it gives an error "unable to install an error occured" i have tried many times. please help me out.

    contents of info.plist


    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Nokia//DTD PLIST 1.0//EN" "http://www.nokia.com/NOKIA_COM_1/DTDs/plist-1.0.dtd">
    <plist version="1.0">
    <dict>
    <key>DisplayName</key>
    <string>naukriWidget</string> <!-- Name to be shown next to the icon -->
    <key>Identifier</key>
    <string>com.naukri.widget.naukriwidget</string> <!-- Unique string to identify this widget (in reverse domain format) -->
    <key>MainHTML</key>
    <string>search.html</string> <!-- File name of the main HTML document -->
    <key>AllowNetworkAccess</key>
    <true /> <!-- Allow access to the network-based resources from the widget -->
    </dict>
    </plist>
    Last edited by kumaranuj; 2008-12-20 at 02:27.

  2. #2
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,347

    Re: unable to install an error occured on emulator

    Quote Originally Posted by kumaranuj View Post
    Hi,
    i have created a simple widget with a js file,a html file, info.plist and an icon.png. i created a zip file for this folder and than renamed that file to wgz extension after doing all this i posted it to the other folder of the s60 directory, when i try to install the application it gives an error "unable to install an error occured" i have tried many times. please help me out.
    Hi Kumaranuj,

    Would you please provide some more details?

    - Where did you put your .wgz file?
    - If on Emulator then which is the SDK?
    - If on phone then which is the phone?
    Nokia Developer Wiki Moderation team

  3. #3
    Registered User
    Join Date
    Dec 2008
    Posts
    8

    Re: unable to install an error occured on emulator

    Hi kiran10182,

    I had putted that .wgz file into the following directory

    S60\devices\S60_5th_Edition_SDK_v0.9\epoc32\winscw\c\Data\Others

    i am using SDK 5th edition v0.9

    please let me know if you need any other information.

    one more thing i tried in between is that i downloaded a example widget named AccuWidget and than i copied it's .wgz in to the above folder , it worked fine. but after that i unzipped the folder of this widget on my system and followed the steps ( first zipped it than converted it into .wgz extension and than copied it to the above directory) to run a widget. but this time i got same message "unable to install....".

    Thanks

  4. #4
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,347

    Re: unable to install an error occured on emulator

    Hi Kumaranuj,

    It would be better if you create your own Widget instead of unzipping .wgz file of other publishers. It is very simple and fast development process with Aptana IDE having WRT plugin installed.

    Just follow the steps below and you will have your own Widget with some cool graphics. Try it out:

    1) Install Aptana Studio from here: http://www.forum.nokia.com/Resources...Aptana_Plugin/
    2) Install S60 WRT plugin from within Aptana studio.

    The whole process is nicely elaborated with pictures in this Wiki article: Aptana WRT Plugin Basics

    And the installation process you described for the Emulator is completely fine. Alternatively, you can directly install .wgz file from Emulator->File->Open.

    Please let me know if you find any problem. I will try my best to get your widget install on your Emulator or device.
    Nokia Developer Wiki Moderation team

  5. #5
    Registered User
    Join Date
    Dec 2008
    Posts
    8

    Re: unable to install an error occured on emulator

    Hi kiran10182,
    thanks a lot now i am able to install my widget on emulator. but there is one problem if i am defining a button on the main page and called a function on onclick event than it is not working on emulator but working fine on aptana studio and this is with all the widgets even i have tried the example widgets also.

    please help me in this regard.


    Thanks a lot,
    Anuj Kumar

  6. #6
    Registered User
    Join Date
    Dec 2008
    Posts
    8

    Re: unable to install an error occured on emulator

    anyone please help me.

  7. #7
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,347

    Re: unable to install an error occured on emulator

    Quote Originally Posted by kumaranuj View Post
    Hi kiran10182,
    thanks a lot now i am able to install my widget on emulator. but there is one problem if i am defining a button on the main page and called a function on onclick event than it is not working on emulator but working fine on aptana studio and this is with all the widgets even i have tried the example widgets also.

    please help me in this regard.


    Thanks a lot,
    Anuj Kumar
    Hi Anuj,

    Can you explain a bit more about your problem? If it works fine on Aptana studio then ideally it should work on Emulator too. You can create one simple "Basic Widget with WRTKit" application. It has minimal functionality of HelloWorld button and it works like a charm.

    Please try that and let me know if you still find this problem.
    Nokia Developer Wiki Moderation team

  8. #8
    Registered User
    Join Date
    Dec 2008
    Posts
    8

    Re: unable to install an error occured on emulator

    hi kiran10182,
    i just created simple widget in which i have two main divs on the page and a button on that page as i click on the button (onclick) the first div gets off and second div wakes up and shown to the user. i am doing it by javascript called at onclick event of the button. this is working fine on aptana but as soon as i deploy it on emulator button dosen't work or second div is not shown.


    Thanks

  9. #9
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,347

    Re: unable to install an error occured on emulator

    Quote Originally Posted by kumaranuj View Post
    hi kiran10182,
    i just created simple widget in which i have two main divs on the page and a button on that page as i click on the button (onclick) the first div gets off and second div wakes up and shown to the user. i am doing it by javascript called at onclick event of the button. this is working fine on aptana but as soon as i deploy it on emulator button dosen't work or second div is not shown.


    Thanks
    Hi Anuj,

    You can send me your application if it's fine with you. I can check at my end and let you know if I find something problematic.

    Just click on my profile and send PM/E-mail to me.
    Nokia Developer Wiki Moderation team

  10. #10
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,347

    Re: unable to install an error occured on emulator

    Quote Originally Posted by kumaranuj View Post
    hi kiran10182,
    i just created simple widget in which i have two main divs on the page and a button on that page as i click on the button (onclick) the first div gets off and second div wakes up and shown to the user. i am doing it by javascript called at onclick event of the button. this is working fine on aptana but as soon as i deploy it on emulator button dosen't work or second div is not shown.


    Thanks
    Hi Anuj,

    I received your mail and your application works fine on my N95 8GB.

    Steps to reproduce:
    1) Installed your application on N95 8GB.
    2) Opened your application.
    3) Clicked on "Search" button and I got "put some content" on the screen.

    Is this what you expected to see? Please let me know if you meant something different so that I can try my best to solve your problem.

    PS: One important thing to note down; when you debug your application from Aptana IDE, open "wrt_preview_frame.html" and then press "F11" or "Debug as-> JavaScript Web Application".
    Nokia Developer Wiki Moderation team

  11. #11
    Registered User
    Join Date
    Dec 2008
    Posts
    8

    Re: unable to install an error occured on emulator

    hi Kiran,
    i tried to install it on nokia N82 and it is showing me that file is corrupt. please help me in this regard.

    i am sending it from S60/......../others/naukriSearch.wgz to mobile through bluetooh device.

    thanks,

  12. #12
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,347

    Re: unable to install an error occured on emulator

    Quote Originally Posted by kumaranuj View Post
    i tried to install it on nokia N82 and it is showing me that file is corrupt. please help me in this regard.
    Hi Anuj.

    Web Runtime environment has been available from S60 3rd FP2 devices inbuilt. There are S60 3rd FP1 devices which support WRT environment but you have to update them through software updates. You have Nokia N82 device which is a S60 3rd FP1 device and you may need to update its software to get widgets install and run on it.

    Here is a link: Device Software update

    Let me know if it still does not work.
    Nokia Developer Wiki Moderation team

  13. #13
    Registered User
    Join Date
    Dec 2008
    Posts
    8

    Re: unable to install an error occured on emulator

    Hi Kiran,
    the widget which i sent to you is not working on my emulator. could you please assist me for the same. it's getting installed but when i click on search button it doesn't work. i think you must me remembering about my widget. do i need to tweak my emulator for this or there is something else which i should do ?

    thanks,
    Anuj Kumar

  14. #14
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,347

    Re: unable to install an error occured on emulator

    Quote Originally Posted by kumaranuj View Post
    Hi Kiran,
    the widget which i sent to you is not working on my emulator. could you please assist me for the same. it's getting installed but when i click on search button it doesn't work. i think you must me remembering about my widget. do i need to tweak my emulator for this or there is something else which i should do ?

    thanks,
    Anuj Kumar
    Hi Anuj,

    Yes, I do remember your widget and I still can install it on my emulator and run it smoothly(I can see "put some content" when I click on search button). By the way I have installed it on S60 5th Edition emulator and also on my N95 8GB. Would you please tell me on which SDK emulator you have tested?
    Nokia Developer Wiki Moderation team

  15. #15
    Registered User
    Join Date
    Dec 2008
    Posts
    8

    Re: unable to install an error occured on emulator

    Hi Kiran,
    i am trying on S60 5th Edition v 9, but this is not working on that. could you please help me out.

    Thanks,
    Anuj Kumar

Similar Threads

  1. [moved] "unable to install. component is already built in" message on emulator.
    By Rajani_sp in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 22
    Last Post: 2008-08-19, 16:31
  2. Can't install .sis file (Problem with Emulator)
    By zlaja in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2006-11-28, 18:46
  3. 6270 emulator for Linux fails to install
    By mortengh in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2005-06-20, 13:28
  4. unable to install midlet: using wap-push on Series 60
    By shumail0 in forum Mobile Java General
    Replies: 1
    Last Post: 2003-12-21, 14:03
  5. Do I need to install my "HelloWorld" MIDlet in N7650 emulator
    By gekecn in forum Mobile Java General
    Replies: 0
    Last Post: 2002-11-29, 04:03

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×