×

Discussion Board

Results 1 to 8 of 8

Hybrid View

  1. #1
    Registered User
    Join Date
    Dec 2008
    Location
    Kazakhstan, Almaty
    Posts
    8

    Angry emultar(epoc) crashes when i run Qt applications

    Emultor(epoc) crashes when i run Qt applications,
    but it works fine with standard Symbias(like HelloWorldBasic)

    while debuggin' i got FAULT: nkern.cpp 0x0000059c (1436)
    on line QApplication a(argc, argv);
    even in simple myFirstQtWidget project


    i'm new to Symbian
    (my expirience list ends with 8-hour-surfing-the-forum.nokia.com)
    and it's hard for me to guess what the problem is.

    So please, if someone has an idea...

    If it's important I have installed:
    1. ActivePerl-5.6.1.638
    2. Java 1.5
    3. Carbide 2.0
    4. S60_3rd_FP1_2
    5. Open C
    6. 4.4.4-temple

  2. #2
    Super Contributor
    Join Date
    Dec 2005
    Location
    England,UK
    Posts
    1,600

    Re: emultar(epoc) crashes when i run Qt applications

    Welcome to Forum Nokia,
    I think you are missing the open c runtime library or qt library.
    There are patches for the S60 kits http://pepper.troll.no/s60prereleases/patches/

    Though I cannot see reason why.

    If you run on vista then take a look at http://wiki.forum.nokia.com/index.ph..._Windows_Vista

    The error is complex for me to interpret so I will leave that to the Qt team

    Good Luck
    Jim

  3. #3
    Registered User
    Join Date
    Dec 2008
    Location
    Kazakhstan, Almaty
    Posts
    8

    Re: emultar(epoc) crashes when i run Qt applications

    I'm using Windows Xp Sp2
    and it seems like i've installed all needed patches (getexports.exe, pips_nikia also present)

    I've reconfigured and rebuilded Qt again
    and now it doesn't crash, but stucks (no respond).

  4. #4
    Registered User
    Join Date
    Dec 2008
    Location
    Kazakhstan, Almaty
    Posts
    8

    Re: emultar(epoc) crashes when i run Qt applications

    yahooo!!! I managed to run myFirstQtWidget.
    But emulator still stucks when i run complex examples like fluidlauncher
    Allmost the same thing happens on my mobile...
    myFirstQtWidget - works fine
    but fluidlauncher - doesn't work at all. But mobile is ok. (doesn't stuck)

    plz anybody..

  5. #5
    Nokia Developer Expert
    Join Date
    Feb 2008
    Posts
    183

    Re: emultar(epoc) crashes when i run Qt applications

    Quote Originally Posted by yunmanger View Post
    yahooo!!! I managed to run myFirstQtWidget.
    But emulator still stucks when i run complex examples like fluidlauncher
    Allmost the same thing happens on my mobile...
    myFirstQtWidget - works fine
    but fluidlauncher - doesn't work at all. But mobile is ok. (doesn't stuck)

    plz anybody..
    See Known issues in http://labs.trolltech.com/page/QtforS60KnownIssues.
    First row: "Running multiple Qt applications in emulator is not possible. ". Fluidlauncher is a Qt application that is not killed, when
    it tries to launch a second Qt application. Therefore in emulator this doesn't work.

  6. #6
    Registered User
    Join Date
    Dec 2008
    Posts
    2

    Re: emultar(epoc) crashes when i run Qt applications

    I have met the same error too. The error application is elasticnodes.
    The error stack is :
    24 QSelectThread::QSelectThread() E:\qt-embedded-s60-commercial-src-4.5.0-garden\src\corelib\kernel\qeventdispatcher_symbian.cpp:251 0x00fede77
    23 QEventDispatcherSymbian::QEventDispatcherSymbian() E:\qt-embedded-s60-commercial-src-4.5.0-garden\src\corelib\kernel\qeventdispatcher_symbian.cpp:493 0x00fef4a0
    22 QEventDispatcherS60::QEventDispatcherS60() E:\qt-embedded-s60-commercial-src-4.5.0-garden\src\gui\kernel\qeventdispatcher_s60.cpp:41 0x016c8b26
    21 QApplicationPrivate::createEventDispatcher() E:\qt-embedded-s60-commercial-src-4.5.0-garden\src\gui\kernel\qapplication_s60.cpp:600 0x016c7300
    20 QCoreApplication::init() E:\qt-embedded-s60-commercial-src-4.5.0-garden\src\corelib\kernel\qcoreapplication.cpp:467 0x00fbea51
    19 QCoreApplication::QCoreApplication() E:\qt-embedded-s60-commercial-src-4.5.0-garden\src\corelib\kernel\qcoreapplication.cpp:390 0x00fbe85f
    18 QApplication::QApplication() E:\qt-embedded-s60-commercial-src-4.5.0-garden\src\gui\kernel\qapplication.cpp:672 0x01671860
    17 main() E:\qt-embedded-s60-commercial-src-4.5.0-garden\examples\graphicsview\elasticnodes\main.cpp:26 0x00402216
    16 QtMainWrapper() E:\qt-embedded-s60-commercial-src-4.5.0-garden\src\s60main\qts60main_mcrt0.cpp:58 0x00408f50
    15 CQtS60MainAppUi::OpenCMainCallBack() E:\qt-embedded-s60-commercial-src-4.5.0-garden\src\s60main\qts60mainappui.cpp:155 0x0040901b
    14 CQtS60MainAppUi::OpenCMainStaticCallBack() E:\qt-embedded-s60-commercial-src-4.5.0-garden\src\s60main\qts60mainappui.cpp:143 0x00408edc
    The error place is :
    if (:ipe(m_pipeEnds) != 0) {

    Do anybody know how to solove this. thanks a lot

  7. #7
    Registered User
    Join Date
    Jan 2009
    Location
    ભારત->ગુજરાત->ભાવનગર
    Posts
    279

    Post Re: emultar(epoc) crashes when i run Qt applications

    Quote Originally Posted by rayer4u View Post
    I have met the same error too. The error application is elasticnodes.
    The error stack is :
    24 QSelectThread::QSelectThread() E:\qt-embedded-s60-commercial-src-4.5.0-garden\src\corelib\kernel\qeventdispatcher_symbian.cpp:251 0x00fede77
    23 QEventDispatcherSymbian::QEventDispatcherSymbian() E:\qt-embedded-s60-commercial-src-4.5.0-garden\src\corelib\kernel\qeventdispatcher_symbian.cpp:493 0x00fef4a0
    22 QEventDispatcherS60::QEventDispatcherS60() E:\qt-embedded-s60-commercial-src-4.5.0-garden\src\gui\kernel\qeventdispatcher_s60.cpp:41 0x016c8b26
    21 QApplicationPrivate::createEventDispatcher() E:\qt-embedded-s60-commercial-src-4.5.0-garden\src\gui\kernel\qapplication_s60.cpp:600 0x016c7300
    20 QCoreApplication::init() E:\qt-embedded-s60-commercial-src-4.5.0-garden\src\corelib\kernel\qcoreapplication.cpp:467 0x00fbea51
    19 QCoreApplication::QCoreApplication() E:\qt-embedded-s60-commercial-src-4.5.0-garden\src\corelib\kernel\qcoreapplication.cpp:390 0x00fbe85f
    18 QApplication::QApplication() E:\qt-embedded-s60-commercial-src-4.5.0-garden\src\gui\kernel\qapplication.cpp:672 0x01671860
    17 main() E:\qt-embedded-s60-commercial-src-4.5.0-garden\examples\graphicsview\elasticnodes\main.cpp:26 0x00402216
    16 QtMainWrapper() E:\qt-embedded-s60-commercial-src-4.5.0-garden\src\s60main\qts60main_mcrt0.cpp:58 0x00408f50
    15 CQtS60MainAppUi::OpenCMainCallBack() E:\qt-embedded-s60-commercial-src-4.5.0-garden\src\s60main\qts60mainappui.cpp:155 0x0040901b
    14 CQtS60MainAppUi::OpenCMainStaticCallBack() E:\qt-embedded-s60-commercial-src-4.5.0-garden\src\s60main\qts60mainappui.cpp:143 0x00408edc
    The error place is :
    if (:ipe(m_pipeEnds) != 0) {

    Do anybody know how to solove this. thanks a lot
    hii
    Before running the configure command on command prompt you have to first off all set the enviroment variable for carbid c++.In window Xp this is done like Start->all programs-> crabid c++->configure winscw command.


    please ensure that your date and time should be set properly.

    Hope this will help you.

    Regards
    Viral Parmar

  8. #8
    Registered User
    Join Date
    Dec 2008
    Posts
    2

    Re: emultar(epoc) crashes when i run Qt applications

    hi, Parmar
    Thanks for your attention.I'd rerun the configure command and nothing need to be changed.My date and time is properly normal,maybe a little advanced. I'd reread the INSTALL file, reconfigure and rebuild.all winscw targets were builded successful, but the error was still.Last week I'd build gcce target and run in device successful. maybe the qt winscw libs I builded is not well.
    My develop envirement
    Carbide.c++ v2.0.0
    S60 Platform SDK 3rd Edition FP1
    Open C/C++ for S60 3rd Edition
    My path
    E:\qt-embedded-s60-commercial-src-4.5.0-garden\bin;E:\Symbian\Carbide2\x86Build\Symbian_Tools\Command_Line_Tools;C:Program Files\PC Connectivity Solution\;C:\Program Files\Common Files\Symbian\Tools;E:Python26\Lib\site-packages\PyQt4;E:\Python26;E:\Python26\Scripts;E:\symbian\CSL Arm Toolchain\bin;C:Perl\bin\;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Program Files\Microsoft SQL Server\90\Tools\binn\;C:\Program Files\TortoiseSVN\bin;E:\soft\Google\google_appengine\;E:\symbian\HookLogger\;
    Ralate libs
    QtGui.lib 3888KB
    QtGui.dll 34356KB

    QtCore.lib 1180KB
    QtCore.dll 7278KB

    qtmain.lib 592KB

    Regards
    Roy Bi

Similar Threads

  1. Run App on Uninstall problem
    By JamesLockett in forum Symbian
    Replies: 1
    Last Post: 2006-07-07, 12:36
  2. Customize the look and feel of the Nokia Device menu’s and applications
    By mukteshwar in forum Feedback - Nokia Developer Services & Infrastructure
    Replies: 2
    Last Post: 2006-04-07, 19:48
  3. Close all applications? <- what exactly does it do?
    By digitaltejas in forum Symbian
    Replies: 0
    Last Post: 2005-07-07, 09:32

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×