×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Regular Contributor
    Join Date
    Dec 2008
    Posts
    84

    S60 emulator preferences disabled

    Once again, apologies if this is the wrong place to ask -- I'm new to S60 development.

    I'm running Qt examples on the S60 emulator.

    These seem to work fine, except that Preferences is disabled (greyed out) in the Tools menu.

    How can change get at the prefercnes, and from Partial to Full mode and so on?

    Sam Dutton
    Last edited by samdutton; 2008-12-23 at 18:21.

  2. #2
    Super Contributor
    Join Date
    Dec 2005
    Location
    England,UK
    Posts
    1,600

    Re: S60 emulator preferences disabled

    Hi Sam,
    Rather than craft a reply. I have chosen an external page which may be more useful to you, than a quote out of manual

    The S60 does have a conference devoted to setting up emulators and problems.

    http://tanzim.wordpress.com/2008/07/...r-development/
    Jim

  3. #3
    Regular Contributor
    Join Date
    Nov 2006
    Location
    Switzerland
    Posts
    476

    Re: S60 emulator preferences disabled

    If you start the emulator directly from Carbide C++, the item is sometimes disabled. I also noticed that behaviour. My solution was to start the emulator from "Start / All programs / S60 Developer Tools / 5th edition SDK / v0.9 / Emulator" first. Then the menu item "Preferences" was enabled and I could change the settings.
    Last edited by patrickfrei; 2009-01-20 at 07:59.

  4. #4
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: S60 emulator preferences disabled

    Is the emulator fully started when you try to access the menu? The window title should change from "S60 Emulator is loading. Please wait ..." to "S60 5th Edition SDK v0.9" before you can access the Preferences menu.

    See also Running the emulator from Carbide.c++ and be aware that depending on the running mode chosen emulator's startup behavior may be different.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  5. #5
    Regular Contributor
    Join Date
    Dec 2008
    Posts
    84

    Re: S60 emulator preferences disabled

    Thanks for the replies.

    For some reason is working OK now, but if the menus mysteriously get disabled again, I'll try patrickfrei's suggestion.

    Sam

  6. #6
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: S60 emulator preferences disabled

    If you find the problem again and a reliable way to reproduce it let me know and we'll try to have it fixed.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  7. #7
    Registered User
    Join Date
    Dec 2009
    Posts
    16

    Re: S60 emulator preferences disabled


  8. #8
    Registered User
    Join Date
    Jun 2010
    Posts
    13

    Re: S60 emulator preferences disabled


Similar Threads

  1. S60 emulators not working
    By auusital in forum Symbian Tools & SDKs
    Replies: 10
    Last Post: 2009-10-21, 09:25
  2. Mimicing EikStart::RunApplication() on S60 2nd
    By ruslan.zalata in forum Symbian
    Replies: 2
    Last Post: 2007-11-14, 04:52
  3. Mail Sync for S60 / S60 3rd Devices
    By bmenke in forum PC Suite API and PC Connectivity SDK
    Replies: 4
    Last Post: 2006-09-17, 06:24
  4. Almost all tools (S60 MIDP SDK B0.1, Nokia S60 SDK Symbian OS v0.3) Crashes
    By alexandershalamov in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2002-07-03, 13:44

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×