×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Regular Contributor
    Join Date
    Nov 2008
    Posts
    81

    Question two error at build project?

    Hi,
    I am using s60 sdk 3 edition f2.
    carbide c++ 2.0.
    create default hello world gui application.
    when i run or build i get two error,
    1)bldmake returned with exit value = 9
    2)EPOCROOT environment variable must be capitalised
    here i am doing nothing special, just create project and build, got those two error.
    guide me where i am doing wrong or where i have been wrong.
    thanks.
    bye
    regards Rajat.

  2. #2
    Super Contributor
    Join Date
    Jul 2007
    Location
    ShenZhen, China
    Posts
    4,346

    Re: two error at build project?

    select "start page" --> "programm files" -->"Carbide.c++ v2.0" --> "Configure environment for WINSCW command line", and try again.
    ----------------------------
    坚持学习, 坚持编码
    http://www.devdiv.net/
    qxiaoyuan

  3. #3
    Regular Contributor
    Join Date
    Nov 2008
    Posts
    81

    Smile Re: two error at build project?

    Hi qxiaoyuan,
    thanks for reply.
    sorry to say, I did get the error after doing the command on command prompt.
    Would you like to say some thing more about it.
    Actually I do not know what exactly happened with carbide environment after execute the command.
    Thanks to concern.
    Bye
    Regards Rajat.

  4. #4
    Registered User
    Join Date
    Jan 2009
    Posts
    1

    Re: two error at build project?

    find and edit file "e32env.pm"
    ==================================================



    # E32ENV.PM
    #
    # Copyright (c) 1997-2006 Symbian Software Ltd. All rights reserved.
    #

    # Contains information for makmake and associated e32tools perl programs
    # within the Epoc32 Environment

    package E32env;


    use vars qw(%Data);

    BEGIN {

    ...

    # the following variable must be set to '1'
    my $found=1;
    ...

    # everything inside double quote must be CAPITALIZED
    $Data{EPOCPath} = $epocroot."\\EPOC32\\";

    $Data{EPOCDataPath} = $epocroot."\\EPOC32\\DATA\\";
    $Data{EPOCIncPath} = $epocroot."\\EPOC32\\INCLUDE\\";
    $Data{BldPath} = $epocroot."\\EPOC32\\BUILD\\";
    #regression hack
    # $Data{LinkPath} = $epocroot."\\epoc32\\library\\";
    $Data{LinkPath} = $epocroot."\\EPOC32\\RELEASE\\";
    #regression hack end
    $Data{RelPath} = $epocroot."\\EPOC32\\RELEASE\\";
    $Data{EPOCToolsPath} = $epocroot."\\EPOC32\\TOOLS\\";
    $Data{RomPath} = $epocroot."\\EPOC32\\ROM\\";

    $Data{DataPath} = "Z\\SYSTEM\\DATA\\";

    $Data{SecurePlatform} = 1;
    }

    1;

  5. #5
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: two error at build project?

    What exactly should one modify? Why would someone modify that file? I'm sure nothing of the kind is needed, it is rather an issue of removing a wrongly set system environment variable.

    Anyhow, mysilversir had this problems solved two months ago ...
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

Similar Threads

  1. GoogleIt
    By deepika.mangla in forum Symbian
    Replies: 5
    Last Post: 2011-05-28, 11:04
  2. My Carbide C++ IDE is not able to build the project
    By arungupta_2jan in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 2
    Last Post: 2008-08-12, 11:22
  3. Carbide C++ does not build my project
    By jensesaat in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 4
    Last Post: 2007-09-27, 10:07
  4. .net, sdk3rd, i can't get project by abld build vs2003, why?
    By zasdfaaa in forum Symbian Tools & SDKs
    Replies: 6
    Last Post: 2006-11-17, 06:23
  5. Help! How to build .net project
    By hongzhou36 in forum Symbian
    Replies: 2
    Last Post: 2005-10-10, 13:13

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×