×

Discussion Board

Results 1 to 3 of 3

Thread: device error

  1. #1
    Registered User
    Join Date
    Dec 2008
    Posts
    37

    device error

    Hello,

    I am implementing a video player. The player is created from a stream (Manager.createplayer(InputStream is)).
    When the player starts it plays for an undefined period (some videos a few seconds and some videos about a minute) I have already discovered that the time the player plays depends on the video (the same video always stops at the same time).
    I printed the player events and it seems that the player crashes when the buffering_started event occurs.
    When I try to pause the player when a buffering_started event occurs, i get an exception:
    javax.microedition.media.MediaException: device error

    Does anybody knows what's going wrong?

    Thanks

  2. #2
    Nokia Developer Expert
    Join Date
    Aug 2007
    Posts
    1,595

    Re: device error

    Hello jdesmedt,

    in addition to your description, could you provide the following info please:

    1) Affected device(s), or the SDK emulator with Edition details?

    2) Src code for testing?

    Regards,
    r2j7
    [URL="http://library.forum.nokia.com/java"][B] >>> Java Developer's Library <<<[/B][/URL]
    [URL="https://www.developer.nokia.com/Resources/Support/Technical_support.xhtml"] [B]>>> Technical Support for Java ME development <<<[/B][/URL]
    [URL="https://publish.ovi.com/info/"][B]>>> Nokia Publish: reach millions of Nokia users worldwide through Nokia Store <<<[/B][/URL]

  3. #3
    Registered User
    Join Date
    Dec 2008
    Posts
    37

    Re: device error

    I get the error on a Nokia 6500c.

Similar Threads

  1. XMl Parser Implementation for Symbian
    By ittiam in forum Symbian
    Replies: 26
    Last Post: 2009-09-16, 05:26
  2. i cant build helloworld project
    By akhin in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 2
    Last Post: 2008-12-22, 12:38
  3. carbide build problem help please
    By berkcekisbas in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2006-09-26, 19:41
  4. problem with the XML Parser SyExpat
    By Vitaly_iva in forum Symbian
    Replies: 2
    Last Post: 2006-06-05, 11:09
  5. Replies: 0
    Last Post: 2002-09-24, 13:11

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×