×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Sep 2006
    Posts
    35

    Unable to configure Qt for S60 Opensource Pyramid release

    Hi I am getting the below error at the end of the configure step.

    Please could you let me know what could be the problem.

    I have included the screenshot of all that happened when I gave configure command, hope thats not bulk info.

    Expecting the answer ASAP.

    Thanks in advance.

    With Regards,
    Ravi



    C:\Qtfors60\qt-embedded-s60-opensource-src-4.4.2-pyramid>configure -platform win
    32-mwc -xplatform symbian-abld -qconfig symbian

    This is the Qt for S60 Open Source Edition.

    You are licensed to use this software under the terms of
    the GNU General Public License (GPL) version 2 or 3.

    Type '2' to view the GNU General Public License version 2 (GPLv2).
    Type '3' to view the GNU General Public License version 3 (GPLv3).
    Type 'y' to accept this license offer.
    Type 'n' to decline this license offer.

    Do you accept the terms of the license?
    y
    Environment:
    INCLUDE=
    Unset
    LIB=
    Unset
    PATH=
    C:\Qtfors60\qt-embedded-s60-opensource-src-4.4.2-pyramid\bin
    C:\Program Files\Nokia\Carbide.c++ v2.0\x86Build\Symbian_Tools\Command_Lin
    e_Tools
    C:\Program Files\Common Files\Symbian\Tools
    C:\Perl\bin\
    C:\Program Files\CSL Arm Toolchain\bin
    C:\Program Files\ThinkPad\Utilities
    C:\WINDOWS\system32
    C:\WINDOWS
    C:\WINDOWS\System32\Wbem
    C:\Program Files\Intel\Wireless\Bin\
    C:\WINDOWS\Downloaded Program Files
    C:\IBMTOOLS\Python22
    C:\Program Files\Common Files\Teleca Shared
    C:\Program Files\QuickTime\QTSystem\
    C:\Program Files\doxygen\bin
    C:\Program Files\SSH Communications Security\SSH Secure Shell
    You are licensed to use this software under the terms of the GNU GPL version 2 o
    r 3.
    See C:/Qtfors60/qt-embedded-s60-opensource-src-4.4.2-pyramid/LICENSE.GPL2
    or C:/Qtfors60/qt-embedded-s60-opensource-src-4.4.2-pyramid/LICENSE.GPL3

    Configuration:
    dist-config
    large-config
    medium-config
    minimal-config
    small-config
    symbian-config
    build_all
    debug
    cross_compile
    Qt Configuration:
    release
    debug
    zlib
    png
    ipv6
    svg

    QMAKESPEC...................symbian-abld (commandline)
    Architecture................symbian
    Maketool....................make
    Debug symbols...............yes
    Accessibility support.......no
    STL support.................no
    Exception support...........no
    RTTI support................no
    MMX support.................no
    3DNOW support...............no
    SSE support.................no
    SSE2 support................no
    IWMMXT support..............no
    OpenGL support..............no
    Direct3D support............no
    OpenSSL support.............no
    QtDBus support..............no
    QtXmlPatterns support.......no
    Phonon support..............no
    WebKit support..............no
    Qt3 compatibility...........no

    Third Party Libraries:
    ZLIB support............qt
    GIF support.............plugin
    TIFF support............plugin
    JPEG support............plugin
    PNG support.............qt
    MNG support.............plugin

    Styles:
    Windows.................yes
    Windows XP..............no
    Windows Vista...........no
    Plastique...............no
    Cleanlooks..............no
    Motif...................no
    CDE.....................no
    Windows CE..............no
    Windows Mobile..........no

    Sql Drivers:
    ODBC....................no
    MySQL...................no
    OCI.....................no
    PostgreSQL..............no
    TDS.....................no
    DB2.....................no
    SQLite..................plugin (qt)
    SQLite2.................no
    InterBase...............no

    Sources are in..............C:\Qtfors60\qt-embedded-s60-opensource-src-4.4.2-pyr
    amid
    Build is done in............C:\Qtfors60\qt-embedded-s60-opensource-src-4.4.2-pyr
    amid
    Install prefix..............
    Headers installed to........
    Libraries installed to......
    Plugins installed to........\resource\qt\plugins
    Binaries installed to.......
    Docs installed to...........
    Data installed to...........
    Translations installed to...
    Examples installed to.......
    Demos installed to..........

    Running syncqt...
    Creating qmake...
    mwccsym2 -gccinc -stackcommit 1024000 -stackreserve 1024000 -w all -w nonotused
    -w nonotinlined -w noimplicit -w nopadding -w noemptydecl -w nounusedexpr -c -o
    qconfig.o -O -I. -Igenerators -Igenerators\unix -Igenerators\win32 -Igenerators\
    mac -Igenerators\symbian -IC:\Qtfors60\qt-embedded-s60-opensource-src-4.4.2-pyra
    mid\include -IC:\Qtfors60\qt-embedded-s60-opensource-src-4.4.2-pyramid\include\Q
    tCore -IC:\Qtfors60\qt-embedded-s60-opensource-src-4.4.2-pyramid\include -IC:\Qt
    fors60\qt-embedded-s60-opensource-src-4.4.2-pyramid\include\QtCore -IC:\Qtfors60
    \qt-embedded-s60-opensource-src-4.4.2-pyramid\src\corelib\global -IC:\Qtfors60\q
    t-embedded-s60-opensource-src-4.4.2-pyramid\mkspecs\win32-mwc -DQT_NO_TEXTCODEC
    -DQT_NO_UNICODETABLES -DQT_LITE_COMPONENT -DQT_NO_PCRE -DQT_NODLL -DQT_NO_STL -D
    QT_NO_COMPRESS -DHAVE_QCONFIG_CPP -DQT_BUILD_QMAKE -DQT_NO_THREAD -DQT_NO_QOBJEC
    T -DQT_NO_GEOM_VARIANT -DQT_NO_DATASTREAM -DQT_NO_LIBRARY -IC:\Qtfors60\qt-embed
    ded-s60-opensource-src-4.4.2-pyramid\include\QtScript -DQMAKE_OPENSOURCE_EDITIO
    N C:\Qtfors60\qt-embedded-s60-opensource-src-4.4.2-pyramid/src/corelib/global/qc
    onfig.cpp
    mwccsym2 -o qmake.exe project.o main.o makefile.o unixmake.o unixmake2.o mingw_
    make.o option.o winmakefile.o projectgenerator.o property.o meta.o makefiledeps.
    o metamakefile.o xmloutput.o pbuilder_pbx.o borland_bmake.o msvc_nmake.o msvc_ds
    p.o msvc_vcproj.o msvc_objectmodel.o symmake.o initprojectdeploy_symbian.o qpope
    n.o qbitarray.o qbuffer.o qbytearray.o qcryptographichash.o qvsnprintf.o qbytear
    raymatcher.o qconfig.o qdatetime.o qdir.o qdiriterator.o qfile.o qtemporaryfile.
    o qfileinfo.o qabstractfileengine.o qfsfileengine.o qfsfileengine_iterator.o qfs
    fileengine_win.o qfsfileengine_iterator_win.o qglobal.o qhash.o qiodevice.o qlib
    raryinfo.o qlistdata.o qlinkedlist.o qlocale.o qmalloc.o qmap.o qregexp.o qstrin
    g.o qstringlist.o qtextstream.o quuid.o qvector.o qurl.o qsettings.o qsettings_w
    in.o qvariant.o qmetatype.o qnumeric.o qscriptasm.o qscriptast.o qscriptastvisit
    or.o qscriptcompiler.o qscriptecmaarray.o qscriptecmaboolean.o qscriptecmacore.o
    qscriptecmadate.o qscriptecmafunction.o qscriptecmaglobal.o qscriptecmamath.o q
    scriptecmanumber.o qscriptecmaobject.o qscriptecmaregexp.o qscriptecmastring.o q
    scriptecmaerror.o qscriptcontext_p.o qscriptengine.o qscriptengine_p.o qscripten
    gineagent.o qscriptextenumeration.o qscriptextvariant.o qscriptcontext.o qscript
    contextinfo.o qscriptfunction.o qscriptgrammar.o qscriptlexer.o qscriptclassdata
    .o qscriptparser.o qscriptprettypretty.o qscriptsyntaxchecker.o qscriptclass.o q
    scriptclasspropertyiterator.o qscriptstring.o qscriptvalue.o qscriptvalueimpl.o
    qscriptvalueiterator.o qscriptvalueiteratorimpl.o -ladvapi32.lib
    copy qmake.exe C:\Qtfors60\qt-embedded-s60-opensource-src-4.4.2-pyramid\bin\qmak
    e.exe
    1 file(s) copied.
    Creating makefiles in src...
    Generating Makefiles...
    execute: Unknown error
    (-spec)
    (symbian-abld)
    (-r)
    (C:/Qtfors60/qt-embedded-s60-opensource-src-4.4.2-pyramid/projects.pro)
    (-o)
    (C:/Qtfors60/qt-embedded-s60-opensource-src-4.4.2-pyramid)
    Qmake failed, return code -1


    C:\Qtfors60\qt-embedded-s60-opensource-src-4.4.2-pyramid>
    ------------------------------
    RaviKiran
    -----------------------------

  2. #2
    Registered User
    Join Date
    Dec 2006
    Posts
    2,280

    Re: Unable to configure Qt for S60 Opensource Pyramid release

    Hi,

    I haven't seen this error before. I strongly suggest you download the newer temple release and try to use that instead though.

    If it doesn't work when you've done that, it looks like qmake is failing to create the MMP, bld.inf & package files for some reason... what SDK have you got installed?

    Mark

  3. #3
    Super Contributor
    Join Date
    Dec 2005
    Location
    England,UK
    Posts
    1,600

    Thumbs up Re: Unable to configure Qt for S60 Opensource Pyramid release

    Hi,
    Whilst pyramid has work well for me. I feel you should load the
    http://pepper.troll.no/s60prerelease...t-20081230.zip
    NOTE:- Date 30th December 2008

    Prior to this release I had problems with Temple release

    I have this patch for vista which I command run

    PHP Code:
    @echo off
    rem patch vista GCCE COMPILE PATH
    SET PATH
    =C:\Program Files\CSL Arm Toolchain\bin;C:\Program Files\CSL Arm Toolchain\arm-none-symbianelf\bin;C:\Program Files\CSL Arm Toolchain\libexec\gcc\arm-none-symbianelf\3.4.3;C:\Program Files\Common Files\Symbian\tools;%PATH%
    PATH=%PATH%;c:\Qt\4.4.4-temple\bin;c:\Qt\4.4.4-temple
    cd 
    \
    cd c:\Qt\4.4.4-temple\examples 
    I have sucessfully loaded and compiled this version
    Jim
    Last edited by jimgilmour1; 2008-12-31 at 09:29. Reason: typos

Similar Threads

  1. Unable to configure Access Point on Nokia 6300
    By kapil_bsp in forum General Development Questions
    Replies: 2
    Last Post: 2008-10-07, 11:53

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×