×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    27

    Exclamation S60 5th Ed. SDK v0.9 and Carbide.vs 3.01 Issue

    Tools:
    SDK: S60 5th Ed. SDK v0.9
    Carbide.vs 3.01
    Visual Studio 2005

    Issues:
    1. TRAPD macro didn't catch exception.

    After investigation of "S60_5th_Edition_SDK_v0.9_v3.xml" I found missed flag in cc-flag "-exc ms". I've add this flag and other issue is appear:

    2. I try to do follow: compile application with flag "-exc ms" and try to start application on emulator. The rusult is emulator crash with message window:

    Title: MW Win32 Runtime
    Text: Could not allocate thread local data.

    Looks like problem occurs in linking stage.

    Compile app with Carbide.c++ 2.0 this problem is not appear. Ciould you please provide solution for Carbide.vs 3.01 plus Visual Studio 2005

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: S60 5th Ed. SDK v0.9 and Carbide.vs 3.01 Issue

    Isn't 1) a documented known issue for Carbide.vs? Please check the release notes.
    Last edited by ltomuta; 2009-01-03 at 11:39. Reason: Typo
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  3. #3
    Registered User
    Join Date
    Mar 2003
    Posts
    27

    Re: S60 5th Ed. SDK v0.9 and Carbide.vs 3.01 Issue

    Actualy main problem is:
    Quote Originally Posted by Igor Pchelko View Post
    Tools:
    2. I try to do follow: compile application with flag "-exc ms" and try to start application on emulator. The rusult is emulator crash with message window:

    Title: MW Win32 Runtime
    Text: Could not allocate thread local data.

    Looks like problem occurs in linking stage.

    Compile app with Carbide.c++ 2.0 this problem is not appear. Ciould you please provide solution for Carbide.vs 3.01 plus Visual Studio 2005
    As described here I've try to fix TRAPD issue, but 2nd fotal issue doesn't allow to start application at all.

  4. #4
    Registered User
    Join Date
    Mar 2003
    Posts
    27

    Smile Re: S60 5th Ed. SDK v0.9 and Carbide.vs 3.01 Issue

    Dear ltomuta,

    Please be more adequate!

    First: read full topic before make suggestions:
    Quote Originally Posted by ltomuta View Post
    Is't 1) a documented known issue for Carbide.vs? Please check the release notes.

    Second allow users delete self questions before such claim:
    Quote Originally Posted by ltomuta View Post
    Please post your questions only once. Even if we have to answer three times the answer would be the same.
    Happy new year! I hope in new year we will have more "Forum Nokia Expert"'s that can help with our issues and be more adequate!
    Last edited by ltomuta; 2009-01-03 at 12:06. Reason: Corrected misquote

  5. #5
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: S60 5th Ed. SDK v0.9 and Carbide.vs 3.01 Issue

    As far as I know every user can edit its own post so the lack of delete feature is not an excuse for multiposts. If you think that a delete feature is needed please do post appropriate feedback in the dedicated forum.

    As for the hint thrown above you are welcome to ignore it if you do not find it ... adequate.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  6. #6
    Registered User
    Join Date
    Mar 2003
    Posts
    27

    Re: S60 5th Ed. SDK v0.9 and Carbide.vs 3.01 Issue

    Quote Originally Posted by ltomuta View Post
    As far as I know every user can edit its own post so the lack of delete feature is not an excuse for multiposts. If you think that a delete feature is needed please do post appropriate feedback in the dedicated forum.

    As for the hint thrown above you are welcome to ignore it if you do not find it ... adequate.
    Yes you right every user can edit posts and even here is option that allow to delete post. And when I try to delete duplicate post I got something like "You don't have enough privileges to complite this operation"... do you know such issue?

    Anyway I thinking about to finish this flame and open new thread about actual problem.

  7. #7
    Registered User
    Join Date
    Mar 2003
    Posts
    27

    Re: S60 5th Ed. SDK v0.9 and Carbide.vs 3.01 Issue

    Here is more details about problem.

    1. TRAP doesn't catch any User::Leave after SDK installation.

    2. After adding flag "-exc ms" to property "cc-flags" in file S60_5th_Edition_SDK_v0.9_v3.xml any calls of User::Leave functions brings to emulator crash with window
    Title: MW Win32 Runtime
    Text: Could not allocate thread local data.

    Does anybody have solution?

Similar Threads

  1. S60 5th Ed. SDK v0.9 and Carbide.vs 3.01 Issue
    By Igor Pchelko in forum Tools and SDK Feedback (Closed)
    Replies: 1
    Last Post: 2009-01-06, 19:47
  2. Discrepancy between Carbide.vs SDK detection and "devices" tool.
    By Noki@lex in forum Symbian Tools & SDKs
    Replies: 3
    Last Post: 2008-08-19, 12:01
  3. Replies: 4
    Last Post: 2008-06-15, 16:02
  4. Installation of S60 3rd ed. C++ SDK fails with carbide.vs
    By rohs in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 2
    Last Post: 2006-08-30, 05:22
  5. Installation of S60 3rd ed. C++ SDK fails with carbide.vs
    By rohs in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2006-08-18, 13:05

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×