×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Regular Contributor
    Join Date
    Jan 2007
    Posts
    135

    JSR 180 (SIP) not supported on s60 5th edition !!!

    hello,

    it seems that the support of the JSR 180 on the s60 5th edition (like the Xpress 5800) is no longer available. Has anybody an explanation for that ? is there another JSR that superceeds that JSR ?

    thanks in advance
    Jean-philippe
    jean-philippe

  2. #2
    Super Contributor
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,191

    Re: JSR 180 (SIP) not supported on s60 5th edition !!!

    Hi jean-philippe,

    The SIP API was infact removed from S60 5th Edition devices. There is no "replacement" API available yet (although 1.1 version of the specs is in the works)
    The rationale for removing the API was that the specification itself is quite bad and has caused a lot of headaches for the implementation and 3rd party developers. This has also casued that the API has not been used much. (we also investigated if developers would need to have that in there, and no-one we asked requested us to preserve it)
    Personally I think an additional reason for the limited use of that API is that most of the SIP API use cases are not really possible due to other limitations of Java ME.

    best regards
    Hartti Suomela
    Nokia

  3. #3
    Registered User
    Join Date
    Feb 2009
    Posts
    1

    Re: JSR 180 (SIP) not supported on s60 5th edition !!!

    Hello Hartti.

    And what can we do to install SIP support in Xpress 5800?.

    There are some JavaME SIP applications that will lost some of their functionalities....

    Thanks in advance.

    Fran Peñarrubia.

  4. #4
    Super Contributor
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,191

    Re: JSR 180 (SIP) not supported on s60 5th edition !!!

    Unfortunately nothing (unless if someone has implemented a Java only implementation of SIP API and you include that in yout MIDlet - of course I do not know of any such implementations)

    Hartti

  5. #5
    Registered User
    Join Date
    Feb 2009
    Posts
    1

    Re: JSR 180 (SIP) not supported on s60 5th edition !!!

    But isn't it weird then that the pdf written by Nokia which can be found at the bottom at this "http://www.s60.com/life/thisiss60/s60indetail/softwareversions/5thedition" page clearly states that symbian s60 5th edition DOES support jsr 180?

    br
    Svante Kumlien

Similar Threads

  1. S60 5th Edition emulator startup problem
    By gopitek in forum Symbian
    Replies: 2
    Last Post: 2010-09-08, 08:05
  2. S60 5th Edition VOIP support
    By ehality in forum VoIP
    Replies: 8
    Last Post: 2010-04-20, 07:44
  3. Replies: 0
    Last Post: 2008-10-08, 10:36
  4. SIP API JSR 180 SIPS
    By joby_13 in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2008-07-03, 08:04
  5. How to run OnDo SIP server with S60 emulator(3rd edition)
    By manasglobal1 in forum Symbian Networking & Messaging (Closed)
    Replies: 1
    Last Post: 2007-12-04, 12:26

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×