×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Regular Contributor
    Join Date
    Jul 2008
    Location
    Delhi, India
    Posts
    285

    Question error on >cshlpcmp FunkyHelp.cshlp

    command for hlp file gives following error

    >cshlpcmp FunkyHelp.cshlp

    Bareword found where operator expected at C:/Symbian/9.1/S60_3rd/epoc32/tools/perllib/params.pm line 461, near "New CParamItem"
    (Do you need to predeclare New?)
    Bareword found where operator expected at C:/Symbian/9.1/S60_3rd/epoc32/tools/perllib/params.pm line 466, near "New CParamItem"
    (Do you need to predeclare New?)
    syntax error at C:/Symbian/9.1/S60_3rd/epoc32/tools/perllib/params.pm line 461, near "New CParamItem"
    syntax error at C:/Symbian/9.1/S60_3rd/epoc32/tools/perllib/params.pm line 466, near "New CParamItem"
    Compilation failed in require at C:/Symbian/9.1/S60_3rd/epoc32/tools/perllib/args.pm line 19.
    BEGIN failed--compilation aborted at C:/Symbian/9.1/S60_3rd/epoc32/tools/perllib/args.pm line 19.
    Compilation failed in require at C:\Symbian\9.1\S60_3rd\\epoc32\tools\cshlpcmp.pl line 58.
    BEGIN failed--compilation aborted at C:\Symbian\9.1\S60_3rd\\epoc32\tools\cshlpcmp.pl line 58.

  2. #2
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: error on >cshlpcmp FunkyHelp.cshlp

    Looks like your perl version is wrong. which version of perl you have installed.

  3. #3
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,355

    Re: error on >cshlpcmp FunkyHelp.cshlp

    Your SDK version seems to be wrong too, you should use the S60 3rd Edition SDK MR (Maintenance Release) version.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  4. #4
    Regular Contributor
    Join Date
    Jul 2008
    Location
    Delhi, India
    Posts
    285

    Re: error on >cshlpcmp FunkyHelp.cshlp

    i've Perl 5.10
    for this command do i really need "S60 3rd Edition SDK MR".

  5. #5
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,355

    Re: error on >cshlpcmp FunkyHelp.cshlp

    You need the MR SDK just because it is a better version of the S60 3rd Edition SDK. It fixes a lot of problems which are likely to affect you if you use the old version of the SDK.

    Your current problem is however not related to the MR SDK but to the fact that you have not read the release notes (mandatory for development tools, it's not like you're installing yet another image viewer) and you are using an incompatible Active Perl version.

    I'm not going to tell you which version you need, you can find that (and many other useful things) by reading the release notes :)
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  6. #6
    Regular Contributor
    Join Date
    Jul 2008
    Location
    Delhi, India
    Posts
    285

    Re: error on >cshlpcmp FunkyHelp.cshlp

    Thnx a lot...

Similar Threads

  1. Erron IN receiving MMS
    By vikas_nsit in forum General Messaging
    Replies: 0
    Last Post: 2007-01-19, 12:31

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •