×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Registered User
    Join Date
    Sep 2008
    Location
    Turkiye
    Posts
    32

    sdk installation?

    hi everybody.
    im new to symbian c++ programming yesterday i installed active perl,carbide.c++ and s60v3 MR sdk.
    i installed all of them to same hard drive.
    s60v3 mr sdk is on "c:\symbian\dev\s60"
    i set carbide.c++ workspace directory to "c:\symbian\dev"

    but afterwards
    it seems sdk is not installed correctly

    errors are below that i'm getting when i try to run an app. design
    Code:
    BLDMAKE ERROR: Platform WıNSCW not supported by "\Symbian\dev\S60_3rd_MR_2\ss\group\BLD.INF"
    bldmake returned with exit value = 1
    http://img132.imageshack.us/img132/9083/adszuv9.jpg
    in the image above there is a "s60 3rd Edition section" but in my carbide there is written only "S60" no "3rd"

    what is wrong with my carbide.c++??

    please help me
    sorry for my english

  2. #2
    Super Contributor
    Join Date
    Mar 2004
    Location
    Czech Republic
    Posts
    2,037

    Re: sdk installation?

    Hi,

    very similar problem was discussed on the DiBo and it was succesfully solved:
    http://discussion.forum.nokia.com/fo...=139692&page=2
    Read it carefully - there are few good points in this thread.

    BR
    STeN

  3. #3
    Registered User
    Join Date
    Sep 2008
    Location
    Turkiye
    Posts
    32

    Re: sdk installation?

    it's not looking like the solution of my problem.:(

  4. #4
    Registered User
    Join Date
    Sep 2008
    Location
    Turkiye
    Posts
    32

    Re: sdk installation?

    when i run this command from the command prompt it says:
    can not set the device "s60_3rd_fp2_sdk:com.nokia.s60" as the default, device not known

  5. #5
    Registered User
    Join Date
    Mar 2006
    Location
    India
    Posts
    503

    Re: sdk installation?

    in which sdk installed drive and workspace created should be in the same drive .
    Set the device -setdefault @s60_3rd_fp2_sdk:com.nokia.s60. This problem is related to System path variable of EPOCROOT.
    Regards
    Kamal :)
    ------------------
    You never expect what expects you.

  6. #6
    Registered User
    Join Date
    Sep 2008
    Location
    Turkiye
    Posts
    32

    Re: sdk installation?

    they are already on same drive
    s60v3_mr_sdk is on "c:\symbian\dev\"
    i set carbide.c++ workspace directory to "c:\symbian\dev"

  7. #7
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: sdk installation?

    Quote Originally Posted by McLightning View Post
    Code:
    BLDMAKE ERROR: Platform WıNSCW not supported by "\Symbian\dev\S60_3rd_MR_2\ss\group\BLD.INF"
    bldmake returned with exit value = 1
    Quote Originally Posted by McLightning View Post
    it's not looking like the solution of my problem.:(
    I think you should have another look. The error message signals a non existing "WıNSCW" platform and that is right, the name of the platform is "WINSCW". It must be your particular language settings in Windows that are causing your problem
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  8. #8
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,674

    Re: sdk installation?

    Indeed, the esoteric WıNSCW issue (if you search for it using the link below, there are 5 threads about it - including this one).
    In fact it would be nice to know if that "ı" character is something what you have typed yourself, or the code generator (of Carbide) produces this letter under certain language settings.

Similar Threads

  1. Installation problem for S60 3.0 SDK
    By harri_salminen in forum Symbian Tools & SDKs
    Replies: 4
    Last Post: 2007-11-14, 22:01
  2. Installation of S60 3rd ed. C++ SDK fails with carbide.vs
    By rohs in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 2
    Last Post: 2006-08-30, 05:22
  3. Series 40 SDK Installation problem
    By swiftguy in forum Tools and SDK Feedback (Closed)
    Replies: 0
    Last Post: 2006-05-11, 11:47
  4. PB with SDK Installation.
    By ptreves in forum Mobile Java General
    Replies: 0
    Last Post: 2003-12-12, 22:32
  5. PB with SDK installation.
    By ptreves in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2003-12-12, 06:50

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×