×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Nov 2005
    Posts
    16

    glib unresolved symbols

    Hi,

    I'm working on porting Pango as part of this project. I'm using glib from Open C and the remaining build issue now is these linker errors (udefined symbols):
    _g_ascii_table
    _g_thread_functions_for_glib_use
    _g_thread_use_default_impl
    _g_unichar_get_script
    _g_utf8_skip

    I've tried to link against all possible libraries e.g. libglib.lib libgobject.lib, libgmodule.lib libgthread.lib with no luck. Before I start digging into glib source, has anyone seen this problem before?

    Cheers,
    iwanj
    Last edited by iwanj; 2009-01-18 at 22:15.

  2. #2
    Registered User
    Join Date
    Nov 2005
    Posts
    16

    Re: glib unresolved symbols

    sorted now by including glib_global.h, except _g_unichar_get_script which seems missing/not implemented in glib from Open C

  3. #3
    Registered User
    Join Date
    Dec 2006
    Posts
    2,280

    Re: glib unresolved symbols

    Hi,

    That's very possible, the documentation only claims 77% of the functions in glib are ported.

    Often there is an alternative API with similar functionality. In this case you may need to port more of glib yourself?

    Mark

  4. #4
    Registered User
    Join Date
    Nov 2005
    Posts
    16

    Re: glib unresolved symbols

    build ok now, got to create my own glib patch using the original code from gscripttable.h, gunicode.h and guniprop.c

  5. #5
    Registered User
    Join Date
    Jul 2009
    Posts
    4

    Re: glib unresolved symbols

    Hi,

    I am getting the same errors when I try to compile the cairo-for-symbian code. Could anybody help with this?

    Thanks

Similar Threads

  1. Unresolved symbols in Streaming Audio link
    By tunelabguy in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2006-08-31, 15:47
  2. error LNK2001: Please Help
    By sourish_khan in forum Symbian C++
    Replies: 9
    Last Post: 2006-04-19, 11:16
  3. S80 Platform SDK and Visual Studio .NET Linking Error
    By jayantjain in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2005-10-07, 22:14
  4. CEikDialog Question
    By AdamBeck in forum Symbian C++
    Replies: 2
    Last Post: 2004-09-30, 19:40
  5. Unresolved external symbols problem
    By georgica1979 in forum Symbian User Interface
    Replies: 1
    Last Post: 2003-04-06, 13:26

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •