×

Discussion Board

Results 1 to 8 of 8

Thread: Some Issues

  1. #1
    Registered User
    Join Date
    Feb 2007
    Location
    Tampere
    Posts
    370

    Exclamation Some Issues

    Hi,

    I ran into some issues when using QT(temple 4.4.4) on s60.

    Here they are,

    a) Not able to sign with my developer certificate.
    I am signing the sis file generated(by carbide 2.0) using signsis command on command prompt.

    b) Not able to kill the application from the Tasklist using "C" button.
    When ever I do a cancel, I get a dialog box asking whether I want to "Exit application". After selecting "yes" nothing happens.

    c) Screen size of the application does not fit into the device.
    I created a GUI widget with default settings and added few pushbuttons to it. And installed the application on phone. the buttons dont seem to fit into the window in "Portrait" mode. And when I swap to landscape mode the bottom edges are clipped.

    d) Launching of application is very slow
    I have just the stuff mentioned above in the application. But it seems it takes quiet a long time to exit out of application.

    I hope you can throw more light on how to fix these problems.
    Or is there something I have made really wrong!!

    Regards
    Regards

    - MVP
    "Dare To Dream" - A.P.J.Kalam

  2. #2
    Registered User
    Join Date
    Feb 2007
    Location
    Tampere
    Posts
    370

    Re: Some Issues

    Further Info:

    I am using E66 and 3.1 sdk
    Regards

    - MVP
    "Dare To Dream" - A.P.J.Kalam

  3. #3
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Some Issues

    You have to remember rhat Qt for S60 is in technology preview status so many things are not working or have not been implemented.

    a) What's the problem with signsis? Any errors at signing time or at install time? How did you installed the application on the phone if signing doesn't work.

    b) The exit command is probably not received/handled by Qt for S60.

    c) The widget size is probably hardcoded to some exotic values but you can of course dinamically change them.

    d) Performance improvements are/will of course be on the task list before product's official release.
    Last edited by ltomuta; 2009-01-20 at 14:40. Reason: added "size" for clarity at c)
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  4. #4
    Registered User
    Join Date
    Feb 2007
    Location
    Tampere
    Posts
    370

    Re: Some Issues

    Hi,

    Agreed its a technology preview. I was trying to find answers to issues I faced at the sametime give feedback about my experiences with using software.

    a) Problems with Signing
    There are no errors during signing.
    Here is the command I use
    signsis -s GUIWidget.sis GUIWidgetEx.sisx ..\..\rd.crt ..\..\rd.key
    I have disabled the signed application check to install the application. Initially I had secure Id, but have now reverted to unsecure(test) Id for the application.

    When I install signed application(With/without) secure Id I get error (Certificate Error- Contact Supplier)
    I am pretty sure the certificate is valid as I have been using it for one of my ongoing projects.

    c) Just ran it on emulator and it does not fit on emulator as well. Ok I will check how to fix this, since now I know its not a installation or somethg other stuff causing problem.
    Regards

    - MVP
    "Dare To Dream" - A.P.J.Kalam

  5. #5
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Some Issues

    On the installation issue, the frequent reason is KIS000451 - Installing self-signed SIS files to Nokia Eseries devices not allowed by default but since I understand you have fixed this and none of the other possible reasons developers have documented in the wiki seem to apply, I'm at a loss ...

    That part about the Secure ID is a bit confusing, you always have a SID whether you explicitly set it or not, but if that would have been an issue I would have expected different error message.

    Without having a look at the SIS file there's little to do about guessing the source of the problem.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  6. #6
    Registered User
    Join Date
    Feb 2007
    Location
    Tampere
    Posts
    370

    Re: Some Issues

    Hi,

    I am attaching the sis file. UID is 0xEBD0543D( which is not secure id)

    Regards

    Mrudul
    Attached Files Attached Files
    Regards

    - MVP
    "Dare To Dream" - A.P.J.Kalam

  7. #7
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Some Issues

    I had no problem installing this sis file self-signed on my N85. I'll see if I can find an E66 with that particular software version and have this tested on it too.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  8. #8
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Some Issues

    just in-case it works .
    1. Go to App Manager Application.
    2. Options->Settings.
    3. change [Software installation] from [Signed only] to [ALL]
    4. Try Installing again.

Similar Threads

  1. GCCE issues
    By apsaarin in forum Symbian Tools & SDKs
    Replies: 18
    Last Post: 2010-06-18, 13:13
  2. Reporting Known Issues is Now Easier than Ever
    By Nokia Ron in forum Tools and SDK Feedback (Closed)
    Replies: 0
    Last Post: 2007-09-20, 17:57
  3. N91 WiFi (WLAN) and Bluetooth Issues.
    By danscoop in forum General Development Questions
    Replies: 12
    Last Post: 2007-06-05, 20:07
  4. 3gp streaming issues
    By njahan in forum Streaming and Video
    Replies: 0
    Last Post: 2006-11-02, 19:05
  5. Series 60 graphics and sound issues
    By Teh_Architect in forum Mobile Java Media (Graphics & Sounds)
    Replies: 0
    Last Post: 2005-08-08, 11:03

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×