×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Oct 2008
    Posts
    25

    Unhappy Is this a BUG of CAknForm on S60 5th SDK.

    Hi guys

    I got a trouble of CAknForm on S60 5th SDK. My form has a bmp background, everything is ok on S60 3rd FP2, but the bmp background can not display normally on 5th. Every edit control or highlight has the background, but the whole form doesn't have.

    Code:
    CAknsItemDef* itemDef = AknsUtils::CreateBitmapItemDefL(KAknsIIDQsnBgAreaScreen, KMyBmpMbmFile, BmpIndex);
    AknsUtils::SkinInstance()->SetLocalItemDefL(itemDef);
    I think the code above can replace default background with my bmp when I draw it, actually the system just draws every form control and form highlight, on the rest where is white color filled in.

    Is it a BUG of 5th SDK?

    Thank you very much.

  2. #2
    Registered User
    Join Date
    Oct 2008
    Posts
    25

    Re: Is this a BUG of CAknForm on S60 5th SDK.

    I have fixed this problem, it is diffcult to say whether it is a bug or not. You can try this "KAknsIIDQsnBgAreaMainListGene" on 5th SDK.

    itemDef = AknsUtils::CreateBitmapItemDefL(KAknsIIDQsnBgAreaMainListGene, KMyBmpMbmFile, index);
    AknsUtils::SkinInstance()->SetLocalItemDefL(itemDef);

  3. #3
    Registered User
    Join Date
    Sep 2009
    Posts
    20

    Re: Is this a BUG of CAknForm on S60 5th SDK.

    Hi,

    I come back with the same problem:

    -> I load some .bmp images for my application and all works on S60 3rd SDK but on 5th SDK, my images are distort (colors are not the same)

    Here is an example of my code to load an image:

    Code:
    	cbOffBmp = new (ELeave) CFbsBitmap();
    	CleanupStack::PushL(cbOffBmp);
    	User::LeaveIfError(cbOffBmp->Load(filename,EMbmCheckboxoff));
    	CleanupStack::Pop();
    Any idea?
    Last edited by Darksshadow; 2009-09-10 at 16:35.

Similar Threads

  1. S60 5th Edition SDK, EMULATOR crashing
    By zoiks_guy in forum Symbian Tools & SDKs
    Replies: 4
    Last Post: 2009-01-16, 05:37
  2. S60 5th Ed. SDK v0.9 and Carbide.vs 3.01 Issue
    By Igor Pchelko in forum Tools and SDK Feedback (Closed)
    Replies: 1
    Last Post: 2009-01-06, 19:47
  3. SDK for S60 2nd FP2 (Nokia 6630) Java development?
    By SanjayKhuntia in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2008-08-27, 09:43
  4. What is going on with Vibration on S60?
    By amd_rikus in forum Mobile Java General
    Replies: 3
    Last Post: 2006-06-16, 00:29
  5. Almost all tools (S60 MIDP SDK B0.1, Nokia S60 SDK Symbian OS v0.3) Crashes
    By alexandershalamov in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2002-07-03, 13:44

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×