×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Regular Contributor
    Join Date
    Nov 2007
    Posts
    130

    Building problem in QT4.4.4

    Hi,

    I created a sample Hello program in QT as per given in GETTING STARTED WITH QT FOR S60 which is in
    http://wiki.forum.nokia.com/index.ph...ith_Qt_for_S60.

    i follwed the steps correctly.

    and when i build using armv5, showing error.

    cannot find file: E:\symbian\S60_5th_Edition_SDK_v0.9_3\epoc32\release\armv5\udeb\Hello.exe

    Can you help me with this...

    Thanks&Regards,
    Bala

  2. #2
    Regular Contributor
    Join Date
    Nov 2007
    Posts
    130

    Re: Building problem in QT4.4.4

    Hi,

    i am running the command prompt in administrator mode.. but still i get this error when running
    configure -platform win32-mwc -xplatform symbian-abld -qconfig symbian
    .......
    Running syncqt...
    Creating qmake...
    .....
    ....
    ....

    mwccsym2 -c -gccinc -stackcommit 1024000 -stackreserve 1024000 -O2 -w on -w nonotused -w nonotinlined -w noimplicit -w no
    padding -w noemptydecl -w nounusedexpr -Cpp_exceptions off -RTTI off -DUNICODE -DQT_NO_PROCESS -DQT_NO_SHAREDMEMORY -DQT_
    NO_CONCURRENT -DQT_NO_SYSTEMSEMAPHORE -DQT_EDITION=QT_EDITION_DESKTOP -DQT_BOOTSTRAPPED -DQT_RCC -DQT_LITE_UNICODE -DQT_N
    O_DATASTREAM -DQT_NO_THREAD -DQT_NO_QOBJECT -DQT_NO_UNICODETABLES -DQT_NO_LIBRARY -DQT_NO_SYSTEMLOCALE -DQT_NO_GEOM_VARIA
    NT -DQT_NO_CAST_FROM_ASCII -DQT_NO_CAST_TO_ASCII -DQT_NODLL -I"..\..\corelib\arch\generic" -I"..\..\..\include" -I"." -I"
    ..\..\..\include\QtCore" -I"..\..\..\include\QtXml" -I"..\..\xml" -I"." -I"." -I"..\..\..\mkspecs\win32-mwc" -o tmp\obj\r
    elease_shared\qbytearray.o ..\..\corelib\tools\qbytearray.cpp
    ### mwccsym2 Compiler:
    # File: ..\..\corelib\tools\qbytearray.cpp
    # -------------------------------------------
    # 50: #include <zlib.h>
    # Error: ^^^^^^^^
    # the file 'zlib.h' cannot be opened
    ### mwccsym2 Compiler:
    # 450: res = ::compress2((uchar*)bazip.data()+4, &len, (uchar*)data, nbytes, compressionLevel);
    # Error: ^^^^^^^^^
    # undefined identifier 'compress2'
    ### mwccsym2 Compiler:
    # 453: case Z_OK:
    # Error: ^^^^
    # undefined identifier 'Z_OK'
    ### mwccsym2 Compiler:
    # 460: case Z_MEM_ERROR:
    # Error: ^^^^^^^^^^^
    # undefined identifier 'Z_MEM_ERROR'
    ### mwccsym2 Compiler:
    # 464: case Z_BUF_ERROR:
    # Error: ^^^^^^^^^^^
    # undefined identifier 'Z_BUF_ERROR'
    ### mwccsym2 Compiler:
    # 468: } while (res == Z_BUF_ERROR);
    # Error: ^^^^^^^^^^^
    # undefined identifier 'Z_BUF_ERROR'
    ### mwccsym2 Compiler:
    # 523: res = ::uncompress((uchar*)baunzip.data(), &len,
    # Error: ^^^^^^^^^^
    # undefined identifier 'uncompress'
    ### mwccsym2 Compiler:
    # 524: (uchar*)data+4, nbytes-4);
    # Error: ^
    # call of non-function
    ### mwccsym2 Compiler:
    # 527: case Z_OK:
    # Error: ^^^^
    # undefined identifier 'Z_OK'
    ### mwccsym2 Compiler:
    # 531: case Z_MEM_ERROR:
    # Error: ^^^^^^^^^^^
    # undefined identifier 'Z_MEM_ERROR'
    ### mwccsym2 Compiler:
    # 534: case Z_BUF_ERROR:
    # Error: ^^^^^^^^^^^
    # undefined identifier 'Z_BUF_ERROR'
    ### mwccsym2 Compiler:
    # 537: case Z_DATA_ERROR:
    # Error: ^^^^^^^^^^^^
    # undefined identifier 'Z_DATA_ERROR'
    ### mwccsym2 Compiler:
    # 541: } while (res == Z_BUF_ERROR);
    # Error: ^^^^^^^^^^^
    # undefined identifier 'Z_BUF_ERROR'
    ### mwccsym2 Compiler:
    # 543: if (res != Z_OK)
    # Error: ^^^^
    # undefined identifier 'Z_OK'

    Errors caused tool to abort.
    make[1]: *** [tmp/obj/release_shared/qbytearray.o] Error 1
    make[1]: Leaving directory `E:/QT_FOR_SYMBIAN/src/tools/rcc'
    make: *** [release] Error 2
    Building src/tools/rcc failed, return code 2


    E:\QT_FOR_SYMBIAN>

    But if i give

    configure -platform win32-mwc -xplatform symbian-abld -qconfig symbian -D QT_NO_COMPRESS

    it doesn't show any error and builded properly, but when creating project in carbide it s showing cretion error... and also WINSCW option is not in build configuration of carbidec++..

    kindly help..

    Regards,
    Bala

  3. #3
    Nokia Developer Moderator
    Join Date
    Jan 2008
    Location
    Moscow, Russia
    Posts
    3,347

    Re: Building problem in QT4.4.4


  4. #4
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,335

    Re: Building problem in QT4.4.4

    Quote Originally Posted by A.A.M. View Post
    Rather this http://discussion.forum.nokia.com/fo...d.php?t=157014
    Nokia Developer Wiki Moderation team

  5. #5
    Nokia Developer Moderator
    Join Date
    Jan 2008
    Location
    Moscow, Russia
    Posts
    3,347

    Re: Building problem in QT4.4.4

    Quote Originally Posted by kiran10182 View Post
    Yes, of course. Thanks for the fix.

Similar Threads

  1. Help: Problem building 'Cheat Sheet' sample problem.
    By stevenc9 in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2008-08-21, 03:14
  2. Problem building gateway
    By schlunzi in forum Mobile Web Server
    Replies: 1
    Last Post: 2007-10-13, 19:42
  3. Problem while building jsp/servlet in j2me
    By sachinwarang in forum Mobile Java General
    Replies: 4
    Last Post: 2007-08-22, 12:08
  4. Example Icons not shown : Please help !
    By Mauro_Nokia in forum Symbian C++
    Replies: 4
    Last Post: 2006-07-07, 09:25
  5. Problem building BT examples
    By kiaong in forum Bluetooth Technology
    Replies: 1
    Last Post: 2003-04-30, 11:12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •