×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 19
  1. #1
    Regular Contributor
    Join Date
    Nov 2008
    Posts
    73

    Question Silent mode at Symbianc++

    Hi All;
    We need to make an application to convert mobile profile to silent mode at a certain time
    where we can find examples about it?
    and what is the required API to do this? and does it free or no??
    thanks in ad

  2. #2
    Nokia Developer Champion
    Join Date
    Jan 2008
    Location
    Moscow, Russia
    Posts
    3,348

    Re: Silent mode at Symbianc++

    You can do it with Profiles Engine API.

  3. #3
    Regular Contributor
    Join Date
    Nov 2008
    Posts
    113

    Re: Silent mode at Symbianc++

    Quote Originally Posted by A.A.M. View Post
    You can do it with Profiles Engine API.
    Okay... when I follow that link ,I added these lib and start to create an instance of MProfileEngine , but it gave me the following error

    Code:
     Undefined symbol: 'class MProfileEngine * CreateProfileEngineL(void) (?CreateProfileEngineL@@YAPAVMProfileEngine@@XZ)'
    Can any one tell me what is the problem???
    thanks in advance

  4. #4
    Nokia Developer Champion
    Join Date
    Jan 2008
    Location
    Moscow, Russia
    Posts
    3,348

    Re: Silent mode at Symbianc++

    Do you already have installed SDK API Plug-in for your version SDK as described in article?

    Link against
    profileeng.lib

    Capabilities required for activating new profile: WriteDeviceData
    Add this line to .mmp file:
    LIBRARY profileeng.lib
    Last edited by A.A.M.; 2009-02-03 at 14:07.

  5. #5
    Regular Contributor
    Join Date
    Nov 2008
    Posts
    113

    Re: Silent mode at Symbianc++

    Quote Originally Posted by A.A.M. View Post
    Do you already have installed SDK API Plug-in for your version SDK as described in article?


    Add this line to .mmp file:
    I've added it but the problem still exist :confused
    what can I do ????

  6. #6
    Nokia Developer Champion
    Join Date
    Jan 2008
    Location
    Moscow, Russia
    Posts
    3,348

    Re: Silent mode at Symbianc++

    1. Which version of SDK you are using?
    2. Do you already have installed SDK API Plug-in for your version SDK as described in article?

  7. #7
    Regular Contributor
    Join Date
    Nov 2008
    Posts
    113

    Re: Silent mode at Symbianc++

    Quote Originally Posted by A.A.M. View Post
    1. Which version of SDK you are using?
    2. Do you already have installed SDK API Plug-in for your version SDK as described in article?
    I've downloaded this zipped folder
    http://www.forum.nokia.com/info/sw.n...Pack1.zip.html
    and extracted ProfilesEngine and ProfilesEngineExtended putting them into Epoc32

    and install Extensions_plugin_S60_3rd_ed.exe
    is there anything else ????

  8. #8
    Nokia Developer Champion
    Join Date
    Jan 2008
    Location
    Moscow, Russia
    Posts
    3,348

    Re: Silent mode at Symbianc++

    Are you sure that you use S60 3rd ed. FP1 SDK?

    Also see example application attached to article - http://wiki.forum.nokia.com/index.ph...SampleCode.zip

  9. #9
    Regular Contributor
    Join Date
    Nov 2008
    Posts
    113

    Re: Silent mode at Symbianc++

    Quote Originally Posted by A.A.M. View Post
    Are you sure that you use S60 3rd ed. FP1 SDK?

    Also see example application attached to article - http://wiki.forum.nokia.com/index.ph...SampleCode.zip
    yes I'm sure of that ,
    and I've downloaded the sample code and try to build it it gave me the same error ,
    so can you tell me the ideal steps to Add API's to our project ?
    sorry for bother

  10. #10
    Nokia Developer Champion
    Join Date
    Jan 2008
    Location
    Moscow, Russia
    Posts
    3,348

    Re: Silent mode at Symbianc++

    Likely you are trying to build app for emulator (WINSCW), but this plug-in don't support this build configuration. Try to build Phone release configuration.

  11. #11
    Regular Contributor
    Join Date
    Nov 2008
    Posts
    113

    Re: Silent mode at Symbianc++

    Quote Originally Posted by A.A.M. View Post
    Likely you are trying to build app for emulator (WINSCW), but this plug-in don't support this build configuration. Try to build Phone release configuration.
    done and it worked well , thanks I really appreciate it

  12. #12
    Regular Contributor
    Join Date
    Nov 2008
    Posts
    113

    Re: Silent mode at Symbianc++

    Hi
    I've built application which display mobile profiles and set it to silent mode
    when I install it to mobile phone and call the form that display that it gave me an error which state it not worked for security reason , I certified it using free certificate for one mobile ,
    so can any one help me ??
    thanks a lot

  13. #13
    Nokia Developer Champion
    Join Date
    Jan 2008
    Location
    Moscow, Russia
    Posts
    3,348

    Re: Silent mode at Symbianc++

    Check capabilities of your project.
    Capabilities required for activating new profile: WriteDeviceData

  14. #14
    Regular Contributor
    Join Date
    Nov 2008
    Posts
    113

    Re: Silent mode at Symbianc++

    Quote Originally Posted by A.A.M. View Post
    Check capabilities of your project.
    Capabilities required for activating new profile: WriteDeviceData
    can you explain more :$ is that using coding or what ??
    and if by using coding can you give me a sample code for that??

    Thanks so much for your quick reply

  15. #15
    Nokia Developer Champion
    Join Date
    Jan 2008
    Location
    Moscow, Russia
    Posts
    3,348

    Re: Silent mode at Symbianc++

    Open .mmp file of your project ( <you_project_folder>\group\<project_name>.mmp ) and look for CAPABILITY statement.

    CAPABILITY WriteDeviceData
    For more information see MMP file syntax >> capability

Similar Threads

  1. How about a simple silent mode delay!!!
    By gsgriffin in forum General Development Questions
    Replies: 2
    Last Post: 2008-01-25, 02:04
  2. Replies: 3
    Last Post: 2007-03-30, 06:10
  3. bug playing MIDI in silent mode
    By hlynurjoh in forum Mobile Java Media (Graphics & Sounds)
    Replies: 1
    Last Post: 2005-09-20, 09:59
  4. detecting silent mode
    By jameswmohr in forum Mobile Java Media (Graphics & Sounds)
    Replies: 1
    Last Post: 2004-05-15, 08:58
  5. Any way to access the silent mode?
    By memosen80 in forum Symbian
    Replies: 0
    Last Post: 2003-09-06, 10:55

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×