×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Nov 2005
    Posts
    16

    gcc 4 linker error

    Hi,

    I'm trying to replace GCCE 3.4.3 with GCCE 4.3.2 on S60 3rd FP1_2 SDK to enable epocallowdlldata support. I've followed the instructions on this wiki but experiencing this problem during linking

    arm-none-symbianelf-ld -L"c:\program files\csl arm toolchain\bin\..\arm-none-symbianelf\lib" -L"c:\program files\csl arm toolchain\bin\..\lib\gcc\arm-none-sy
    fined -nostdlib -shared -Ttext 0x8000 -Tdata 0x400000 --default-symver -soname libpng{000a0000}[e000ff01].dll --entry _E32Dll -u _E32Dll \Symbian\9.2\S6
    LIB \
    -o "\Symbian\9.2\S60_3rd_FP1_2\EPOC32\BUILD\usr\src\cairo-for-symbian\build\LIBPNG\GCCE\UREL\libpng.dll" \
    -Map "\Symbian\9.2\S60_3rd_FP1_2\EPOC32\RELEASE\GCCE\UREL\libpng.dll.map" \
    \Symbian\9.2\S60_3rd_FP1_2\EPOC32\BUILD\usr\src\cairo-for-symbian\build\LIBPNG\GCCE\UREL\png.o \Symbian\9.2\S60_3rd_FP1_2\EPOC32\BUILD\usr\src\cairo-
    .o \Symbian\9.2\S60_3rd_FP1_2\EPOC32\BUILD\usr\src\cairo-for-symbian\build\LIBPNG\GCCE\UREL\pnggccrd.o \Symbian\9.2\S60_3rd_FP1_2\EPOC32\BUILD\usr\src\cairo-
    \Symbian\9.2\S60_3rd_FP1_2\EPOC32\BUILD\usr\src\cairo-for-symbian\build\LIBPNG\GCCE\UREL\pngmem.o \Symbian\9.2\S60_3rd_FP1_2\EPOC32\BUILD\usr\src\cairo-for-
    Symbian\9.2\S60_3rd_FP1_2\EPOC32\BUILD\usr\src\cairo-for-symbian\build\LIBPNG\GCCE\UREL\pngread.o \Symbian\9.2\S60_3rd_FP1_2\EPOC32\BUILD\usr\src\cairo-for-s
    bian\9.2\S60_3rd_FP1_2\EPOC32\BUILD\usr\src\cairo-for-symbian\build\LIBPNG\GCCE\UREL\pngrtran.o \Symbian\9.2\S60_3rd_FP1_2\EPOC32\BUILD\usr\src\cairo-for-sym
    bian\9.2\S60_3rd_FP1_2\EPOC32\BUILD\usr\src\cairo-for-symbian\build\LIBPNG\GCCE\UREL\pngset.o \Symbian\9.2\S60_3rd_FP1_2\EPOC32\BUILD\usr\src\cairo-for-symbi
    an\9.2\S60_3rd_FP1_2\EPOC32\BUILD\usr\src\cairo-for-symbian\build\LIBPNG\GCCE\UREL\pngvcrd.o \Symbian\9.2\S60_3rd_FP1_2\EPOC32\BUILD\usr\src\cairo-for-symbia
    9.2\S60_3rd_FP1_2\EPOC32\BUILD\usr\src\cairo-for-symbian\build\LIBPNG\GCCE\UREL\pngwrite.o \Symbian\9.2\S60_3rd_FP1_2\EPOC32\BUILD\usr\src\cairo-for-symbian\
    9.2\S60_3rd_FP1_2\EPOC32\BUILD\usr\src\cairo-for-symbian\build\LIBPNG\GCCE\UREL\pngwutil.o \
    \Symbian\9.2\S60_3rd_FP1_2\EPOC32\RELEASE\ARMV5\UREL\EDLLSTUB.lib -( \Symbian\9.2\S60_3rd_FP1_2\EPOC32\RELEASE\ARMV5\UREL\usrt2_2.lib -) \Symbian\9.2
    c.dso \Symbian\9.2\S60_3rd_FP1_2\EPOC32\RELEASE\ARMV5\LIB\libz.dso \Symbian\9.2\S60_3rd_FP1_2\EPOC32\RELEASE\ARMV5\LIB\libm.dso \Symbian\9.2\S60_3rd_FP1_2\EP
    n\9.2\S60_3rd_FP1_2\EPOC32\RELEASE\ARMV5\LIB\dfprvct2_2.dso \Symbian\9.2\S60_3rd_FP1_2\EPOC32\RELEASE\ARMV5\LIB\drtaeabi.dso \Symbian\9.2\S60_3rd_FP1_2\EPOC3
    .2\S60_3rd_FP1_2\EPOC32\RELEASE\ARMV5\LIB\drtrvct2_2.dso -lsupc++ -lgcc \


    Unhandled exception filter called from program make
    ExceptionCode = c0000005
    ExceptionFlags = 0
    ExceptionAddress = 416666
    Access violation: read operation at address 34
    make: *** [TARGETLIBPNG] Error 255
    make -r -f "\Symbian\9.2\S60_3rd_FP1_2\EPOC32\BUILD\usr\src\cairo-for-symbian\build\GCCE.make" FINAL CFG=UREL

    Anyone's seen this?

    cheers,
    iwanj

  2. #2
    Registered User
    Join Date
    Nov 2005
    Posts
    16

    Re: gcc 4 linker error

    solved now. it was caused by corrupted ld.exe.

  3. #3
    Registered User
    Join Date
    Nov 2008
    Posts
    28

    Re: gcc 4 linker error

    I've encountered the same error,
    It's hard to say what exactly was the cause, because after some restarts of my PC I managed to compile the code once more, and then it didn't work again.
    It didn't work with any of the SDK I have (3rd_MR, FP1, FP2, 5th...)
    nor different Carbide.C++ versions (2.6, 2.7)
    It failed with different projects.

    As I concluded it would be either the problem with corrupted executable or library in the toolchain, I did two things:
    Uninstalled Perl and installed it again (5.6.1, preferably on c: drive),
    Checked my Path variable and removed obsolete paths (also Cygwin which I don't use anymore, but it had some similar tools).

    I also tried to update the GCC compiler, but that didn't help much, and brought lots of new compilation errors, so I'd discourage that.

    For now it works properly...

  4. #4
    Registered User
    Join Date
    Mar 2005
    Posts
    3

    Re: gcc 4 linker error

    Hi,
    For the past few days even I have also started getting same error all of a sudden. After reboot I can compile properly only 2-3 times, but after that due to above issue my build fails and need to reboot again.
    To address this,
    a. I deleted / uninstalled all apps which has ld.exe including that of CSL Tool chain, Carbide, MINGW (I had in my PC), etc
    b. Uninstalled ActivePerl, Carbide and all Symbian SDKs
    c. again reinstalled Activeperl, Carbide and S60 3rd Ed.
    But after done with all these and after couple of trials again I am getting the same issue. Iwanj, can you please let me know if this is the issue with ld.exe, how to replace / rectify it. Any hint will be appreciated alot.

  5. #5
    Registered User
    Join Date
    Mar 2011
    Posts
    30

    Re: gcc 4 linker error

    Has anyone found a solution to this???? This is really impacting my development and I tried the things already mentioned but they didn't work.
    I am using Windows 7 64-bit. Don't know if that matters or not.

Similar Threads

  1. error including vector
    By Lichtens in forum Open C/C++
    Replies: 5
    Last Post: 2009-04-03, 14:19
  2. Browser monitoring
    By NevePankaj in forum Symbian
    Replies: 19
    Last Post: 2008-08-12, 10:06
  3. CEikDialog Question
    By AdamBeck in forum Symbian
    Replies: 2
    Last Post: 2004-09-30, 19:40
  4. how to avoid linking error
    By skdas in forum Symbian
    Replies: 6
    Last Post: 2003-07-07, 07:57

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×