×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Feb 2009
    Posts
    2

    SDK verification problems

    Hi,

    I just installed S60 5th_Edition SDK v0.9 and now I'm following the verification steps in the included guide. The first task is compiling and running the hello world application. The "bldmake bldfiles" generates some make files for the application + abld.bat (this seems to be correct). However the "abld build" command generates the "Nothing to do" message and no new output files are produced. Naturally, I can't continue starting the application in the simulator...

    Another guide suggests using "abld build winscw udeb". If I compile with this command I no longer get the previous message, just a lot of output info, though no clear errors/warnings. However I still can't find the example application on the emulator.

    Any ideas?
    Thanks
    Last edited by MihaiD; 2009-02-07 at 15:40.

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: SDK verification problems

    Welcome to the Discussion board, glad to see people who still like doing it command line, it used to be the way really, but nowadays we do have rather nice IDEs, so if you want to make it easier, you could try Carbide C++ IDE, its free and rather nice already.

    Also, if you want to try it comamnd line, check with devices that you have the correct SDK as default one, then try again bldmake bldfiles, and then try the build with full syntax, like "abld build winscw udeb" and maybe it works better.

  3. #3
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: SDK verification problems

    Before using the Nokia C/C++ compiler in command line (that's what abld build amounts to eventually) you have to configure it for command line use.

    When installing Carbide.c++ a note is displayed telling you how to enable command line builds: look for the "Configure environment for WINSCW command line" shortcut under Start -> Programs -> Carbide.c++ 2.0

    Also, see the starting tutorial linked in my signature, it has a more complete SDK install verification guide.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  4. #4
    Registered User
    Join Date
    Feb 2009
    Posts
    2

    Re: SDK verification problems

    OK, problem solved. Thanks for the quick reply

Similar Threads

  1. SDK Installation problems (wrong drive) S60 3rd
    By Jeepy in forum Symbian Tools & SDKs
    Replies: 6
    Last Post: 2007-03-12, 21:59
  2. SDK Installation/Verification Problems
    By beoweulf in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2006-12-22, 05:33
  3. 7710 SDK emulator browser problems
    By kipokipo in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2005-04-20, 12:49
  4. SDK 3.0 Problems
    By pxc433 in forum General Messaging
    Replies: 1
    Last Post: 2004-09-15, 15:26
  5. Nokia Series 60 SDK 2.0 Comms problems
    By lewisf in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2004-05-04, 11:19

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×