×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 18
  1. #1
    Regular Contributor
    Join Date
    Jan 2007
    Location
    Bangalore
    Posts
    285

    CCamera: StartViewFinderBitmapsL leaves on N96

    Hi All,
    I have written a Camera Application that captures images in JPEG format. The Application works fine on all devices Except N96.
    N96 is Symbian 9.3 FP2 Device. But so is N79 , N85, N78 etc. It works fine on N79, N78 & N85. Also on N95,E51, E71 etc.

    I have found that the Camera Engine leaves when StartViewFinderBitmapsL() Method is called from PowerOnComplete().
    It Leaves with message "Feature Not Supported"
    The Format that i am using to capture image is CCamera::EFormatExif.
    Is this format not supported on N96??
    I have personally tested this App on some phones like N78, N95, E71 etc. However i tested on N96 using RDA Service provided by nokia. I also observed the in built camera App on N96(in RDA) does not function properly.

    Does anyone know the reason why the My App leave only on N96???
    Regards
    Shashi Kiran G M

  2. #2
    Registered User
    Join Date
    Dec 2006
    Posts
    2,280

    Re: CCamera: StartViewFinderBitmapsL leaves on N96

    Hi,

    In what way does the built-in camera app in the N96 on the RDA service "not function properly". Does the viewfinder work?

    Your capture format should be completely irrelevant for starting viewfinder bitmaps.

    I think there are some quirks/differences from other FP2 devices in the N96 camera implementation but the basics should work.

    The built-in camera app also works fine on my N96. If you want to send me an appropriately signed SIS file then I could do a quick test in my N96 for you?

    Sorcery

  3. #3
    Regular Contributor
    Join Date
    Apr 2004
    Posts
    96

    Re: CCamera: StartViewFinderBitmapsL leaves on N96

    IIRC my viewfinder app was working on the N96.

  4. #4
    Regular Contributor
    Join Date
    Jan 2007
    Location
    Bangalore
    Posts
    285

    Re: CCamera: StartViewFinderBitmapsL leaves on N96

    I built my Camera App for 3rd Edition devices . The Format that i use is EFormatExif i.e JPEG
    It is a format that must be supported on all 3rd edition devices atleast i beleive.
    Anyways thanks for ur concern sorcery. Ill get back to you in a short while
    Regards
    Shashi Kiran G M

  5. #5
    Regular Contributor
    Join Date
    Jan 2007
    Location
    Bangalore
    Posts
    285

    Re: CCamera: StartViewFinderBitmapsL leaves on N96

    Hi Sorcery can i have ur personal mail-id so that i can send my installer file to you.
    Regards
    Shashi Kiran G M

  6. #6
    Registered User
    Join Date
    Dec 2006
    Posts
    2,280

    Re: CCamera: StartViewFinderBitmapsL leaves on N96

    Sorry to say your application also gives "feature not supported" on my N96. I suggested a possible issue in a personal email response. Hope you can work it out.

    Mark

  7. #7
    Regular Contributor
    Join Date
    Jan 2007
    Location
    Bangalore
    Posts
    285

    Re: CCamera: StartViewFinderBitmapsL leaves on N96

    Thanks a lot for the help Mark. I am looking into possible solutions. If i do find something ill keep you updated; also this post
    ;-)
    Regards
    Shashi Kiran G M

  8. #8
    Regular Contributor
    Join Date
    Jan 2007
    Location
    Bangalore
    Posts
    285

    Re: CCamera: StartViewFinderBitmapsL leaves on N96

    Hi All,
    Finally the solution:
    The API Call CCamera::StartViewFinderBitmapsL(TSize aSize); would leave on some devices if aSize values are more than what the device supports.
    In My App the aSize value was 640x320. N96 doesn't support this resolution hence the call leaves
    {Funny y this was not mentioned in the documentation}

    Now i am calculating size as follows TSize aSize = Rect().Size();//This works

    A Special mention of thanks to sorcery without whose invaluable help the issue would not have been resolved.
    Regards
    Shashi Kiran G M

  9. #9
    Registered User
    Join Date
    Jun 2008
    Posts
    7

    Re: CCamera: StartViewFinderBitmapsL leaves on N96

    Hello,

    I am trying to use N96 Camera, in my application.
    `CCamera::StartViewFinderBitmapsL' leaves with error value `-5’
    I tried the TSize values:
    2592 x 1944 , 2048 x 1536 , 1600 x 1200 , 1280 x 960 , 640 x 480
    Which are suppoerted by N96 (TCameraInfo::EnumerateCaptureSizes), but couldn't succeed.

    For the value, 320 x 240
    TRAPD( err, iCamera->StartViewFinderBitmapsL ( TSize(320, 240) );
    err value = 0, but the function `ViewFinderFrameReady’ is not getting called.

    Any suggestion?
    Thanks in advance.
    P.S. my application works fine for all FP2 devices.

  10. #10
    Registered User
    Join Date
    Dec 2006
    Posts
    2,280

    Re: CCamera: StartViewFinderBitmapsL leaves on N96

    The enumerated capture sizes are for CAPTURE only, not viewfinder frames. If other devices don't give an error when you request these sizes it is just the implementation being flexible (and probably giving you the largest size it does support instead).

    320x240 should work fine. For the frames not being recieved check what camera observer you're using. This does work correctly on the N96, I've tried gmsk19's app on my N96 and seen it with my own eyes.

    Mark

  11. #11
    Registered User
    Join Date
    Jun 2008
    Posts
    7

    Re: CCamera: StartViewFinderBitmapsL leaves on N96

    Thanks.

    I was able to launch Camera successfully on N96, with `MCameraObserver'.

    Q: How to support autofocus in N96?

    Any clues?

    It is also unanswered question for the thread:
    http://discussion.forum.nokia.com/fo...d.php?t=152427

  12. #12
    Registered User
    Join Date
    Mar 2009
    Posts
    8

    Re: CCamera: StartViewFinderBitmapsL leaves on N96

    Hello for all,

    Is there any possible way to turn light (LED) on the N96 while using the StartViewFinderBitmapsL?

    That you all for help.

    Pierre

  13. #13
    Registered User
    Join Date
    Jul 2009
    Posts
    2

    Re: CCamera: StartViewFinderBitmapsL leaves on N96

    can anyone please mail me Ccamera to
    21stjun@gmail.com

  14. #14
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,738

    Re: CCamera: StartViewFinderBitmapsL leaves on N96

    CCamera is a built-in API, part of the SDK-s for many years.

  15. #15
    Registered User
    Join Date
    Jul 2009
    Posts
    2

    Re: CCamera: StartViewFinderBitmapsL leaves on N96

    actually i use a N79 and i dont have any ccamera software preinstalled.

Similar Threads

  1. N96 + CCamera + +Autofocus
    By jascco in forum Symbian Media (Closed)
    Replies: 15
    Last Post: 2009-06-03, 13:37
  2. C++ exceptions VS Symbian Leaves :)
    By metalim in forum Symbian
    Replies: 18
    Last Post: 2009-04-15, 11:54
  3. Access Point Connection Problem on N96... Help!
    By asenechalM5T in forum Symbian Networking & Messaging (Closed)
    Replies: 4
    Last Post: 2008-11-17, 15:00
  4. CCamera dosen't work in an own thread?
    By NevenS in forum Symbian Media (Closed)
    Replies: 3
    Last Post: 2008-10-14, 17:51
  5. About leaves on HTTP API.
    By kosjanne in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2005-04-15, 07:41

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×