×

Discussion Board

Results 1 to 9 of 9
  1. #1
    Registered User
    Join Date
    Jul 2007
    Posts
    26

    Question [moved] Unsupported platform GCCE specified

    Hi,

    I'm trying to build sample application from
    "C:\Symbian\9.1\S60_3rd\Examples\AppProts\exampleclient".

    It builds fine on emulator.

    I'm getting the following build error when I try to build for device.

    \Symbian\9.1\S60_3rd\Examples\AppProts\exampleclient\BLD.INF FATAL ERROR(S):
    \Symbian\9.1\S60_3rd\Examples\AppProts\exampleclient\BLD.INF(7) : Unsupported platform GCCE specified

    Added the line
    PRJ_PLATFORMS
    GCCE WINSCW
    to the .mmp file. Still getting the error.

    Could someone tell me how to fix this? Or my SDK installation is corrupted?

    Thanks,
    jvin

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Unsupported platform GCCE specified

    You should use the S60 3rd Edition MR (Maintenance Release). Also, make sure to install the GCCE compiler, the SDK installation prompts you to do this but you can also do it at a later time.

    See yesterday's useful link in my signature for a guide on how to test the installed tools.

    Also, you may want to try first the S60 examples (\S60Ex) and only when you are convinced that you master the SDK you can try the less user friendly Symbian examples from \Examples

    Finally, this is not an networking issue, it's an SDK and Tools issue and should be posted in the appropriate forum. (I'm moving the thread there)
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  3. #3
    Registered User
    Join Date
    Jul 2007
    Posts
    26

    Re: [moved] Unsupported platform GCCE specified

    Hi,

    Are you talking about this link?
    http://wiki.forum.nokia.com/index.ph..._Symbian_OS%3F

    I checked everything. Only difference is I'm using S60_3rd, not S60_3rd MR. I'm going to install that and try.

    I had another issue in networking. I was checking under Networking section.
    Forgot to change the forum and posted the new thread. Sorry about that.

    Thanks,
    jvin

  4. #4
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: [moved] Unsupported platform GCCE specified

    No problem really, is just that posting in the relevant forum helps you find the answer faster and also helps other find a solution later.

    So you have the GCCE compiler installed and the proper path set yet you are still getting that error. Interesting ...
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  5. #5
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: [moved] Unsupported platform GCCE specified

    Quote Originally Posted by jvinjam View Post
    ...
    Added the line
    PRJ_PLATFORMS
    GCCE WINSCW
    to the .mmp file. ...
    I hope you have the above statement in the bld.inf file and not in the *.mmp, as in fact the error message also suggests. Moving it to the MMP files is not a valid solution
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  6. #6
    Registered User
    Join Date
    Jul 2007
    Posts
    26

    Re: [moved] Unsupported platform GCCE specified

    Yes, that's right. In bld.inf file.
    Sorry. :-)

  7. #7
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,672

    Re: [moved] Unsupported platform GCCE specified

    Missing CSL installation usually results in other kind of problems (compiler turns out to be missing when the toolchain tries to call it). "Unsupported platform GCCE" rather suggests that you are using a 2nd edition SDK for some reason.

  8. #8
    Registered User
    Join Date
    Jul 2007
    Posts
    26

    Re: [moved] Unsupported platform GCCE specified

    I installed S60 3rd Edition MR. That fixed the problem.

    Thanks,
    jvin

  9. #9
    Registered User
    Join Date
    Nov 2009
    Posts
    4

    Re: [moved] Unsupported platform GCCE specified

    I had the same problem. But I solved it by setting the EPOCROOT properly.

    The EPOCROOT was earlier been set to \S60\devices\S60_3rd_FP2_SDK_v1.1\epoc32. With this path the build command "make debug-winscw" use to give error message "Unsupported platform GCCE specified". When I changed the EPOCROOT to \S60\devices\S60_3rd_FP2_SDK_v1.1\ (without specifying epoc32) then the problem got solved :)

Similar Threads

  1. [moved] HELP! Phone Debug (GCCE)
    By joseph.m in forum Symbian
    Replies: 18
    Last Post: 2008-07-14, 10:42
  2. [Moved] Need Help - Beginner in Symbian Platform
    By voidmain123 in forum Symbian Media (Closed)
    Replies: 2
    Last Post: 2008-05-19, 11:17
  3. Error with makesis.exe and creating the .pkg file
    By gramya87 in forum Symbian Tools & SDKs
    Replies: 7
    Last Post: 2007-10-10, 13:53
  4. Unsupported platform GCCE specified
    By jdw in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2007-06-04, 12:22

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×